summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason A. Donenfeld <zx2c4@gentoo.org>2021-11-17 00:30:13 +0100
committerJason A. Donenfeld <zx2c4@gentoo.org>2021-11-17 00:33:44 +0100
commit876602ee223c6c4225371b428a346f0b2d7f2020 (patch)
treed95ec63e84dd3db8143dd226d21d920d8cbf8511 /sys-libs/glibc
parentprofiles: enable new ppc(32) basic profiles (diff)
downloadgentoo-876602ee223c6c4225371b428a346f0b2d7f2020.tar.gz
gentoo-876602ee223c6c4225371b428a346f0b2d7f2020.tar.bz2
gentoo-876602ee223c6c4225371b428a346f0b2d7f2020.zip
sys-libs/glibc: add -mno-avx512f to -m32 build for gcc 11 bug
No need to revbump as this only affects folks who cannot currently compile. Closes: https://bugs.gentoo.org/823780 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Jason A. Donenfeld <zx2c4@gentoo.org>
Diffstat (limited to 'sys-libs/glibc')
-rw-r--r--sys-libs/glibc/glibc-2.34-r2.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/sys-libs/glibc/glibc-2.34-r2.ebuild b/sys-libs/glibc/glibc-2.34-r2.ebuild
index 4510d31aeb66..00c85cf62a55 100644
--- a/sys-libs/glibc/glibc-2.34-r2.ebuild
+++ b/sys-libs/glibc/glibc-2.34-r2.ebuild
@@ -326,6 +326,14 @@ setup_target_flags() {
export CFLAGS_x86="${CFLAGS_x86} -march=${t}"
einfo "Auto adding -march=${t} to CFLAGS_x86 #185404 (ABI=${ABI})"
fi
+
+ # Workaround for https://bugs.gentoo.org/823780. This really should
+ # be removed when the upstream bug https://gcc.gnu.org/bugzilla/show_bug.cgi?id=103275
+ # is fixed in our tree, either via 11.3 or an 11.2p2 patch set.
+ if [[ ${ABI} == x86 ]] && tc-is-gcc && (($(gcc-major-version) == 11)) && (($(gcc-minor-version) < 3)); then
+ export CFLAGS_x86="${CFLAGS_x86} -mno-avx512f"
+ einfo "Auto adding -mno-avx512f to CFLAGS_x86 #823780 (ABI=${ABI})"
+ fi
;;
mips)
# The mips abi cannot support the GNU style hashes. #233233