summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2019-08-04 02:12:16 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2019-08-04 02:12:44 +0200
commitfb3ccd285e5a9580e778a1a60ead30221c407dbe (patch)
treebc1cdb836ded488774f7485403457d1128b41460 /sys-libs/glibc
parentnet-libs/libmicrohttpd: drop older stable version (diff)
downloadgentoo-fb3ccd285e5a9580e778a1a60ead30221c407dbe.tar.gz
gentoo-fb3ccd285e5a9580e778a1a60ead30221c407dbe.tar.bz2
gentoo-fb3ccd285e5a9580e778a1a60ead30221c407dbe.zip
sys-libs/glibc: Pass missing parameter to locale-gen
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'sys-libs/glibc')
-rw-r--r--sys-libs/glibc/glibc-2.30.ebuild13
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild13
2 files changed, 20 insertions, 6 deletions
diff --git a/sys-libs/glibc/glibc-2.30.ebuild b/sys-libs/glibc/glibc-2.30.ebuild
index 2d1e13c28ace..9bdb5a434c82 100644
--- a/sys-libs/glibc/glibc-2.30.ebuild
+++ b/sys-libs/glibc/glibc-2.30.ebuild
@@ -1141,16 +1141,23 @@ src_test() {
run_locale_gen() {
# if the host locales.gen contains no entries, we'll install everything
local root="$1"
+ local inplace=""
+
+ if [[ ${root}=="--inplace-glibc" ]] ; then
+ inplace="--inplace-glibc"
+ root="$2"
+ fi
+
local locale_list="${root}/etc/locale.gen"
pushd "${ED}"/$(get_libdir)
if [[ -z $(locale-gen --list --config "${locale_list}") ]] ; then
- ewarn "Generating all locales; edit /etc/locale.gen to save time/space"
+ [[ -z ${inplace} ]] && ewarn "Generating all locales; edit /etc/locale.gen to save time/space"
locale_list="${root}/usr/share/i18n/SUPPORTED"
fi
- locale-gen --jobs $(makeopts_jobs) --config "${locale_list}" \
+ locale-gen ${inplace} --jobs $(makeopts_jobs) --config "${locale_list}" \
--destdir "${root}"
popd
@@ -1337,7 +1344,7 @@ glibc_do_src_install() {
# Generate all locales if this is a native build as locale generation
if use compile-locales && ! is_crosscompile ; then
- run_locale_gen "${ED}"
+ run_locale_gen --inplace-glibc "${ED}"
sed -e 's:COMPILED_LOCALES="":COMPILED_LOCALES="1":' -i "${ED}"/usr/sbin/locale-gen || die
fi
}
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index 4d0a9edb57a0..c9d06b204994 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -1141,16 +1141,23 @@ src_test() {
run_locale_gen() {
# if the host locales.gen contains no entries, we'll install everything
local root="$1"
+ local inplace=""
+
+ if [[ ${root}=="--inplace-glibc" ]] ; then
+ inplace="--inplace-glibc"
+ root="$2"
+ fi
+
local locale_list="${root}/etc/locale.gen"
pushd "${ED}"/$(get_libdir)
if [[ -z $(locale-gen --list --config "${locale_list}") ]] ; then
- ewarn "Generating all locales; edit /etc/locale.gen to save time/space"
+ [[ -z ${inplace} ]] && ewarn "Generating all locales; edit /etc/locale.gen to save time/space"
locale_list="${root}/usr/share/i18n/SUPPORTED"
fi
- locale-gen --jobs $(makeopts_jobs) --config "${locale_list}" \
+ locale-gen ${inplace} --jobs $(makeopts_jobs) --config "${locale_list}" \
--destdir "${root}"
popd
@@ -1337,7 +1344,7 @@ glibc_do_src_install() {
# Generate all locales if this is a native build as locale generation
if use compile-locales && ! is_crosscompile ; then
- run_locale_gen "${ED}"
+ run_locale_gen --inplace-glibc "${ED}"
sed -e 's:COMPILED_LOCALES="":COMPILED_LOCALES="1":' -i "${ED}"/usr/sbin/locale-gen || die
fi
}