summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-libs/itx-bind
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-libs/itx-bind')
-rw-r--r--sys-libs/itx-bind/files/weak.s304
-rw-r--r--sys-libs/itx-bind/itx-bind-0.1-r2.ebuild93
-rw-r--r--sys-libs/itx-bind/metadata.xml13
3 files changed, 410 insertions, 0 deletions
diff --git a/sys-libs/itx-bind/files/weak.s b/sys-libs/itx-bind/files/weak.s
new file mode 100644
index 000000000000..9efa9622af4e
--- /dev/null
+++ b/sys-libs/itx-bind/files/weak.s
@@ -0,0 +1,304 @@
+.extern ___fp_nquery
+.global _fp_nquery
+_fp_nquery:
+ jmp ___fp_nquery
+.extern ___fp_query
+.global _fp_query
+_fp_query:
+ jmp ___fp_query
+.extern ___hostalias
+.global _hostalias
+_hostalias:
+ jmp ___hostalias
+.extern ___p_query
+.global _p_query
+_p_query:
+ jmp ___p_query
+.extern ___res_close
+.global _res_close
+_res_close:
+ jmp ___res_close
+.extern ___res_init
+.global _res_init
+_res_init:
+ jmp ___res_init
+.extern ___res_isourserver
+.global _res_isourserver
+_res_isourserver:
+ jmp ___res_isourserver
+.extern ___res_mkquery
+.global _res_mkquery
+_res_mkquery:
+ jmp ___res_mkquery
+.extern ___res_query
+.global _res_query
+_res_query:
+ jmp ___res_query
+.extern ___res_querydomain
+.global _res_querydomain
+_res_querydomain:
+ jmp ___res_querydomain
+.extern ___res_search
+.global _res_search
+_res_search:
+ jmp ___res_search
+.extern ___res_send
+.global _res_send
+_res_send:
+ jmp ___res_send
+.extern ___res_sendsigned
+.global _res_sendsigned
+_res_sendsigned:
+ jmp ___res_sendsigned
+.extern ___b64_ntop
+.global _b64_ntop
+_b64_ntop:
+ jmp ___b64_ntop
+.extern ___b64_pton
+.global _b64_pton
+_b64_pton:
+ jmp ___b64_pton
+.extern ___dn_comp
+.global _dn_comp
+_dn_comp:
+ jmp ___dn_comp
+.extern ___dn_count_labels
+.global _dn_count_labels
+_dn_count_labels:
+ jmp ___dn_count_labels
+.extern ___dn_expand
+.global _dn_expand
+_dn_expand:
+ jmp ___dn_expand
+.extern ___dn_skipname
+.global _dn_skipname
+_dn_skipname:
+ jmp ___dn_skipname
+.extern ___fp_resstat
+.global _fp_resstat
+_fp_resstat:
+ jmp ___fp_resstat
+.extern ___loc_aton
+.global _loc_aton
+_loc_aton:
+ jmp ___loc_aton
+.extern ___loc_ntoa
+.global _loc_ntoa
+_loc_ntoa:
+ jmp ___loc_ntoa
+.extern ___p_cdname
+.global _p_cdname
+_p_cdname:
+ jmp ___p_cdname
+.extern ___p_cdnname
+.global _p_cdnname
+_p_cdnname:
+ jmp ___p_cdnname
+.extern ___p_class
+.global _p_class
+_p_class:
+ jmp ___p_class
+.extern ___p_fqname
+.global _p_fqname
+_p_fqname:
+ jmp ___p_fqname
+.extern ___p_fqnname
+.global _p_fqnname
+_p_fqnname:
+ jmp ___p_fqnname
+.extern ___p_option
+.global _p_option
+_p_option:
+ jmp ___p_option
+.extern ___p_secstodate
+.global _p_secstodate
+_p_secstodate:
+ jmp ___p_secstodate
+.extern ___p_section
+.global _p_section
+_p_section:
+ jmp ___p_section
+.extern ___p_time
+.global _p_time
+_p_time:
+ jmp ___p_time
+.extern ___p_type
+.global _p_type
+_p_type:
+ jmp ___p_type
+.extern ___p_rcode
+.global _p_rcode
+_p_rcode:
+ jmp ___p_rcode
+.extern ___p_sockun
+.global _p_sockun
+_p_sockun:
+ jmp ___p_sockun
+.extern ___putlong
+.global _putlong
+_putlong:
+ jmp ___putlong
+.extern ___putshort
+.global _putshort
+_putshort:
+ jmp ___putshort
+.extern ___res_dnok
+.global _res_dnok
+_res_dnok:
+ jmp ___res_dnok
+.extern ___res_findzonecut
+.global _res_findzonecut
+_res_findzonecut:
+ jmp ___res_findzonecut
+.extern ___res_findzonecut2
+.global _res_findzonecut2
+_res_findzonecut2:
+ jmp ___res_findzonecut2
+.extern ___res_hnok
+.global _res_hnok
+_res_hnok:
+ jmp ___res_hnok
+.extern ___res_hostalias
+.global _res_hostalias
+_res_hostalias:
+ jmp ___res_hostalias
+.extern ___res_mailok
+.global _res_mailok
+_res_mailok:
+ jmp ___res_mailok
+.extern ___res_nameinquery
+.global _res_nameinquery
+_res_nameinquery:
+ jmp ___res_nameinquery
+.extern ___res_nclose
+.global _res_nclose
+_res_nclose:
+ jmp ___res_nclose
+.extern ___res_ninit
+.global _res_ninit
+_res_ninit:
+ jmp ___res_ninit
+.extern ___res_nmkquery
+.global _res_nmkquery
+_res_nmkquery:
+ jmp ___res_nmkquery
+.extern ___res_pquery
+.global _res_pquery
+_res_pquery:
+ jmp ___res_pquery
+.extern ___res_nquery
+.global _res_nquery
+_res_nquery:
+ jmp ___res_nquery
+.extern ___res_nquerydomain
+.global _res_nquerydomain
+_res_nquerydomain:
+ jmp ___res_nquerydomain
+.extern ___res_nsearch
+.global _res_nsearch
+_res_nsearch:
+ jmp ___res_nsearch
+.extern ___res_nsend
+.global _res_nsend
+_res_nsend:
+ jmp ___res_nsend
+.extern ___res_nsendsigned
+.global _res_nsendsigned
+_res_nsendsigned:
+ jmp ___res_nsendsigned
+.extern ___res_ownok
+.global _res_ownok
+_res_ownok:
+ jmp ___res_ownok
+.extern ___res_queriesmatch
+.global _res_queriesmatch
+_res_queriesmatch:
+ jmp ___res_queriesmatch
+.extern ___res_randomid
+.global _res_randomid
+_res_randomid:
+ jmp ___res_randomid
+.extern ___sym_ntop
+.global _sym_ntop
+_sym_ntop:
+ jmp ___sym_ntop
+.extern ___sym_ntos
+.global _sym_ntos
+_sym_ntos:
+ jmp ___sym_ntos
+.extern ___sym_ston
+.global _sym_ston
+_sym_ston:
+ jmp ___sym_ston
+.extern ___res_nopt
+.global _res_nopt
+_res_nopt:
+ jmp ___res_nopt
+.extern ___res_ndestroy
+.global _res_ndestroy
+_res_ndestroy:
+ jmp ___res_ndestroy
+.extern ___res_nametoclass
+.global _res_nametoclass
+_res_nametoclass:
+ jmp ___res_nametoclass
+.extern ___res_nametotype
+.global _res_nametotype
+_res_nametotype:
+ jmp ___res_nametotype
+.extern ___res_setservers
+.global _res_setservers
+_res_setservers:
+ jmp ___res_setservers
+.extern ___res_getservers
+.global _res_getservers
+_res_getservers:
+ jmp ___res_getservers
+.extern ___res_buildprotolist
+.global _res_buildprotolist
+_res_buildprotolist:
+ jmp ___res_buildprotolist
+.extern ___res_destroyprotolist
+.global _res_destroyprotolist
+_res_destroyprotolist:
+ jmp ___res_destroyprotolist
+.extern ___res_destroyservicelist
+.global _res_destroyservicelist
+_res_destroyservicelist:
+ jmp ___res_destroyservicelist
+.extern ___res_get_nibblesuffix
+.global _res_get_nibblesuffix
+_res_get_nibblesuffix:
+ jmp ___res_get_nibblesuffix
+.extern ___res_get_nibblesuffix2
+.global _res_get_nibblesuffix2
+_res_get_nibblesuffix2:
+ jmp ___res_get_nibblesuffix2
+.extern ___res_ourserver_p
+.global _res_ourserver_p
+_res_ourserver_p:
+ jmp ___res_ourserver_p
+.extern ___res_protocolname
+.global _res_protocolname
+_res_protocolname:
+ jmp ___res_protocolname
+.extern ___res_protocolnumber
+.global _res_protocolnumber
+_res_protocolnumber:
+ jmp ___res_protocolnumber
+.extern ___res_send_setqhook
+.global _res_send_setqhook
+_res_send_setqhook:
+ jmp ___res_send_setqhook
+.extern ___res_send_setrhook
+.global _res_send_setrhook
+_res_send_setrhook:
+ jmp ___res_send_setrhook
+.extern ___res_servicename
+.global _res_servicename
+_res_servicename:
+ jmp ___res_servicename
+.extern ___res_servicenumber
+.global _res_servicenumber
+_res_servicenumber:
+ jmp ___res_servicenumber
diff --git a/sys-libs/itx-bind/itx-bind-0.1-r2.ebuild b/sys-libs/itx-bind/itx-bind-0.1-r2.ebuild
new file mode 100644
index 000000000000..4a414b3b1b9c
--- /dev/null
+++ b/sys-libs/itx-bind/itx-bind-0.1-r2.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit toolchain-funcs
+
+DESCRIPTION="the bind library for interix"
+HOMEPAGE="http://dev.gentoo.org/~mduft"
+SRC_URI=""
+
+LICENSE="ISC BSD-4"
+SLOT="0"
+KEYWORDS="-* ~x86-interix"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_install() {
+ # scratch together the pieces of the bind installation from all over the
+ # place on different interix systems, and copy the files to the local
+ # prefix installation.
+
+ if [[ -d /usr/local/bind ]]; then
+ # layout as of vista onwards.
+ local incdir="/usr/local/bind/include"
+ local libdir="/usr/local/lib/bind"
+ else
+ # layout of xp and server 2003
+ local incdir="/usr/local/include/bind"
+ local libdir="/usr/local/lib/bind"
+
+ # windows xp has a silly bug in the installer it seems:
+ [[ -x "${incdir}/sys" ]] || chmod a+x "${incdir}/sys"
+ fi
+
+ insinto /usr/include/bind
+
+ for obj in "${incdir}"/*; do
+ [[ -f "${obj}" ]] && doins "${obj}"
+ [[ -d "${obj}" ]] && doins -r "${obj}"
+ done
+
+ cd "${T}"
+ # wrap some symbols for the sake of configure link test. the libbind names
+ # symbols differently than required (some extra underscores), and renames
+ # them through the headers. however this is not enough, if configure checks
+ # don't include header files ... :(
+ $(tc-getCC) -c "${FILESDIR}"/weak.s
+
+ mkdir "${T}"/link || die "cannot mkdir"
+ cd "${T}"/link
+
+ # now for the _magic_ part...
+ ar -x "${libdir}/libbind.a"
+ # permissions are _totally_ broken here...
+ chmod 666 *.o
+
+ # remove the gethostent.o file, since the contained gethostbyname* functions
+ # seem to not work on older interixen, whereas the libc contained versions
+ # do work well enough.
+ rm gethostent.o
+
+ # find libdb.a from the system - need the _oold_ one...
+ local mydb=
+
+ for mydb in \
+ "/usr/lib/x86/libdb.a" \
+ "/usr/lib/libdb.a"; do
+ if test -f "${mydb}"; then
+ break
+ fi
+ done
+
+ # this needs a _stoneage_ berkeley db, so we really need to take the
+ # systems instead if installing db ourselves. newer db's don't have the
+ # requested symbols (they do support it, but with a different name). Another
+ # option would be to generate wrapper symbols for the things needed, but i'd
+ # rather avoid doing so, since i don't know them all.
+ $(tc-getCC) -shared -Wl,-h,libbind.so.${PV} -o libbind.so.${PV} *.o \
+ ../weak.o "${mydb}" || die "cannot link shared libbind"
+
+ dolib.so libbind.so.${PV}
+
+ # to prevent accidental linking during configure tests of packages which are
+ # not prepared for itx-bind, install things in a separate directory.
+ # packages need to explicitly add this and the include directory for this to
+ # work!
+ dosym ../libbind.so.${PV} /usr/lib/bind/libbind.so
+ dosym ../libbind.so.${PV} /usr/lib/bind/libresolv.so # mean, huh? :)
+}
diff --git a/sys-libs/itx-bind/metadata.xml b/sys-libs/itx-bind/metadata.xml
new file mode 100644
index 000000000000..4dfff39fdd6b
--- /dev/null
+++ b/sys-libs/itx-bind/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>haubi@gentoo.org</email>
+ <name>Michael Haubenwallner</name>
+</maintainer>
+<longdescription lang="en">
+ bind library based on the interix' host bind library. the host library
+ is linked into a shared library, wrapping some symbols to more common names
+</longdescription>
+</pkgmetadata>
+