summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2017-06-15 11:08:19 +0200
committerUlrich Müller <ulm@gentoo.org>2017-06-15 11:08:19 +0200
commit6b8746851f7bd6a2d2af3ce419507819f2c39645 (patch)
tree085d2a1f117f18be2ca738296f8eff1ff46bf57c /sys-libs/lib-compat/lib-compat-1.5.ebuild
parentapp-doc/pms: Define VARTEXFONTS in compile phase. (diff)
downloadgentoo-6b8746851f7bd6a2d2af3ce419507819f2c39645.tar.gz
gentoo-6b8746851f7bd6a2d2af3ce419507819f2c39645.tar.bz2
gentoo-6b8746851f7bd6a2d2af3ce419507819f2c39645.zip
sys-libs/lib-compat: Install only libs that are needed by reverse deps.
The only library that is still needed by reverse dependencies appears to be libstdc++-libc6.2-2.so.3 (aka libstdc++-3-libc6.2-2-2.10.0.so). Add a notice where to find the Corresponding Source (namely, in the gcc-2.95.3 tarball) to fulfil GPL requirements. Bug: 504952 Bug: 515926 Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'sys-libs/lib-compat/lib-compat-1.5.ebuild')
-rw-r--r--sys-libs/lib-compat/lib-compat-1.5.ebuild16
1 files changed, 16 insertions, 0 deletions
diff --git a/sys-libs/lib-compat/lib-compat-1.5.ebuild b/sys-libs/lib-compat/lib-compat-1.5.ebuild
new file mode 100644
index 000000000000..064a9db028cb
--- /dev/null
+++ b/sys-libs/lib-compat/lib-compat-1.5.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Compatibility C++ library for very old programs"
+HOMEPAGE="https://www.gentoo.org/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="libstdc++" # corresponding source code in gcc-2.95.3.tar.bz2
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+src_install() {
+ ABI=x86 dolib.so x86/libstdc++-libc6.2-2.so.3
+}