summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-11-24 12:56:15 +0100
committerLars Wendler <polynomial-c@gentoo.org>2020-11-24 13:10:16 +0100
commitf62a6c02e48801fb6e52ec174b660a1b1c31b374 (patch)
treead15015b1cd3552675e790e0736dab6e8462335d /sys-libs/libaal
parentdev-games/tiled: version bump 1.4.3 (diff)
downloadgentoo-f62a6c02e48801fb6e52ec174b660a1b1c31b374.tar.gz
gentoo-f62a6c02e48801fb6e52ec174b660a1b1c31b374.tar.bz2
gentoo-f62a6c02e48801fb6e52ec174b660a1b1c31b374.zip
sys-libs/libaal: EAPI-7 revbump. Don't install .la files
Package-Manager: Portage-3.0.10, Repoman-3.0.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-libs/libaal')
-rw-r--r--sys-libs/libaal/libaal-1.0.7-r2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sys-libs/libaal/libaal-1.0.7-r2.ebuild b/sys-libs/libaal/libaal-1.0.7-r2.ebuild
new file mode 100644
index 000000000000..f1b3c5cd8d39
--- /dev/null
+++ b/sys-libs/libaal/libaal-1.0.7-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs usr-ldscript
+
+DESCRIPTION="library required by reiser4progs"
+HOMEPAGE="https://sourceforge.net/projects/reiser4/"
+SRC_URI="mirror://sourceforge/reiser4/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/7"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 -sparc ~x86"
+IUSE="static-libs"
+
+BDEPEND="virtual/os-headers"
+
+src_prepare() {
+ default
+
+ # remove stupid CFLAG hardcodes
+ sed -i \
+ -e "/GENERIC_CFLAGS/s:-O3::" \
+ -e "/^CFLAGS=/s:\"\":\"${CFLAGS}\":" \
+ configure || die
+ printf '#!/bin/sh\n:\n' > run-ldconfig || die
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-libminimal
+ --enable-memory-manager
+ $(use_enable static-libs static)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ gen_usr_ldscript -a aal{,-minimal}
+ find "${ED}" -type f -name "*.la" -delete || die
+}