summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-10-03 14:45:41 +0200
committerMichał Górny <mgorny@gentoo.org>2016-10-03 14:47:37 +0200
commit983ab306d43d2cd82b32ef3880b81b0bae2b5ac2 (patch)
treef32e58925fc8758626ff07b66bee12231fb9a9bd /sys-libs/libcxx
parentdev-perl/DBD-SQLite-1.500.0-r0: stable on alpha (diff)
downloadgentoo-983ab306d43d2cd82b32ef3880b81b0bae2b5ac2.tar.gz
gentoo-983ab306d43d2cd82b32ef3880b81b0bae2b5ac2.tar.bz2
gentoo-983ab306d43d2cd82b32ef3880b81b0bae2b5ac2.zip
sys-libs/libcxx: Dep on >=clang-3.9.0 for target symlinks
Diffstat (limited to 'sys-libs/libcxx')
-rw-r--r--sys-libs/libcxx/libcxx-3.9.0.ebuild4
-rw-r--r--sys-libs/libcxx/libcxx-9999.ebuild4
2 files changed, 6 insertions, 2 deletions
diff --git a/sys-libs/libcxx/libcxx-3.9.0.ebuild b/sys-libs/libcxx/libcxx-3.9.0.ebuild
index d466c0f398aa..a55947619831 100644
--- a/sys-libs/libcxx/libcxx-3.9.0.ebuild
+++ b/sys-libs/libcxx/libcxx-3.9.0.ebuild
@@ -42,8 +42,10 @@ RDEPEND="libcxxrt? ( sys-libs/libcxxrt[libunwind=,static-libs?,${MULTILIB_USEDEP
!libcxxrt? ( >=sys-devel/gcc-4.7:=[cxx] )"
# llvm-3.9.0 needed because its cmake files installation path changed, which is
# needed by libcxx
+# clang-3.9.0 installs necessary target symlinks unconditionally
+# which removes the need for MULTILIB_USEDEP
DEPEND="${RDEPEND}
- test? ( sys-devel/clang[${MULTILIB_USEDEP}]
+ test? ( >=sys-devel/clang-3.9.0
${PYTHON_DEPS} )
app-arch/xz-utils
>=sys-devel/llvm-3.9.0"
diff --git a/sys-libs/libcxx/libcxx-9999.ebuild b/sys-libs/libcxx/libcxx-9999.ebuild
index 7f444c79833c..909265280944 100644
--- a/sys-libs/libcxx/libcxx-9999.ebuild
+++ b/sys-libs/libcxx/libcxx-9999.ebuild
@@ -42,8 +42,10 @@ RDEPEND="libcxxrt? ( sys-libs/libcxxrt[libunwind=,static-libs?,${MULTILIB_USEDEP
!libcxxrt? ( >=sys-devel/gcc-4.7:=[cxx] )"
# llvm-3.9.0 needed because its cmake files installation path changed, which is
# needed by libcxx
+# clang-3.9.0 installs necessary target symlinks unconditionally
+# which removes the need for MULTILIB_USEDEP
DEPEND="${RDEPEND}
- test? ( sys-devel/clang[${MULTILIB_USEDEP}]
+ test? ( >=sys-devel/clang-3.9.0
${PYTHON_DEPS} )
app-arch/xz-utils
>=sys-devel/llvm-3.9.0"