summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gentoo.org>2016-06-02 07:48:22 +0300
committerAndrew Savchenko <bircoph@gentoo.org>2016-06-02 07:51:08 +0300
commit29db714e996b321b6903655a96c6e055749f9ee8 (patch)
tree5e71a7eabf2c5a7d3650c7996b7a8c966a0c5c55 /sys-libs/libhx/libhx-3.22-r1.ebuild
parentdev-lang/tcc: set myself as maintainer (diff)
downloadgentoo-29db714e996b321b6903655a96c6e055749f9ee8.tar.gz
gentoo-29db714e996b321b6903655a96c6e055749f9ee8.tar.bz2
gentoo-29db714e996b321b6903655a96c6e055749f9ee8.zip
sys-libs/libhx: fix bug 584724
1. Remove lyx autodetection and disable PDF documentation rebuild, since source tarball already contains PDF docs and we don't need to rebuild it. 2. Migrate to EAPI=6. 3. Add USE="doc". Package-Manager: portage-2.3.0_rc1 Signed-off-by: Andrew Savchenko <bircoph@gentoo.org>
Diffstat (limited to 'sys-libs/libhx/libhx-3.22-r1.ebuild')
-rw-r--r--sys-libs/libhx/libhx-3.22-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sys-libs/libhx/libhx-3.22-r1.ebuild b/sys-libs/libhx/libhx-3.22-r1.ebuild
new file mode 100644
index 000000000000..db64684ee53c
--- /dev/null
+++ b/sys-libs/libhx/libhx-3.22-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools eutils
+
+DESCRIPTION="Platform independent library providing basic system functions"
+HOMEPAGE="http://libhx.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/libHX-${PV}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+
+DEPEND="app-arch/xz-utils"
+RDEPEND=""
+
+S="${WORKDIR}/libHX-${PV}"
+
+PATCHES=( "${FILESDIR}/${P}-no-lyx.patch" )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ if use doc; then
+ dodoc doc/*.txt
+ else
+ dodoc doc/changelog.txt
+ rm "${D}/usr/share/doc/${PF}/"*.pdf || die
+ fi
+
+ prune_libtool_files --all
+}