summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-12-21 17:08:48 +0100
committerMichał Górny <mgorny@gentoo.org>2016-12-21 22:01:07 +0100
commit2faa25ab0a2018b853b00ed4b8d40f2b322b9913 (patch)
tree766cc31d6caa2af07234a1f1919efea9c2900a0f /sys-libs/libomp/libomp-3.9.1.ebuild
parentsys-devel/clang: Bump the meta for 3.9.1 (diff)
downloadgentoo-2faa25ab0a2018b853b00ed4b8d40f2b322b9913.tar.gz
gentoo-2faa25ab0a2018b853b00ed4b8d40f2b322b9913.tar.bz2
gentoo-2faa25ab0a2018b853b00ed4b8d40f2b322b9913.zip
sys-libs/libomp: Bump to 3.9.1
Diffstat (limited to 'sys-libs/libomp/libomp-3.9.1.ebuild')
-rw-r--r--sys-libs/libomp/libomp-3.9.1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/sys-libs/libomp/libomp-3.9.1.ebuild b/sys-libs/libomp/libomp-3.9.1.ebuild
new file mode 100644
index 000000000000..6626fab9b01a
--- /dev/null
+++ b/sys-libs/libomp/libomp-3.9.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
+
+inherit cmake-multilib
+
+MY_P=openmp-${PV}
+DESCRIPTION="OpenMP runtime library for LLVM/clang compiler"
+HOMEPAGE="http://openmp.llvm.org"
+SRC_URI="http://llvm.org/releases/${PV}/${MY_P}.src.tar.xz"
+
+# Additional licenses:
+# - MIT-licensed Intel code,
+# - LLVM Software Grant from Intel.
+
+LICENSE="|| ( UoI-NCSA MIT ) MIT LLVM-Grant"
+SLOT="0/3.9"
+KEYWORDS="~amd64 ~x86"
+IUSE="hwloc ompt"
+
+RDEPEND="hwloc? ( sys-apps/hwloc:0=[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ dev-lang/perl"
+
+S="${WORKDIR}/${MY_P}.src"
+
+PATCHES=(
+ # backport of https://reviews.llvm.org/D24563
+ "${FILESDIR}"/${PN}-3.9.0-optional-aliases.patch
+ # backport of https://reviews.llvm.org/D25071
+ "${FILESDIR}"/${PN}-3.9.0-musl-strerror_r.patch
+)
+
+multilib_src_configure() {
+ local libdir="$(get_libdir)"
+ local mycmakeargs=(
+ -DLIBOMP_LIBDIR_SUFFIX="${libdir#lib}"
+ -DLIBOMP_USE_HWLOC=$(usex hwloc)
+ -DLIBOMP_OMPT_SUPPORT=$(usex ompt)
+ # do not install libgomp.so & libiomp5.so aliases
+ -DLIBOMP_INSTALL_ALIASES=OFF
+ # disable unnecessary hack copying stuff back to srcdir
+ -DLIBOMP_COPY_EXPORTS=OFF
+ )
+ cmake-utils_src_configure
+}