summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-20 23:08:42 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-23 20:30:55 +0200
commite11dbbf271e40d48abca3e4df048afd4dd3a7172 (patch)
tree82c82b6c5088cb36100dd4abf2fac3518a2f58eb /sys-libs/libomp
parentsys-libs/libcxx: Dedupe with new eclass code (diff)
downloadgentoo-e11dbbf271e40d48abca3e4df048afd4dd3a7172.tar.gz
gentoo-e11dbbf271e40d48abca3e4df048afd4dd3a7172.tar.bz2
gentoo-e11dbbf271e40d48abca3e4df048afd4dd3a7172.zip
sys-libs/libomp: Dedupe with new eclass code
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-libs/libomp')
-rw-r--r--sys-libs/libomp/libomp-10.0.1.9999.ebuild14
-rw-r--r--sys-libs/libomp/libomp-10.0.1_rc1.ebuild14
-rw-r--r--sys-libs/libomp/libomp-11.0.0.9999.ebuild14
3 files changed, 6 insertions, 36 deletions
diff --git a/sys-libs/libomp/libomp-10.0.1.9999.ebuild b/sys-libs/libomp/libomp-10.0.1.9999.ebuild
index 01e5f189d659..5bffd6685f64 100644
--- a/sys-libs/libomp/libomp-10.0.1.9999.ebuild
+++ b/sys-libs/libomp/libomp-10.0.1.9999.ebuild
@@ -5,7 +5,7 @@ EAPI=7
CMAKE_ECLASS=cmake
PYTHON_COMPAT=( python3_{6..9} )
-inherit cmake-multilib linux-info llvm.org multiprocessing python-any-r1
+inherit cmake-multilib linux-info llvm.org python-any-r1
DESCRIPTION="OpenMP runtime library for LLVM/clang compiler"
HOMEPAGE="https://openmp.llvm.org"
@@ -39,9 +39,6 @@ BDEPEND="dev-lang/perl
>=sys-devel/clang-6
)"
-# least intrusive of all
-CMAKE_BUILD_TYPE=RelWithDebInfo
-
python_check_deps() {
has_version "dev-python/lit[${PYTHON_USEDEP}]"
}
@@ -67,13 +64,6 @@ pkg_setup() {
use test && python-any-r1_pkg_setup
}
-src_prepare() {
- # cmake eclasses suck by forcing ${S} here
- CMAKE_USE_DIR=${S} \
- S=${WORKDIR} \
- cmake_src_prepare
-}
-
multilib_src_configure() {
local libdir="$(get_libdir)"
local mycmakeargs=(
@@ -98,7 +88,7 @@ multilib_src_configure() {
use test && mycmakeargs+=(
# this project does not use standard LLVM cmake macros
-DOPENMP_LLVM_LIT_EXECUTABLE="${EPREFIX}/usr/bin/lit"
- -DOPENMP_LIT_ARGS="-vv;-j;${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}"
+ -DOPENMP_LIT_ARGS="$(get_lit_flags)"
-DOPENMP_TEST_C_COMPILER="$(type -P "${CHOST}-clang")"
-DOPENMP_TEST_CXX_COMPILER="$(type -P "${CHOST}-clang++")"
diff --git a/sys-libs/libomp/libomp-10.0.1_rc1.ebuild b/sys-libs/libomp/libomp-10.0.1_rc1.ebuild
index 01e5f189d659..5bffd6685f64 100644
--- a/sys-libs/libomp/libomp-10.0.1_rc1.ebuild
+++ b/sys-libs/libomp/libomp-10.0.1_rc1.ebuild
@@ -5,7 +5,7 @@ EAPI=7
CMAKE_ECLASS=cmake
PYTHON_COMPAT=( python3_{6..9} )
-inherit cmake-multilib linux-info llvm.org multiprocessing python-any-r1
+inherit cmake-multilib linux-info llvm.org python-any-r1
DESCRIPTION="OpenMP runtime library for LLVM/clang compiler"
HOMEPAGE="https://openmp.llvm.org"
@@ -39,9 +39,6 @@ BDEPEND="dev-lang/perl
>=sys-devel/clang-6
)"
-# least intrusive of all
-CMAKE_BUILD_TYPE=RelWithDebInfo
-
python_check_deps() {
has_version "dev-python/lit[${PYTHON_USEDEP}]"
}
@@ -67,13 +64,6 @@ pkg_setup() {
use test && python-any-r1_pkg_setup
}
-src_prepare() {
- # cmake eclasses suck by forcing ${S} here
- CMAKE_USE_DIR=${S} \
- S=${WORKDIR} \
- cmake_src_prepare
-}
-
multilib_src_configure() {
local libdir="$(get_libdir)"
local mycmakeargs=(
@@ -98,7 +88,7 @@ multilib_src_configure() {
use test && mycmakeargs+=(
# this project does not use standard LLVM cmake macros
-DOPENMP_LLVM_LIT_EXECUTABLE="${EPREFIX}/usr/bin/lit"
- -DOPENMP_LIT_ARGS="-vv;-j;${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}"
+ -DOPENMP_LIT_ARGS="$(get_lit_flags)"
-DOPENMP_TEST_C_COMPILER="$(type -P "${CHOST}-clang")"
-DOPENMP_TEST_CXX_COMPILER="$(type -P "${CHOST}-clang++")"
diff --git a/sys-libs/libomp/libomp-11.0.0.9999.ebuild b/sys-libs/libomp/libomp-11.0.0.9999.ebuild
index 01e5f189d659..5bffd6685f64 100644
--- a/sys-libs/libomp/libomp-11.0.0.9999.ebuild
+++ b/sys-libs/libomp/libomp-11.0.0.9999.ebuild
@@ -5,7 +5,7 @@ EAPI=7
CMAKE_ECLASS=cmake
PYTHON_COMPAT=( python3_{6..9} )
-inherit cmake-multilib linux-info llvm.org multiprocessing python-any-r1
+inherit cmake-multilib linux-info llvm.org python-any-r1
DESCRIPTION="OpenMP runtime library for LLVM/clang compiler"
HOMEPAGE="https://openmp.llvm.org"
@@ -39,9 +39,6 @@ BDEPEND="dev-lang/perl
>=sys-devel/clang-6
)"
-# least intrusive of all
-CMAKE_BUILD_TYPE=RelWithDebInfo
-
python_check_deps() {
has_version "dev-python/lit[${PYTHON_USEDEP}]"
}
@@ -67,13 +64,6 @@ pkg_setup() {
use test && python-any-r1_pkg_setup
}
-src_prepare() {
- # cmake eclasses suck by forcing ${S} here
- CMAKE_USE_DIR=${S} \
- S=${WORKDIR} \
- cmake_src_prepare
-}
-
multilib_src_configure() {
local libdir="$(get_libdir)"
local mycmakeargs=(
@@ -98,7 +88,7 @@ multilib_src_configure() {
use test && mycmakeargs+=(
# this project does not use standard LLVM cmake macros
-DOPENMP_LLVM_LIT_EXECUTABLE="${EPREFIX}/usr/bin/lit"
- -DOPENMP_LIT_ARGS="-vv;-j;${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}"
+ -DOPENMP_LIT_ARGS="$(get_lit_flags)"
-DOPENMP_TEST_C_COMPILER="$(type -P "${CHOST}-clang")"
-DOPENMP_TEST_CXX_COMPILER="$(type -P "${CHOST}-clang++")"