summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2016-10-23 16:20:39 +0800
committerJason Zaman <perfinion@gentoo.org>2016-10-24 23:38:02 +0800
commit784f3d7257a0d912404adac3642e40875ef8b831 (patch)
treebe20231e9588adda5c4dc1c6276f052cb8e198fa /sys-libs/libsepol/libsepol-2.6.ebuild
parentsys-libs/compiler-rt-sanitizers: Remove asan_symbolize.py (diff)
downloadgentoo-784f3d7257a0d912404adac3642e40875ef8b831.tar.gz
gentoo-784f3d7257a0d912404adac3642e40875ef8b831.tar.bz2
gentoo-784f3d7257a0d912404adac3642e40875ef8b831.zip
sys-libs/libsepol: bump to 2.6 final release
Package-Manager: portage-2.3.0
Diffstat (limited to 'sys-libs/libsepol/libsepol-2.6.ebuild')
-rw-r--r--sys-libs/libsepol/libsepol-2.6.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/sys-libs/libsepol/libsepol-2.6.ebuild b/sys-libs/libsepol/libsepol-2.6.ebuild
new file mode 100644
index 000000000000..b3452a0d98de
--- /dev/null
+++ b/sys-libs/libsepol/libsepol-2.6.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+inherit multilib toolchain-funcs multilib-minimal
+
+MY_P="${P//_/-}"
+MY_RELEASEDATE="20161014"
+
+DESCRIPTION="SELinux binary policy representation library"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+ S="${WORKDIR}/${MY_P}/${PN}"
+else
+ SRC_URI="https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/${MY_RELEASEDATE}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+# tests are not meant to be run outside of the full SELinux userland repo
+RESTRICT="test"
+
+src_prepare() {
+ eapply_user
+ multilib_copy_sources
+}
+
+multilib_src_compile() {
+ tc-export RANLIB;
+ LIBDIR="\$(PREFIX)/$(get_libdir)" SHLIBDIR="\$(DESTDIR)/$(get_libdir)" \
+ emake AR="$(tc-getAR)" CC="$(tc-getCC)"
+}
+
+multilib_src_install() {
+ LIBDIR="\$(PREFIX)/$(get_libdir)" SHLIBDIR="\$(DESTDIR)/$(get_libdir)" \
+ emake DESTDIR="${D}" install
+}