summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2018-04-26 18:48:54 +0800
committerJason Zaman <perfinion@gentoo.org>2018-04-26 19:22:08 +0800
commit65c8897532b3c23c432b4cbea9ff694399176e84 (patch)
treebf7cb005d169f396b7f4c878e27f26882bd518c6 /sys-libs/libsepol
parentsys-apps/restorecond: update live ebuild (diff)
downloadgentoo-65c8897532b3c23c432b4cbea9ff694399176e84.tar.gz
gentoo-65c8897532b3c23c432b4cbea9ff694399176e84.tar.bz2
gentoo-65c8897532b3c23c432b4cbea9ff694399176e84.zip
sys-libs/libsepol: bump to 2.8_rc1
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'sys-libs/libsepol')
-rw-r--r--sys-libs/libsepol/Manifest1
-rw-r--r--sys-libs/libsepol/libsepol-2.8_rc1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/sys-libs/libsepol/Manifest b/sys-libs/libsepol/Manifest
index 75e863d7e9d2..2dfb18552e7f 100644
--- a/sys-libs/libsepol/Manifest
+++ b/sys-libs/libsepol/Manifest
@@ -1,2 +1,3 @@
DIST libsepol-2.6.tar.gz 442549 BLAKE2B d56eea07310e0e8338f4ef2de7470db0cda57efcad92bbb2fd7b5df184cd210a316f2f517c227f5d711a5b7ec967908e22e5c687859060e020ae8710e2240724 SHA512 17d007857634e3d581fcc9bafcbb75674a06e382bb258c2c6b3656c141d71493699c42b78c8e1917c628476aeb8ead73bb86e8ccf43d7ce59aa0b7884bea132a
DIST libsepol-2.7.tar.gz 471147 BLAKE2B 5eea0be27cd14e105c261ce67d46806c60f8454ebcc82c27d060529deb1d36b1d7a3aac7a2c6706e969b0cea9225351e0cbce3149a73c0bbb18242b70d258344 SHA512 1d308c17bfea2659f9dc4877ab685449a5a33dff7260e62b603cde9551bed2010360b71a896c6dfcdb8b9fe86ecebc9f6b3225e6c3573a80fca8578a9d561b47
+DIST libsepol-2.8-rc1.tar.gz 473554 BLAKE2B 274894dfeb1d0dd7ba7b661266e7acdd0dc1c4ae4a51b689f2beb3a838ffebe5f1a9b7ce3f28c421215a68ba9eea57b9a3a5a4cf2a3effefa905bfdb1d71e72a SHA512 79307249604207b52af154ee17c96b90ea31c44d208935a06b276975c7521b84f8c96f9f2dd578478d2baa974fe5777c5f1417073eba828202fa227cf2ea383d
diff --git a/sys-libs/libsepol/libsepol-2.8_rc1.ebuild b/sys-libs/libsepol/libsepol-2.8_rc1.ebuild
new file mode 100644
index 000000000000..0b34ccbc1760
--- /dev/null
+++ b/sys-libs/libsepol/libsepol-2.8_rc1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit multilib toolchain-funcs multilib-minimal
+
+MY_P="${P//_/-}"
+MY_RELEASEDATE="20180419"
+
+DESCRIPTION="SELinux binary policy representation library"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+ S="${WORKDIR}/${MY_P}/${PN}"
+else
+ SRC_URI="https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/${MY_RELEASEDATE}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+# tests are not meant to be run outside of the full SELinux userland repo
+RESTRICT="test"
+
+src_prepare() {
+ eapply_user
+ multilib_copy_sources
+}
+
+multilib_src_compile() {
+ tc-export CC AR RANLIB
+ emake \
+ LIBDIR="\$(PREFIX)/$(get_libdir)" \
+ SHLIBDIR="/$(get_libdir)"
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" \
+ LIBDIR="\$(PREFIX)/$(get_libdir)" \
+ SHLIBDIR="/$(get_libdir)" \
+ install
+}