summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-libs/libspe2
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-libs/libspe2')
-rw-r--r--sys-libs/libspe2/Manifest2
-rw-r--r--sys-libs/libspe2/files/spe.rc639
-rw-r--r--sys-libs/libspe2/libspe2-2.2.80_p95-r1.ebuild67
-rw-r--r--sys-libs/libspe2/libspe2-2.3.0_p135.ebuild68
-rw-r--r--sys-libs/libspe2/metadata.xml10
5 files changed, 186 insertions, 0 deletions
diff --git a/sys-libs/libspe2/Manifest b/sys-libs/libspe2/Manifest
new file mode 100644
index 000000000000..831e99813aab
--- /dev/null
+++ b/sys-libs/libspe2/Manifest
@@ -0,0 +1,2 @@
+DIST libspe2-2.2.80-95.tar.gz 153122 SHA256 a8160fb41faa83247ffe132a25502fdd2237427a55ed3a22344058f3dc5e2a44
+DIST libspe2-2.3.0.135.tar.gz 197848 SHA256 35b26c2f478feabce9b94ecca2b28726b462e29578aa49f38fb104f8ecf2d23a
diff --git a/sys-libs/libspe2/files/spe.rc6 b/sys-libs/libspe2/files/spe.rc6
new file mode 100644
index 000000000000..33fc72fdbe9f
--- /dev/null
+++ b/sys-libs/libspe2/files/spe.rc6
@@ -0,0 +1,39 @@
+#!/sbin/runscript
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ # you need the elfspe bin
+ need localmount
+}
+
+start() {
+ ebegin "Registering elfspe to binfmt"
+
+ if test -f /proc/sys/fs/binfmt_misc/spe
+ then
+ eerror "elfspe already registered"
+ return 1
+ else
+ if test -f /proc/sys/fs/binfmt_misc/register
+ then
+ echo ':spe:M::\x7fELF\x01\x02\x01\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x02\x00\x17::/usr/bin/elfspe:' >/proc/sys/fs/binfmt_misc/register
+ eend $?
+ else
+ eerror "binfmt not available"
+ return 1
+ fi
+ fi
+}
+
+stop() {
+ if ! test -f /proc/sys/fs/binfmt_misc/spe
+ then
+ eerror "elfspe not present"
+ return 1
+ else
+ echo -1 > /proc/sys/fs/binfmt_misc/spe
+ eend $?
+ fi
+}
diff --git a/sys-libs/libspe2/libspe2-2.2.80_p95-r1.ebuild b/sys-libs/libspe2/libspe2-2.2.80_p95-r1.ebuild
new file mode 100644
index 000000000000..8d8384a4dda6
--- /dev/null
+++ b/sys-libs/libspe2/libspe2-2.2.80_p95-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+inherit eutils
+
+MY_P=${P/_p/-}
+
+DESCRIPTION="A wrapper library to adapt the JSRE SPU usage model to SPUFS"
+HOMEPAGE="http://sourceforge.net/projects/libspe"
+SRC_URI="mirror://sourceforge/libspe/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="ppc ppc64"
+IUSE="debug"
+
+S="${WORKDIR}/${P//_p*}"
+
+DEPEND=""
+# This packages also provides libspe1
+RDEPEND="!sys-libs/libspe"
+
+export CBUILD=${CBUILD:-${CHOST}}
+export CTARGET=${CTARGET:-${CHOST}}
+if [[ ${CTARGET} == ${CHOST} ]] ; then
+ if [[ ${CATEGORY} == cross-* ]] ; then
+ export CTARGET=${CATEGORY#cross-}
+ fi
+fi
+
+if [[ ${CTARGET} == ${CHOST} ]] ; then
+ SYSROOT=""
+else
+ SYSROOT="/usr/${CTARGET}"
+fi
+
+src_unpack () {
+ unpack ${A}
+ #just in case something is missing
+ cd "${S}"
+}
+
+src_compile() {
+ myconf=""
+ use debug && myconf="${myconf} DEBUG=1"
+ make all elfspe-all CROSS="${CTARGET}-" \
+ prefix=/usr SYSROOT="$SYSROOT" ${myconf} \
+ speinclude=/usr/spu-elf/include || die
+}
+
+src_install() {
+ make CROSS="${CTARGET}-" prefix=/usr \
+ speinclude=/usr/spu-elf/include \
+ SYSROOT="$SYSROOT" \
+ DESTDIR="$D" install elfspe-install || die
+ newinitd "${FILESDIR}/spe.rc6" elfspe
+}
+
+pkg_postinst() {
+ einfo "You may want to register elfspe to binfmt using the"
+ einfo "provided initscript"
+ einfo "# rc-update add elfspe boot"
+ ewarn "make sure your fstab contains the following line"
+ ewarn "none /spu spufs defaults
+ 0 0"
+ ewarn "and that you have spufs support enabled in the kernel"
+}
diff --git a/sys-libs/libspe2/libspe2-2.3.0_p135.ebuild b/sys-libs/libspe2/libspe2-2.3.0_p135.ebuild
new file mode 100644
index 000000000000..cf010518d118
--- /dev/null
+++ b/sys-libs/libspe2/libspe2-2.3.0_p135.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+inherit eutils
+
+MY_P=${P/_p/.}
+
+DESCRIPTION="A wrapper library to adapt the JSRE SPU usage model to SPUFS"
+HOMEPAGE="http://sourceforge.net/projects/libspe"
+SRC_URI="mirror://sourceforge/libspe/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~ppc64"
+IUSE="debug"
+
+S="${WORKDIR}/${P/_p*//}"
+
+DEPEND=""
+# This packages also provides libspe1
+RDEPEND="!sys-libs/libspe"
+
+export CBUILD=${CBUILD:-${CHOST}}
+export CTARGET=${CTARGET:-${CHOST}}
+if [[ ${CTARGET} == ${CHOST} ]] ; then
+ if [[ ${CATEGORY} == cross-* ]] ; then
+ export CTARGET=${CATEGORY#cross-}
+ fi
+fi
+
+if [[ ${CTARGET} == ${CHOST} ]] ; then
+ SYSROOT=""
+else
+ SYSROOT="/usr/${CTARGET}"
+fi
+
+src_unpack () {
+ unpack ${A}
+ #just in case something is missing
+ cd "${S}"
+ echo "${S}"
+}
+
+src_compile() {
+ myconf=""
+ use debug && myconf="${myconf} DEBUG=1"
+ make all elfspe-all CROSS="${CTARGET}-" \
+ prefix=/usr SYSROOT="$SYSROOT" ${myconf} \
+ speinclude=/usr/spu-elf/include || die
+}
+
+src_install() {
+ make CROSS="${CTARGET}-" prefix=/usr \
+ speinclude=/usr/spu-elf/include \
+ SYSROOT="$SYSROOT" \
+ DESTDIR="$D" install elfspe-install || die
+ newinitd "${FILESDIR}/spe.rc6" elfspe
+}
+
+pkg_postinst() {
+ einfo "You may want to register elfspe to binfmt using the"
+ einfo "provided initscript"
+ einfo "# rc-update add elfspe boot"
+ ewarn "make sure your fstab contains the following line"
+ ewarn "none /spu spufs defaults
+ 0 0"
+ ewarn "and that you have spufs support enabled in the kernel"
+}
diff --git a/sys-libs/libspe2/metadata.xml b/sys-libs/libspe2/metadata.xml
new file mode 100644
index 000000000000..16fed8ff6fb6
--- /dev/null
+++ b/sys-libs/libspe2/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>lu_zero@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">libspe</remote-id>
+ </upstream>
+</pkgmetadata>