summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2020-07-06 19:26:25 +0200
committerSergei Trofimovich <slyfox@gentoo.org>2020-07-06 19:40:28 +0100
commit9a837fb82b78ecbbc91dbb1b629e6967f28b2368 (patch)
tree5cf399a94485987dd3106ef7008e81ca505733cb /sys-libs/libunwind
parentnet-libs/libnsl: Bump to version 1.3.0 (diff)
downloadgentoo-9a837fb82b78ecbbc91dbb1b629e6967f28b2368.tar.gz
gentoo-9a837fb82b78ecbbc91dbb1b629e6967f28b2368.tar.bz2
gentoo-9a837fb82b78ecbbc91dbb1b629e6967f28b2368.zip
sys-libs/libunwind: remove unused patches
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/16615 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-libs/libunwind')
-rw-r--r--sys-libs/libunwind/files/libunwind-1.2-ia64-undwarf.patch17
-rw-r--r--sys-libs/libunwind/files/libunwind-1.2.1-arm-__asm__.patch47
-rw-r--r--sys-libs/libunwind/files/libunwind-1.2.1-fix_version_macros.patch13
-rw-r--r--sys-libs/libunwind/files/libunwind-1.2.1-no-PROTECTED.patch14
4 files changed, 0 insertions, 91 deletions
diff --git a/sys-libs/libunwind/files/libunwind-1.2-ia64-undwarf.patch b/sys-libs/libunwind/files/libunwind-1.2-ia64-undwarf.patch
deleted file mode 100644
index 1e3e2489828e..000000000000
--- a/sys-libs/libunwind/files/libunwind-1.2-ia64-undwarf.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-diff --git a/src/mi/Gget_proc_name.c b/src/mi/Gget_proc_name.c
-index 5376f82..64d2503 100644
---- a/src/mi/Gget_proc_name.c
-+++ b/src/mi/Gget_proc_name.c
-@@ -106,8 +106,12 @@ unw_get_proc_name (unw_cursor_t *cursor, char *buf, size_t buf_len,
- ip = tdep_get_ip (c);
-+#if !defined(__ia64)
- if (c->dwarf.use_prev_instr)
- --ip;
-+#endif
- error = get_proc_name (tdep_get_as (c), ip, buf, buf_len, offp,
- tdep_get_as_arg (c));
-+#if !defined(__ia64)
- if (c->dwarf.use_prev_instr && offp != NULL && error == 0)
- *offp += 1;
-+#endif
- return error;
diff --git a/sys-libs/libunwind/files/libunwind-1.2.1-arm-__asm__.patch b/sys-libs/libunwind/files/libunwind-1.2.1-arm-__asm__.patch
deleted file mode 100644
index 4b6debabefcf..000000000000
--- a/sys-libs/libunwind/files/libunwind-1.2.1-arm-__asm__.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-https://bugs.gentoo.org/635674
-
-From ca6b6f3ad9190814ef7869e8c7e73dae0922f647 Mon Sep 17 00:00:00 2001
-From: Romain Naour <romain.naour@smile.fr>
-Date: Mon, 3 Jul 2017 15:31:10 +0200
-Subject: [PATCH] libunwind-arm: fix build failure due to asm()
-
-mesa3d on ARM build with libunwind support enabled fail to build due to asm()
-function used when building with -std=c99.
-The gcc documentation [1] suggest to use __asm__ instead of asm.
-
-Fixes:
-https://urldefense.proofpoint.com/v2/url?u=http-3A__autobuild.buildroot.net_results_3ef_3efe156b6494e4392b6c31de447ee2c72acc1a53&d=DwICAg&c=5VD0RTtNlTh3ycd41b3MUw&r=vou6lT5jmE_fWQWZZgNrsMWu4RT87QAB9V07tPHlP5U&m=BlAszRQ0vewy5vW7raCh9FmNOACKez_juz55zoiNfUs&s=4sXL6_rFriQz7qi5ygKXBIVHMc7YSdCBnkkHoi347CU&e=
-
-[1] https://gcc.gnu.org/onlinedocs/gcc/Alternate-Keywords.html#Alternate-Keywords
-
-Signed-off-by: Romain Naour <romain.naour@smile.fr>
-Cc: Bernd Kuhls <bernd.kuhls@t-online.de>
----
- include/libunwind-arm.h | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/include/libunwind-arm.h b/include/libunwind-arm.h
-index f208487a..1c856faf 100644
---- a/include/libunwind-arm.h
-+++ b/include/libunwind-arm.h
-@@ -265,7 +265,7 @@ unw_tdep_context_t;
- #ifndef __thumb__
- #define unw_tdep_getcontext(uc) (({ \
- unw_tdep_context_t *unw_ctx = (uc); \
-- register unsigned long *unw_base asm ("r0") = unw_ctx->regs; \
-+ register unsigned long *unw_base __asm__ ("r0") = unw_ctx->regs; \
- __asm__ __volatile__ ( \
- "stmia %[base], {r0-r15}" \
- : : [base] "r" (unw_base) : "memory"); \
-@@ -273,7 +273,7 @@ unw_tdep_context_t;
- #else /* __thumb__ */
- #define unw_tdep_getcontext(uc) (({ \
- unw_tdep_context_t *unw_ctx = (uc); \
-- register unsigned long *unw_base asm ("r0") = unw_ctx->regs; \
-+ register unsigned long *unw_base __asm__ ("r0") = unw_ctx->regs; \
- __asm__ __volatile__ ( \
- ".align 2\nbx pc\nnop\n.code 32\n" \
- "stmia %[base], {r0-r15}\n" \
---
-2.18.0
-
diff --git a/sys-libs/libunwind/files/libunwind-1.2.1-fix_version_macros.patch b/sys-libs/libunwind/files/libunwind-1.2.1-fix_version_macros.patch
deleted file mode 100644
index 63202937084c..000000000000
--- a/sys-libs/libunwind/files/libunwind-1.2.1-fix_version_macros.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/configure.ac b/configure.ac
-index a254bbe..fe0247b 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -1,6 +1,6 @@
- define(pkg_major, 1)
--define(pkg_minor, 2.1)
--define(pkg_extra, )
-+define(pkg_minor, 2)
-+define(pkg_extra, 1)
- define(pkg_maintainer, libunwind-devel@nongnu.org)
- define(mkvers, $1.$2$3)
- dnl Process this file with autoconf to produce a configure script.
diff --git a/sys-libs/libunwind/files/libunwind-1.2.1-no-PROTECTED.patch b/sys-libs/libunwind/files/libunwind-1.2.1-no-PROTECTED.patch
deleted file mode 100644
index 6b12d9712ff8..000000000000
--- a/sys-libs/libunwind/files/libunwind-1.2.1-no-PROTECTED.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-https://bugs.gentoo.org/659732
-https://github.com/libunwind/libunwind/issues/58
-
-From a1437a3d27924e17d00021df3cc659bd998e8580 Mon Sep 17 00:00:00 2001
-From: Dave Watson <davejwatson@fb.com>
-Date: Thu, 28 Dec 2017 08:26:42 -0800
-Subject: [PATCH] Remove PROTECTED visibility
-
-This only works on bfd ld, not lld or gold.
---- a/include/compiler.h
-+++ b/include/compiler.h
-@@ -43 +43 @@ WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE. */
--# define PROTECTED __attribute__((visibility ("protected")))
-+# define PROTECTED