summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeorize <alaviss@users.noreply.github.com>2018-02-19 15:36:14 +0700
committerMichał Górny <mgorny@gentoo.org>2018-02-20 17:39:37 +0100
commit14f34132fedfa241528b7699d19bebe3c98ded63 (patch)
treebac7c02c14d9813488314f877e30a390b5297c27 /sys-libs/llvm-libunwind
parentdev-python/git-review: 1.26.0 stable (diff)
downloadgentoo-14f34132fedfa241528b7699d19bebe3c98ded63.tar.gz
gentoo-14f34132fedfa241528b7699d19bebe3c98ded63.tar.bz2
gentoo-14f34132fedfa241528b7699d19bebe3c98ded63.zip
sys-libs/llvm-libunwind: fix when test is off (*9999)
Also avoid fetching libcxx unless test is used. Closes: https://github.com/gentoo/gentoo/pull/7227
Diffstat (limited to 'sys-libs/llvm-libunwind')
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-6.0.9999.ebuild8
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild8
2 files changed, 10 insertions, 6 deletions
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-6.0.9999.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-6.0.9999.ebuild
index 7523ff7bd6f6..87f9ee1eb39b 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-6.0.9999.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-6.0.9999.ebuild
@@ -43,15 +43,17 @@ pkg_setup() {
src_unpack() {
# we need headers & test utilities
- git-r3_fetch "https://git.llvm.org/git/libcxx.git
- https://github.com/llvm-mirror/libcxx.git"
+ if use test; then
+ git-r3_fetch "https://git.llvm.org/git/libcxx.git
+ https://github.com/llvm-mirror/libcxx.git"
+ fi
git-r3_fetch
if use test; then
git-r3_checkout https://llvm.org/git/libcxx.git \
"${WORKDIR}"/libcxx '' include utils/libcxx
- git-r3_checkout
fi
+ git-r3_checkout
}
multilib_src_configure() {
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild
index 60a321c7d609..2ac7db3bbf71 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild
@@ -42,15 +42,17 @@ pkg_setup() {
src_unpack() {
# we need headers & test utilities
- git-r3_fetch "https://git.llvm.org/git/libcxx.git
- https://github.com/llvm-mirror/libcxx.git"
+ if use test
+ git-r3_fetch "https://git.llvm.org/git/libcxx.git
+ https://github.com/llvm-mirror/libcxx.git"
+ fi
git-r3_fetch
if use test; then
git-r3_checkout https://llvm.org/git/libcxx.git \
"${WORKDIR}"/libcxx '' include utils/libcxx
- git-r3_checkout
fi
+ git-r3_checkout
}
multilib_src_configure() {