summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-12-21 17:14:48 +0100
committerMichał Górny <mgorny@gentoo.org>2016-12-21 22:01:08 +0100
commit5df1156862a9a46565a9ebc1c51441031243c9d7 (patch)
tree22a23ab309f2b9ab3f3dd6eec98839d8a843efc9 /sys-libs/llvm-libunwind
parentsys-libs/libomp: Bump to 3.9.1 (diff)
downloadgentoo-5df1156862a9a46565a9ebc1c51441031243c9d7.tar.gz
gentoo-5df1156862a9a46565a9ebc1c51441031243c9d7.tar.bz2
gentoo-5df1156862a9a46565a9ebc1c51441031243c9d7.zip
sys-libs/llvm-libunwind: Bump to 3.9.1
Diffstat (limited to 'sys-libs/llvm-libunwind')
-rw-r--r--sys-libs/llvm-libunwind/Manifest1
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-3.9.1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/sys-libs/llvm-libunwind/Manifest b/sys-libs/llvm-libunwind/Manifest
index 40a45c157316..45bd6dd29932 100644
--- a/sys-libs/llvm-libunwind/Manifest
+++ b/sys-libs/llvm-libunwind/Manifest
@@ -1,2 +1,3 @@
DIST libunwind-3.8.1.src.tar.xz 60596 SHA256 21e58ce09a5982255ecf86b86359179ddb0be4f8f284a95be14201df90e48453 SHA512 2a60d7c4b0aee6c58f50089ac9fa2b756ab1d74faaee32f7436ddace4510589c7ffdd20478919966ed2fa8a23ee1b5d1b26115dbd8ee2834b00b5bcd61d00b14 WHIRLPOOL f2756de12d39de2df9bf06be3024327b3ca37f2537aae17efda6e94fb9807c31cab1a2eb070aca8e7e44467ab51c69fecbeef063e07472ec59657309a16bdd1c
DIST libunwind-3.9.0.src.tar.xz 61764 SHA256 66675ddec5ba0d36689757da6008cb2596ee1a9067f4f598d89ce5a3b43f4c2b SHA512 dce384bea99ed61b363b847e20946fc9d70377389a227cc7054fbaa916e7cb5ba0b9d89f0df6ed33409dbf38beefd3654c18c1abcf0e50b5d0315ce0135a1d25 WHIRLPOOL 3fddaf6a06390143beee04d0e73ac0b66fb27c5497b80309ca314a52fd67d49ae3806b2b7588f07185c49339a75b7549bbf303f50224916f1ed65f6ad82415d0
+DIST libunwind-3.9.1.src.tar.xz 61788 SHA256 0b0bc73264d7ab77d384f8a7498729e3c4da8ffee00e1c85ad02a2f85e91f0e6 SHA512 a80f5d0660e209f5bf709316b5df2ca63b9f0db49f5f74dfe9c9e580c654f61a15acc071a739fdb84baf5ffa9420b92498f8560331173642d80f6b74e1e2afb7 WHIRLPOOL d79928771468e344bd4c73ec458f4994fbfa04b4f625e559f3ef20c75d504d06f8edc1051d1444d8b4260f253716333ecd4bc7a18e8aca822dd77245a5a99ac2
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-3.9.1.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-3.9.1.ebuild
new file mode 100644
index 000000000000..e06514de5201
--- /dev/null
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-3.9.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
+CMAKE_MIN_VERSION=3.4.3
+inherit cmake-multilib
+
+MY_P="libunwind-${PV}"
+DESCRIPTION="C++ runtime stack unwinder from LLVM"
+HOMEPAGE="https://github.com/llvm-mirror/libunwind"
+SRC_URI="http://llvm.org/releases/${PV}/${MY_P}.src.tar.xz"
+
+LICENSE="|| ( UoI-NCSA MIT )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +static-libs"
+
+RDEPEND="!sys-libs/libunwind"
+# llvm-config and cmake files needed to get proper flags
+# (3.9.0 needed because cmake file install path changed)
+DEPEND=">=sys-devel/llvm-3.9.0[${MULTILIB_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}.src"
+
+src_prepare() {
+ # add switch for static-libs; accepted upstream
+ eapply "${FILESDIR}/libunwind-3.9-cmake-static-lib.patch"
+ default
+}
+
+multilib_src_configure() {
+ local libdir=$(get_libdir)
+
+ local mycmakeargs=(
+ -DLLVM_LIBDIR_SUFFIX=${libdir#lib}
+ -DLIBUNWIND_ENABLE_ASSERTIONS=$(usex debug)
+ -DLIBUNWIND_ENABLE_STATIC=$(usex static-libs)
+ )
+
+ cmake-utils_src_configure
+}
+
+multilib_src_install() {
+ cmake-utils_src_install
+
+ # install headers like sys-libs/libunwind
+ doheader "${S}"/include/*.h
+}