summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-01-20 10:33:52 +0100
committerMichał Górny <mgorny@gentoo.org>2018-01-20 10:39:21 +0100
commit82239d2f05f6b9a836d2fc53d5efbfd2fd68782a (patch)
treef3dc32a1a97ff7d495243fcdf3ac035a8f6f80c5 /sys-libs/llvm-libunwind
parentapp-arch/xar: convert sed to path, add virtual/acl dep, bug #645054 (diff)
downloadgentoo-82239d2f05f6b9a836d2fc53d5efbfd2fd68782a.tar.gz
gentoo-82239d2f05f6b9a836d2fc53d5efbfd2fd68782a.tar.bz2
gentoo-82239d2f05f6b9a836d2fc53d5efbfd2fd68782a.zip
sys-libs/llvm-libunwind: Enable cross-unwinding support in 6+
Closes: https://bugs.gentoo.org/645046
Diffstat (limited to 'sys-libs/llvm-libunwind')
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-6.0.9999.ebuild4
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild4
2 files changed, 8 insertions, 0 deletions
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-6.0.9999.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-6.0.9999.ebuild
index 2d1f18ceeabf..0be3b4e8c29e 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-6.0.9999.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-6.0.9999.ebuild
@@ -60,6 +60,10 @@ multilib_src_configure() {
-DLIBUNWIND_ENABLE_ASSERTIONS=$(usex debug)
-DLIBUNWIND_ENABLE_STATIC=$(usex static-libs)
-DLLVM_INCLUDE_TESTS=$(usex test)
+
+ # support non-native unwinding; given it's small enough,
+ # enable it unconditionally
+ -DLIBUNWIND_ENABLE_CROSS_UNWINDING=ON
)
if use test; then
mycmakeargs+=(
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild
index d7622010ab47..c10226761668 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild
@@ -59,6 +59,10 @@ multilib_src_configure() {
-DLIBUNWIND_ENABLE_ASSERTIONS=$(usex debug)
-DLIBUNWIND_ENABLE_STATIC=$(usex static-libs)
-DLLVM_INCLUDE_TESTS=$(usex test)
+
+ # support non-native unwinding; given it's small enough,
+ # enable it unconditionally
+ -DLIBUNWIND_ENABLE_CROSS_UNWINDING=ON
)
if use test; then
mycmakeargs+=(