summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-10-06 14:40:11 +0200
committerMichał Górny <mgorny@gentoo.org>2016-10-06 15:28:53 +0200
commita499a225bb7e5ddd8c2478fbe804e6cbfac212c5 (patch)
tree85f219fe5a60b71b69dc5ac69590a86de2e3289d /sys-libs/llvm-libunwind
parentdev-ros/tf2: remove old (diff)
downloadgentoo-a499a225bb7e5ddd8c2478fbe804e6cbfac212c5.tar.gz
gentoo-a499a225bb7e5ddd8c2478fbe804e6cbfac212c5.tar.bz2
gentoo-a499a225bb7e5ddd8c2478fbe804e6cbfac212c5.zip
sys-libs/llvm-libunwind: Install headers, req for #596340
Diffstat (limited to 'sys-libs/llvm-libunwind')
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-3.9.0-r1.ebuild (renamed from sys-libs/llvm-libunwind/llvm-libunwind-3.9.0.ebuild)7
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild7
2 files changed, 14 insertions, 0 deletions
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-3.9.0.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-3.9.0-r1.ebuild
index 1346f7ab91b7..e06514de5201 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-3.9.0.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-3.9.0-r1.ebuild
@@ -42,3 +42,10 @@ multilib_src_configure() {
cmake-utils_src_configure
}
+
+multilib_src_install() {
+ cmake-utils_src_install
+
+ # install headers like sys-libs/libunwind
+ doheader "${S}"/include/*.h
+}
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild
index df6f7707c965..1fee4bf287a5 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild
@@ -35,3 +35,10 @@ multilib_src_configure() {
cmake-utils_src_configure
}
+
+multilib_src_install() {
+ cmake-utils_src_install
+
+ # install headers like sys-libs/libunwind
+ doheader "${S}"/include/*.h
+}