summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2021-09-24 13:15:56 -0400
committerAnthony G. Basile <blueness@gentoo.org>2021-09-24 13:15:56 -0400
commit9dbc17872b221dd94343d4cd13e5719734efc08d (patch)
tree49c6c563ed502910d3ba86c11bee47e157d8388c /sys-libs/musl-nscd
parentnet-misc/cgminer: drop to maintainer needed (diff)
downloadgentoo-9dbc17872b221dd94343d4cd13e5719734efc08d.tar.gz
gentoo-9dbc17872b221dd94343d4cd13e5719734efc08d.tar.bz2
gentoo-9dbc17872b221dd94343d4cd13e5719734efc08d.zip
sys-libs/musl-nscd: version bumpt to 1.1.1
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Diffstat (limited to 'sys-libs/musl-nscd')
-rw-r--r--sys-libs/musl-nscd/Manifest1
-rw-r--r--sys-libs/musl-nscd/musl-nscd-1.1.1.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/sys-libs/musl-nscd/Manifest b/sys-libs/musl-nscd/Manifest
index 1ec7646eb383..2dc727fea3a0 100644
--- a/sys-libs/musl-nscd/Manifest
+++ b/sys-libs/musl-nscd/Manifest
@@ -1,2 +1,3 @@
DIST musl-nscd-1.0.2.tar.gz 44912 BLAKE2B 8a496c941232ba617b8468351cbbb780b1decc2c162210f939abb3baa430a5f5a79e21fcd3aadac2cbe62820452fc18001edc7ebc13cae7a6ab768353c45235f SHA512 45cd73f1e0eee7b32c3dcdfa96c0a11379f6208389b87fee97016af0ecb19e9e7d2a2f10e0df6e5ed8a6ad4bbbef70c01cd31ac3631fb1bcce6e69bf48843a3d
DIST musl-nscd-1.0.3.tar.gz 45023 BLAKE2B de3985878745497f0f6904efba0ecf1c5d4ab96dd190fe0b776459db946749858821f51e75d457172da75cd68c5bba22143647b269473f35d41e0ab9bbac3e36 SHA512 b931a28d70bbcc19a5b592449e7400ee61d5af93511d44e2e63416010b3938f1d350a965b0ad876699bed406926d3180a0380868279e13d3456e2264c80a4b7d
+DIST musl-nscd-1.1.1.tar.gz 51598 BLAKE2B 0c14cfed06f766e174154cdedf046eee8206822d21ce6ac0f1d2c253224a9c8be2fabe6a7d9c0e7c63d1811e3ccf06ca7b2c9dcb728cde445108039723e486c2 SHA512 f067b1491c6c46c3070aa2f61328b874eb6ad390c2efc928e2fee591ef5997b40400e29495546a861e803460efa46024c7a01c53ddae5b763ef63c2f274fceea
diff --git a/sys-libs/musl-nscd/musl-nscd-1.1.1.ebuild b/sys-libs/musl-nscd/musl-nscd-1.1.1.ebuild
new file mode 100644
index 000000000000..78daab8676aa
--- /dev/null
+++ b/sys-libs/musl-nscd/musl-nscd-1.1.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd tmpfiles
+
+DESCRIPTION="musl-nscd is an implementation of the NSCD protocol for the musl libc"
+HOMEPAGE="https://github.com/pikhq/musl-nscd"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/pikhq/musl-nscd"
+ EGIT_BRANCH=master
+else
+ SRC_URI="https://github.com/pikhq/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="minimal"
+
+DEPEND="
+ !sys-libs/glibc
+ !sys-libs/uclibc"
+
+src_prepare() {
+ eapply_user
+
+ sed -i '/LDFLAGS_AUTO=-s/d' configure || die 'Cannot patch configure file'
+}
+
+src_install() {
+ if use minimal; then
+ emake DESTDIR="${D}" install-headers
+ else
+ emake DESTDIR="${D}" install
+
+ newinitd "${FILESDIR}"/nscd.initd nscd
+ systemd_dounit "${FILESDIR}"/nscd.service
+ newtmpfiles "${FILESDIR}"/nscd.tmpfilesd nscd.conf
+
+ dodoc README
+ fi
+}
+
+pkg_postinst() {
+ if ! use minimal; then
+ tmpfiles_process nscd.conf
+ fi
+}