summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-09-09 22:44:32 +0200
committerMichał Górny <mgorny@gentoo.org>2017-09-09 23:11:22 +0200
commitbb6df34982cd799c9dc34c1a70746614b6bb5d68 (patch)
treec7bb53ff2e281af166d06b6e956b62c534cc5d5c /sys-libs/pinktrace/pinktrace-0.9.3.ebuild
parentsys-libs/zlib: HOMEPAGE and SRC_URI use https (diff)
downloadgentoo-bb6df34982cd799c9dc34c1a70746614b6bb5d68.tar.gz
gentoo-bb6df34982cd799c9dc34c1a70746614b6bb5d68.tar.bz2
gentoo-bb6df34982cd799c9dc34c1a70746614b6bb5d68.zip
sys-libs/pinktrace: Easy tracing lib, dep of sydbox
Diffstat (limited to 'sys-libs/pinktrace/pinktrace-0.9.3.ebuild')
-rw-r--r--sys-libs/pinktrace/pinktrace-0.9.3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-libs/pinktrace/pinktrace-0.9.3.ebuild b/sys-libs/pinktrace/pinktrace-0.9.3.ebuild
new file mode 100644
index 000000000000..52e6628349fe
--- /dev/null
+++ b/sys-libs/pinktrace/pinktrace-0.9.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="ptrace() easy wrapper library"
+HOMEPAGE="https://dev.exherbo.org/~alip/pinktrace/"
+SRC_URI="http://distfiles.exherbo.org/distfiles/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0/0.9"
+KEYWORDS="~amd64"
+IUSE="ipv6"
+
+src_configure() {
+ local myconf=(
+ $(use_enable ipv6)
+ --disable-doxygen
+ --disable-python
+ --disable-python-doc
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}