summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2018-03-29 07:28:12 -0400
committerAnthony G. Basile <blueness@gentoo.org>2018-03-29 07:28:12 -0400
commit1ffea40c4a42bba612604c22f56cafc46f5fb4da (patch)
tree0c59e20744e0432229c62742085b440a86c1cc92 /sys-libs/rpmatch-standalone
parentsys-devel/llvm: Remove non-arm & non-Darwin keywords from 3.7.1 (diff)
downloadgentoo-1ffea40c4a42bba612604c22f56cafc46f5fb4da.tar.gz
gentoo-1ffea40c4a42bba612604c22f56cafc46f5fb4da.tar.bz2
gentoo-1ffea40c4a42bba612604c22f56cafc46f5fb4da.zip
sys-libs/rpmatch-standalone: initial commit
This is a breakout library for rpmatch() which is not provided by the musl libc. See `man 3 rpmatch'. Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'sys-libs/rpmatch-standalone')
-rw-r--r--sys-libs/rpmatch-standalone/Manifest1
-rw-r--r--sys-libs/rpmatch-standalone/metadata.xml11
-rw-r--r--sys-libs/rpmatch-standalone/rpmatch-standalone-1.0.ebuild39
3 files changed, 51 insertions, 0 deletions
diff --git a/sys-libs/rpmatch-standalone/Manifest b/sys-libs/rpmatch-standalone/Manifest
new file mode 100644
index 000000000000..0f7f82cf3b04
--- /dev/null
+++ b/sys-libs/rpmatch-standalone/Manifest
@@ -0,0 +1 @@
+DIST rpmatch-standalone-1.0.tar.gz 3151 BLAKE2B e396d18bfb092aa59c70e81028ba889c1095c97b5f13bffbb4ae7b97a1ce63a6c536663304e4fdefaa06a22854dd5b986ff7238f0091b23bcd336cc6db0fca75 SHA512 9d8fc3be66f23b57793eccf62998d1c0ff8df24d8781d37ee99faf618cdceeda778132df2c75ace2ecd8aa6392bcdf15eaa9ce0acd657401af049ccf61fd5b14
diff --git a/sys-libs/rpmatch-standalone/metadata.xml b/sys-libs/rpmatch-standalone/metadata.xml
new file mode 100644
index 000000000000..4aa32e43cbee
--- /dev/null
+++ b/sys-libs/rpmatch-standalone/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>blueness@gentoo.org</email>
+ <name>Anthony G. Basile</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">pullmoll/musl-rpmatch</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-libs/rpmatch-standalone/rpmatch-standalone-1.0.ebuild b/sys-libs/rpmatch-standalone/rpmatch-standalone-1.0.ebuild
new file mode 100644
index 000000000000..4881a46decc1
--- /dev/null
+++ b/sys-libs/rpmatch-standalone/rpmatch-standalone-1.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Standalone rpmatch library for use with musl"
+HOMEPAGE="https://github.com/pullmoll/musl-rpmatch"
+SRC_URI="https://github.com/pullmoll/musl-rpmatch/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~x86"
+IUSE="static-libs"
+
+DEPEND="
+ !sys-libs/glibc
+ !sys-libs/uclibc"
+
+S="${WORKDIR}/musl-rpmatch-${PV}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+
+ mkdir "${ED%/}"/usr/$(get_libdir)/pkgconfig/
+ cp "${S}"/musl-rpmatch.pc "${ED%/}"/usr/$(get_libdir)/pkgconfig/rpmatch-standalone.pc
+}