summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2015-11-23 11:39:37 +0100
committerLars Wendler <polynomial-c@gentoo.org>2015-11-23 12:02:29 +0100
commit6387b9de981b0fa09deb37ea193317fe121e81bb (patch)
tree5140b627790ba9491fb01843c750f10133a3cba5 /sys-libs/tevent
parentsys-libs/talloc: Removed old. (diff)
downloadgentoo-6387b9de981b0fa09deb37ea193317fe121e81bb.tar.gz
gentoo-6387b9de981b0fa09deb37ea193317fe121e81bb.tar.bz2
gentoo-6387b9de981b0fa09deb37ea193317fe121e81bb.zip
sys-libs/tevent: Bump to version 0.9.26
Package-Manager: portage-2.2.25 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-libs/tevent')
-rw-r--r--sys-libs/tevent/Manifest1
-rw-r--r--sys-libs/tevent/tevent-0.9.26.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/sys-libs/tevent/Manifest b/sys-libs/tevent/Manifest
index 34ba208e5dd3..c1b4e2a1cddc 100644
--- a/sys-libs/tevent/Manifest
+++ b/sys-libs/tevent/Manifest
@@ -1,3 +1,4 @@
DIST tevent-0.9.21.tar.gz 550606 SHA256 f2be7463573dab2d8210cb57fe7e7e2aeb323274cbdc865a6e29ddcfb977f0f4 SHA512 d1d76402bf32c4da9394ec5e0eb149abefa3f4dc86e5d22529f5cc4f30b1d3071e7a00aac3bd5707532e68dfed5a03dc5a267ea367c8fbe0aaead9df63beafdf WHIRLPOOL 4b4525394cdc06a5ce2535216eea8fdcf44dc0b4ab7964506042df3ee67ce9463d82e9b6be3bdd4cd9983ce92a62e3dfc69c6abf66d30b9b6466e863b2c1d7cd
DIST tevent-0.9.24.tar.gz 560585 SHA256 4db94cc092611775340891bb138e1c45310638b27fb3c59fb11b5af345973f50 SHA512 38e7757556f6438d06343cd20f9ecad9bc66e3fad461486d56d5bba9d5cdb0738deeaf8735dd0f7cf364bb94007a757207e8c0c115452253a864eca3ee1ebab1 WHIRLPOOL 2f3dcddfd2f03e25fc456620cb9b22a74995951f7ce91953012af05824d1ee6d4c441c7da9423ba3b81f8d57f053fbd049d13ad472cbc2f4a923425625ec7fda
DIST tevent-0.9.25.tar.gz 573357 SHA256 fedeb0d55a11b3593b562ec09b32e44bd67619ed10e5fa10d1868adb1649c669 SHA512 5cc477bf7a67b2a80c5d663a8382c0006395b17396f5e7ac44ed24b40b58b8a498497b08ed050a2ea838140ad36d60ad3256552c60b3339bf307244f9de4704e WHIRLPOOL 359557ed7cfa3046a141c2a263fea5382576f7554636a1f13b1ba102650d6f8222ac5fa478db4e81fcc31bec01157cd701a8580e635c5ba1823307e45e692b56
+DIST tevent-0.9.26.tar.gz 581664 SHA256 262c14d78ede13f2c4fc5e61485ae7250a201782d94735a1d8412652453370bd SHA512 cc841e4267cdda52d4e236040a82852a29a29427d7d374170cc74b4ff8ec0652f521580a1f69a9b4f2a66d8b2a6e3fcd34f21b2e94d0512dae848d271c090ec1 WHIRLPOOL df159329f30c9bd014be9b33b2f2e6ed1a47b7dd5af7fb964952d1e9aa7d7b72fc3028122b464c933c93253fd72b2f6248af5e7cfbb6d8cfb9259454804618d7
diff --git a/sys-libs/tevent/tevent-0.9.26.ebuild b/sys-libs/tevent/tevent-0.9.26.ebuild
new file mode 100644
index 000000000000..4563290a66f2
--- /dev/null
+++ b/sys-libs/tevent/tevent-0.9.26.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit waf-utils multilib-minimal python-single-r1
+
+DESCRIPTION="Samba tevent library"
+HOMEPAGE="http://tevent.samba.org/"
+SRC_URI="http://samba.org/ftp/tevent/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~arm-linux ~x86-linux"
+IUSE="python"
+
+RDEPEND=">=sys-libs/talloc-2.1.5[${MULTILIB_USEDEP}]
+ python? ( ${PYTHON_DEPS} )"
+
+DEPEND="${RDEPEND}
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+ ${PYTHON_DEPS}
+"
+# build system does not work with python3
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+WAF_BINARY="${S}/buildtools/bin/waf"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ waf-utils_src_configure \
+ $(multilib_native_usex python '' '--disable-python')
+}
+
+multilib_src_compile() {
+ # need to avoid parallel building, this looks like the sanest way with waf-utils/multiprocessing eclasses
+ unset MAKEOPTS
+ waf-utils_src_compile
+}
+
+multilib_src_install() {
+ waf-utils_src_install
+
+ multilib_is_native_abi && use python && python_domodule tevent.py
+}