summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-03-25 15:42:57 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-03-25 16:00:32 +0100
commitf1eb81601f3c2f67f4ea25099091b429751c9dea (patch)
tree014780378857ccf6c20dbb80609565a9c2d8c9e2 /sys-libs/tevent
parentsys-libs/tdb: Added missing dev-libs/libbsd to RDEPEND. (diff)
downloadgentoo-f1eb81601f3c2f67f4ea25099091b429751c9dea.tar.gz
gentoo-f1eb81601f3c2f67f4ea25099091b429751c9dea.tar.bz2
gentoo-f1eb81601f3c2f67f4ea25099091b429751c9dea.zip
sys-libs/tevent: Added missing dev-libs/libbsd to RDEPEND.
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-libs/tevent')
-rw-r--r--sys-libs/tevent/tevent-0.9.28.ebuild5
-rw-r--r--sys-libs/tevent/tevent-0.9.31-r1.ebuild5
-rw-r--r--sys-libs/tevent/tevent-0.9.37.ebuild5
-rw-r--r--sys-libs/tevent/tevent-0.9.38.ebuild3
-rw-r--r--sys-libs/tevent/tevent-0.9.39.ebuild3
5 files changed, 13 insertions, 8 deletions
diff --git a/sys-libs/tevent/tevent-0.9.28.ebuild b/sys-libs/tevent/tevent-0.9.28.ebuild
index 64a7393d1853..61b6c9c77bea 100644
--- a/sys-libs/tevent/tevent-0.9.28.ebuild
+++ b/sys-libs/tevent/tevent-0.9.28.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -16,7 +16,8 @@ SLOT="0"
KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-linux"
IUSE="python"
-RDEPEND=">=sys-libs/talloc-2.1.5[${MULTILIB_USEDEP}]
+RDEPEND="!elibc_FreeBSD? ( dev-libs/libbsd[${MULTILIB_USEDEP}] )
+ >=sys-libs/talloc-2.1.5[${MULTILIB_USEDEP}]
python? ( ${PYTHON_DEPS} )"
DEPEND="${RDEPEND}
diff --git a/sys-libs/tevent/tevent-0.9.31-r1.ebuild b/sys-libs/tevent/tevent-0.9.31-r1.ebuild
index 9c45e2388dad..d53cf5a4a69e 100644
--- a/sys-libs/tevent/tevent-0.9.31-r1.ebuild
+++ b/sys-libs/tevent/tevent-0.9.31-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -16,7 +16,8 @@ SLOT="0"
KEYWORDS="alpha amd64 arm ~arm64 ~hppa ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-linux"
IUSE="python"
-RDEPEND=">=sys-libs/talloc-2.1.8[${MULTILIB_USEDEP}]
+RDEPEND="!elibc_FreeBSD? ( dev-libs/libbsd[${MULTILIB_USEDEP}] )
+ >=sys-libs/talloc-2.1.8[${MULTILIB_USEDEP}]
python? ( ${PYTHON_DEPS} )"
DEPEND="${RDEPEND}
diff --git a/sys-libs/tevent/tevent-0.9.37.ebuild b/sys-libs/tevent/tevent-0.9.37.ebuild
index cb7290190250..91b6e1b6b32a 100644
--- a/sys-libs/tevent/tevent-0.9.37.ebuild
+++ b/sys-libs/tevent/tevent-0.9.37.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -16,7 +16,8 @@ SLOT="0"
KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh ~sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-linux"
IUSE="elibc_glibc python"
-RDEPEND=">=sys-libs/talloc-2.1.13[${MULTILIB_USEDEP}]
+RDEPEND="!elibc_FreeBSD? ( dev-libs/libbsd[${MULTILIB_USEDEP}] )
+ >=sys-libs/talloc-2.1.13[${MULTILIB_USEDEP}]
python? ( ${PYTHON_DEPS} )"
DEPEND="${RDEPEND}
diff --git a/sys-libs/tevent/tevent-0.9.38.ebuild b/sys-libs/tevent/tevent-0.9.38.ebuild
index 2639789e8992..5f1718624ce4 100644
--- a/sys-libs/tevent/tevent-0.9.38.ebuild
+++ b/sys-libs/tevent/tevent-0.9.38.ebuild
@@ -16,7 +16,8 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-linux"
IUSE="elibc_glibc python"
-RDEPEND=">=sys-libs/talloc-2.1.15[${MULTILIB_USEDEP}]
+RDEPEND="!elibc_FreeBSD? ( dev-libs/libbsd[${MULTILIB_USEDEP}] )
+ >=sys-libs/talloc-2.1.15[${MULTILIB_USEDEP}]
python? ( ${PYTHON_DEPS} )"
DEPEND="${RDEPEND}
diff --git a/sys-libs/tevent/tevent-0.9.39.ebuild b/sys-libs/tevent/tevent-0.9.39.ebuild
index d7fea1a26865..c49c0a7b4721 100644
--- a/sys-libs/tevent/tevent-0.9.39.ebuild
+++ b/sys-libs/tevent/tevent-0.9.39.ebuild
@@ -16,7 +16,8 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-linux"
IUSE="elibc_glibc python"
-RDEPEND=">=sys-libs/talloc-2.1.16[${MULTILIB_USEDEP}]
+RDEPEND="!elibc_FreeBSD? ( dev-libs/libbsd[${MULTILIB_USEDEP}] )
+ >=sys-libs/talloc-2.1.16[${MULTILIB_USEDEP}]
python? ( ${PYTHON_DEPS} )"
DEPEND="${RDEPEND}