summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2017-02-23 11:48:39 +0800
committerJason Zaman <perfinion@gentoo.org>2017-02-23 19:14:19 +0800
commit0357e16dcdd8deafbf949de3faf97f195e0b4bc3 (patch)
tree09485c52859ad9d169a33bc563e9590ed8906569 /sys-libs
parentsys-apps/ed: Removed old. (diff)
downloadgentoo-0357e16dcdd8deafbf949de3faf97f195e0b4bc3.tar.gz
gentoo-0357e16dcdd8deafbf949de3faf97f195e0b4bc3.tar.bz2
gentoo-0357e16dcdd8deafbf949de3faf97f195e0b4bc3.zip
sys-libs/libselinux: update live ebuild
python libs and include dir are now properly detected so dont need to pass in need to pass the path to libsepol.a Package-Manager: portage-2.3.3
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libselinux/libselinux-9999.ebuild17
1 files changed, 9 insertions, 8 deletions
diff --git a/sys-libs/libselinux/libselinux-9999.ebuild b/sys-libs/libselinux/libselinux-9999.ebuild
index cc82d24f7768..c7b8377eafaa 100644
--- a/sys-libs/libselinux/libselinux-9999.ebuild
+++ b/sys-libs/libselinux/libselinux-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -67,9 +67,7 @@ multilib_src_compile() {
if multilib_is_native_abi && use python; then
building() {
- python_export PYTHON_INCLUDEDIR PYTHON_LIBPATH
emake \
- PYINC="-I${PYTHON_INCLUDEDIR}" \
LDFLAGS="-fPIC ${LDFLAGS} -lpthread" \
LIBDIR="\$(PREFIX)/$(get_libdir)" \
SHLIBDIR="\$(DESTDIR)/$(get_libdir)" \
@@ -101,16 +99,18 @@ multilib_src_compile() {
}
multilib_src_install() {
- emake DESTDIR="${D}" \
- LIBDIR="\$(PREFIX)/$(get_libdir)" \
- SHLIBDIR="\$(DESTDIR)/$(get_libdir)" \
- USE_PCRE2="$(usex pcre2 y n)" \
- install
+ emake DESTDIR="${D}" \
+ LIBDIR="\$(PREFIX)/$(get_libdir)" \
+ SHLIBDIR="\$(DESTDIR)/$(get_libdir)" \
+ LIBSEPOLA="/usr/$(get_libdir)/libsepol.a" \
+ USE_PCRE2="$(usex pcre2 y n)" \
+ install
if multilib_is_native_abi && use python; then
installation() {
emake DESTDIR="${D}" \
LIBDIR="\$(PREFIX)/$(get_libdir)" \
+ LIBSEPOLA="/usr/$(get_libdir)/libsepol.a" \
USE_PCRE2="$(usex pcre2 y n)" \
install-pywrap
python_optimize # bug 531638
@@ -125,6 +125,7 @@ multilib_src_install() {
rm src/selinuxswig_ruby_wrap.lo
emake DESTDIR="${D}" \
LIBDIR="\$(PREFIX)/$(get_libdir)" \
+ LIBSEPOLA="/usr/$(get_libdir)/libsepol.a" \
RUBY=${1} \
USE_PCRE2="$(usex pcre2 y n)" \
install-rubywrap