summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2018-05-14 00:47:47 +0800
committerJason Zaman <perfinion@gentoo.org>2018-05-14 01:28:09 +0800
commit101fb419010b9c9d92b3afce0d09cdef38a3f502 (patch)
treeb080c0b548b300b6e8a6a946b7a4cbe1e9995eeb /sys-libs
parentsys-apps/restorecond: update live ebuild (diff)
downloadgentoo-101fb419010b9c9d92b3afce0d09cdef38a3f502.tar.gz
gentoo-101fb419010b9c9d92b3afce0d09cdef38a3f502.tar.bz2
gentoo-101fb419010b9c9d92b3afce0d09cdef38a3f502.zip
sys-libs/libsepol: bump to 2.8_rc3
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libsepol/Manifest1
-rw-r--r--sys-libs/libsepol/libsepol-2.8_rc3.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/sys-libs/libsepol/Manifest b/sys-libs/libsepol/Manifest
index 2bc5830d2c30..38483e831113 100644
--- a/sys-libs/libsepol/Manifest
+++ b/sys-libs/libsepol/Manifest
@@ -2,3 +2,4 @@ DIST libsepol-2.6.tar.gz 442549 BLAKE2B d56eea07310e0e8338f4ef2de7470db0cda57efc
DIST libsepol-2.7.tar.gz 471147 BLAKE2B 5eea0be27cd14e105c261ce67d46806c60f8454ebcc82c27d060529deb1d36b1d7a3aac7a2c6706e969b0cea9225351e0cbce3149a73c0bbb18242b70d258344 SHA512 1d308c17bfea2659f9dc4877ab685449a5a33dff7260e62b603cde9551bed2010360b71a896c6dfcdb8b9fe86ecebc9f6b3225e6c3573a80fca8578a9d561b47
DIST libsepol-2.8-rc1.tar.gz 473554 BLAKE2B 274894dfeb1d0dd7ba7b661266e7acdd0dc1c4ae4a51b689f2beb3a838ffebe5f1a9b7ce3f28c421215a68ba9eea57b9a3a5a4cf2a3effefa905bfdb1d71e72a SHA512 79307249604207b52af154ee17c96b90ea31c44d208935a06b276975c7521b84f8c96f9f2dd578478d2baa974fe5777c5f1417073eba828202fa227cf2ea383d
DIST libsepol-2.8-rc2.tar.gz 473561 BLAKE2B a27526915a02c1a77c49bcb107d164759799835c32ed07a9ca7924d195c4127257fa97325434e6e4edd932564f9c80c5ed122dbd7b597a4749a5cad8fbb76507 SHA512 2e738986e6ddcc86904c5ef605fe03f4a3cbd239b34c76b1a3d06da1c21c327aa835949dbd5b2328d11c6c032d1a8677da21e5c06e2107f1f60a182286a9f2ea
+DIST libsepol-2.8-rc3.tar.gz 473488 BLAKE2B 1befe617e73b3a845322efe107cd22649dc17a6df0ff90c6c25486d937bffa84d9f6e83979e294df693772f1afb8943dd2db6a95f76ae71d83f15fd90819d888 SHA512 afefd13732aadd2b7e476cb439fa3d09dc870ac50f262b3c803459a5ce431c26d896e327a4207fea88eac7121e0901db77674bae632bb3940a80e183c156d7fc
diff --git a/sys-libs/libsepol/libsepol-2.8_rc3.ebuild b/sys-libs/libsepol/libsepol-2.8_rc3.ebuild
new file mode 100644
index 000000000000..1e5f9c74df6b
--- /dev/null
+++ b/sys-libs/libsepol/libsepol-2.8_rc3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit multilib toolchain-funcs multilib-minimal
+
+MY_P="${P//_/-}"
+MY_RELEASEDATE="20180510"
+
+DESCRIPTION="SELinux binary policy representation library"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+ S="${WORKDIR}/${MY_P}/${PN}"
+else
+ SRC_URI="https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/${MY_RELEASEDATE}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+# tests are not meant to be run outside of the full SELinux userland repo
+RESTRICT="test"
+
+src_prepare() {
+ eapply_user
+ multilib_copy_sources
+}
+
+multilib_src_compile() {
+ tc-export CC AR RANLIB
+ emake \
+ LIBDIR="\$(PREFIX)/$(get_libdir)" \
+ SHLIBDIR="/$(get_libdir)"
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" \
+ LIBDIR="\$(PREFIX)/$(get_libdir)" \
+ SHLIBDIR="/$(get_libdir)" \
+ install
+}