summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Chernov <4ernov@gmail.com>2021-08-17 00:17:42 +0300
committerSam James <sam@gentoo.org>2021-09-28 02:45:15 +0100
commit19945b3429e7c2eb89b66c7ee4e054aec66d7cfe (patch)
tree11eca2d9e90f8ab76d46708313e52f9a011b066b /sys-libs
parentdev-db/oracle-instantclient: bump version to 21.3.0.0.0 (diff)
downloadgentoo-19945b3429e7c2eb89b66c7ee4e054aec66d7cfe.tar.gz
gentoo-19945b3429e7c2eb89b66c7ee4e054aec66d7cfe.tar.bz2
gentoo-19945b3429e7c2eb89b66c7ee4e054aec66d7cfe.zip
sys-libs/newlib: fix `libm_nano.a` installation
Add `libm_nano.a` installation in case of `nano` USE flag on, as it's now required in `nano.specs` for RISC V targets, in particular. See also: riscv/riscv-newlib@f289cef6be67da67b2d97a47d6576fa7e6b4c858 riscv/riscv-gnu-toolchain@2922650dd095747b07d6ced1b746d1faae07a01c Closes: https://github.com/gentoo/gentoo/pull/22007 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/newlib/newlib-4.1.0-r1.ebuild (renamed from sys-libs/newlib/newlib-4.1.0.ebuild)4
-rw-r--r--sys-libs/newlib/newlib-9999.ebuild4
2 files changed, 4 insertions, 4 deletions
diff --git a/sys-libs/newlib/newlib-4.1.0.ebuild b/sys-libs/newlib/newlib-4.1.0-r1.ebuild
index e16fd4c10b75..a5ec41db3c45 100644
--- a/sys-libs/newlib/newlib-4.1.0.ebuild
+++ b/sys-libs/newlib/newlib-4.1.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -136,7 +136,7 @@ src_install() {
emake -j1 DESTDIR="${NEWLIBNANOTMPINSTALL}" install
# Rename nano lib* files to lib*_nano and move to the real ${D}
local nanolibfiles=""
- nanolibfiles=$(find "${NEWLIBNANOTMPINSTALL}" -regex ".*/lib\(c\|g\|rdimon\)\.a" -print)
+ nanolibfiles=$(find "${NEWLIBNANOTMPINSTALL}" -regex ".*/lib\(c\|g\|m\|rdimon\)\.a" -print)
for f in ${nanolibfiles}; do
local l="${f##${NEWLIBNANOTMPINSTALL}}"
mv -v "${f}" "${D}/${l%%\.a}_nano.a" || die
diff --git a/sys-libs/newlib/newlib-9999.ebuild b/sys-libs/newlib/newlib-9999.ebuild
index e16fd4c10b75..a5ec41db3c45 100644
--- a/sys-libs/newlib/newlib-9999.ebuild
+++ b/sys-libs/newlib/newlib-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -136,7 +136,7 @@ src_install() {
emake -j1 DESTDIR="${NEWLIBNANOTMPINSTALL}" install
# Rename nano lib* files to lib*_nano and move to the real ${D}
local nanolibfiles=""
- nanolibfiles=$(find "${NEWLIBNANOTMPINSTALL}" -regex ".*/lib\(c\|g\|rdimon\)\.a" -print)
+ nanolibfiles=$(find "${NEWLIBNANOTMPINSTALL}" -regex ".*/lib\(c\|g\|m\|rdimon\)\.a" -print)
for f in ${nanolibfiles}; do
local l="${f##${NEWLIBNANOTMPINSTALL}}"
mv -v "${f}" "${D}/${l%%\.a}_nano.a" || die