summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-09-01 22:57:14 +0200
committerMichał Górny <mgorny@gentoo.org>2016-09-02 23:40:05 +0200
commit2113d786733d37734c7870094be25864cb77e3e7 (patch)
treea7fddec9a1c6c3d52396586615b61e1ff5e163cc /sys-libs
parentsys-libs/llvm-libunwind: Update maintainer to the LLVM project (diff)
downloadgentoo-2113d786733d37734c7870094be25864cb77e3e7.tar.gz
gentoo-2113d786733d37734c7870094be25864cb77e3e7.tar.bz2
gentoo-2113d786733d37734c7870094be25864cb77e3e7.zip
sys-libs/llvm-libunwind: Add a live ebuild
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild
new file mode 100644
index 000000000000..1dc0656f7c9e
--- /dev/null
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
+CMAKE_MIN_VERSION=3.4.3
+inherit cmake-utils git-r3
+
+DESCRIPTION="C++ runtime stack unwinder from LLVM"
+HOMEPAGE="https://github.com/llvm-mirror/libunwind"
+SRC_URI=""
+EGIT_REPO_URI="http://llvm.org/git/libunwind.git
+ https://github.com/llvm-mirror/libunwind.git"
+
+LICENSE="|| ( UoI-NCSA MIT )"
+SLOT="0"
+KEYWORDS=""
+IUSE="debug +static-libs"
+
+RDEPEND="!sys-libs/libunwind"
+# llvm-config and cmake files needed to get proper flags
+DEPEND=">=sys-devel/llvm-3.8.1-r2"
+
+src_configure() {
+ local libdir=$(get_libdir)
+
+ local mycmakeargs=(
+ -DLLVM_LIBDIR_SUFFIX=${libdir#lib}
+ -DLIBUNWIND_ENABLE_ASSERTIONS=$(usex debug)
+ -DLIBUNWIND_ENABLE_STATIC=$(usex static-libs)
+ )
+
+ cmake-utils_src_configure
+}