summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAric Belsito <lluixhi@gmail.com>2017-01-12 12:52:17 -0800
committerAnthony G. Basile <blueness@gentoo.org>2017-01-13 20:35:56 -0500
commit2a8b932a7c58338e111b42f6049c1d1ce75abef8 (patch)
tree649602f514046db767d73c311db32ab645599660 /sys-libs
parentdev-games/simgear: Security cleanup (bug #602658). (diff)
downloadgentoo-2a8b932a7c58338e111b42f6049c1d1ce75abef8.tar.gz
gentoo-2a8b932a7c58338e111b42f6049c1d1ce75abef8.tar.bz2
gentoo-2a8b932a7c58338e111b42f6049c1d1ce75abef8.zip
sys-libs/fts-standalone: Switch to musl-fts
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/fts-standalone/Manifest1
-rw-r--r--sys-libs/fts-standalone/fts-standalone-1.2.7.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/sys-libs/fts-standalone/Manifest b/sys-libs/fts-standalone/Manifest
index 4f58f869d5aa..25515d69ed97 100644
--- a/sys-libs/fts-standalone/Manifest
+++ b/sys-libs/fts-standalone/Manifest
@@ -1 +1,2 @@
DIST fts-0.2.tar.gz 339498 SHA256 4ee5db6449dc0fa4a83438616fd4bbed0f65b2123e56ac253cba5b25dbd9e056 SHA512 4f31182f4ebce7f663db893def0e2380b87ef1a262a021837fc6fc9965803a829217142df140c67b1cd83b292eb8862fa0a470cf795a312494674e6e94f02f79 WHIRLPOOL 23a55fc572189d827fc35849205296ac39d83d74ccab9431fb47b1eab7e2da8e196aca50b8161e9b9ea4a2f0e7471676a4f229f8c510c4b6af023beb5a5657b4
+DIST fts-standalone-1.2.7.tar.gz 19336 SHA256 49ae567a96dbab22823d045ffebe0d6b14b9b799925e9ca9274d47d26ff482a6 SHA512 949f73b9406b06bd8712c721b4ec89afcb37d4eaef5666cccf3712242d3a57fc0acf3ca994934e0f57c1e92f40521a9370132a21eb6d1957415a83c76bf20feb WHIRLPOOL c2ae59855a8093ca789d3d26e1300c89d8ca11cc4e60714e4a0364181feb82b9380beba8e034311ea0df13a62a64a6cbfbc485fc79b1c84c021895eb60c43d19
diff --git a/sys-libs/fts-standalone/fts-standalone-1.2.7.ebuild b/sys-libs/fts-standalone/fts-standalone-1.2.7.ebuild
new file mode 100644
index 000000000000..3922920ff035
--- /dev/null
+++ b/sys-libs/fts-standalone/fts-standalone-1.2.7.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Standalone fts library for use with musl"
+HOMEPAGE="https://github.com/pullmoll/musl-fts"
+SRC_URI="https://github.com/pullmoll/musl-fts/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~x86"
+IUSE="static-libs"
+
+DEPEND="
+ !sys-libs/glibc
+ !sys-libs/uclibc"
+
+S="${WORKDIR}/musl-fts-${PV}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+ mv "${ED%/}"/usr/$(get_libdir)/pkgconfig/{musl-fts,fts-standalone}.pc || die
+}