summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLei Zhang <zhanglei.april@gmail.com>2016-09-30 18:28:28 +0800
committerMichał Górny <mgorny@gentoo.org>2016-11-06 20:56:42 +0100
commit36865df46389e5f0b8055433b46d6e14d2ab4378 (patch)
tree3e69504fa9c82a010f4f6bc73523cd30caa42e2a /sys-libs
parentmedia-sound/gmusicbrowser: add gstreamer-1 support (diff)
downloadgentoo-36865df46389e5f0b8055433b46d6e14d2ab4378.tar.gz
gentoo-36865df46389e5f0b8055433b46d6e14d2ab4378.tar.bz2
gentoo-36865df46389e5f0b8055433b46d6e14d2ab4378.zip
sys-libs/libcxxabi: fix a compile error on musl
Closes: https://github.com/gentoo/gentoo/pull/2491 Package-Manager: portage-2.3.1
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libcxxabi/libcxxabi-3.9.0.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/sys-libs/libcxxabi/libcxxabi-3.9.0.ebuild b/sys-libs/libcxxabi/libcxxabi-3.9.0.ebuild
index 48c45199c980..2d5c58e671a7 100644
--- a/sys-libs/libcxxabi/libcxxabi-3.9.0.ebuild
+++ b/sys-libs/libcxxabi/libcxxabi-3.9.0.ebuild
@@ -18,7 +18,7 @@ SRC_URI="http://llvm.org/releases/${PV}/${P}.src.tar.xz
LICENSE="|| ( UoI-NCSA MIT )"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="libunwind +static-libs test"
+IUSE="elibc_musl libunwind +static-libs test"
RDEPEND="
libunwind? (
@@ -79,6 +79,9 @@ multilib_src_configure() {
-DLIT_COMMAND="${EPREFIX}"/usr/bin/lit
)
fi
+ if use elibc_musl; then
+ local -x CPPFLAGS="${CPPFLAGS} -D_LIBCPP_HAS_MUSL_LIBC=1"
+ fi
cmake-utils_src_configure
}