summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-07-29 11:27:56 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-07-29 14:17:43 +0200
commit39ecc4ecbb841d9c2d1025f67e7008e3e36e4cba (patch)
treec513c492808ae24c168691d3f5c76fc5df57e561 /sys-libs
parentsys-kernel/hardened-sources: version bump to 4.6.5 (diff)
downloadgentoo-39ecc4ecbb841d9c2d1025f67e7008e3e36e4cba.tar.gz
gentoo-39ecc4ecbb841d9c2d1025f67e7008e3e36e4cba.tar.bz2
gentoo-39ecc4ecbb841d9c2d1025f67e7008e3e36e4cba.zip
sys-libs/tdb: Bump to version 1.3.10
Package-Manager: portage-2.3.0 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/tdb/Manifest1
-rw-r--r--sys-libs/tdb/tdb-1.3.10.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/sys-libs/tdb/Manifest b/sys-libs/tdb/Manifest
index cc781f3a68ca..ee4a1f094d7f 100644
--- a/sys-libs/tdb/Manifest
+++ b/sys-libs/tdb/Manifest
@@ -1,2 +1,3 @@
+DIST tdb-1.3.10.tar.gz 494907 SHA256 5578fb726bd04835f250bea11fe7d1398fe0bb3a7c9390404241c83cd6b50c1c SHA512 044b0155db7755f271a040d36799a9482ba23fe9685ea7e80dcb4ac70c5aaa0f72ad7cd0c540e5d68e3d8339f795059ae4e0fbf938ad3cb4a73d8b35f25ac206 WHIRLPOOL 45122ba9364b49fe95ad2aadd9d063113a1e18e62b068d9c78c42406679a4c84db451ed4ddc61aa7fd60c2813e2ef712f5df1ef5bcb91567fe8f78bbe9b7191e
DIST tdb-1.3.8.tar.gz 494106 SHA256 0605ac0427eac9c23bf61ebfd8206a07d5ece198498eab1769cd0cfb6e7de6b1 SHA512 9a7040206bbaae419a296714fe14fcbd3b67c0cef2b0f33563d52336aac2fe814049f5136a148fb049a273bb36fe81e3d777df58869c93f45d6e42b4adf9970b WHIRLPOOL 61070a71aba9b44d5141844ffac6b4657ddc938850934fe00ff7312d9f76e1c318e37764b60fbac255ff5b8dc8d8226f668f80315fccdc67550eeb9bd1c4bc25
DIST tdb-1.3.9.tar.gz 493585 SHA256 7101f726e6d5c70f14e577b01c133e2e6059c4455239115e56a12ba64fc084d2 SHA512 ee724e54d6eef51cb368bccbf41a1ab326f3b618e8366d8b43b91953a30e4c486842cd7f41b83f613becb1e4117ce4831b1065d6efdcf14bb96b545ef1dd8175 WHIRLPOOL eb27d028b0f09c66e6e64783cd9bbf44d238bf70816879455ae59d268df7dd07ae0f9f4b634ac78224ca9b6b867e711b13cdb9aa75cfb6a2154d447def761d17
diff --git a/sys-libs/tdb/tdb-1.3.10.ebuild b/sys-libs/tdb/tdb-1.3.10.ebuild
new file mode 100644
index 000000000000..6f54a5a44321
--- /dev/null
+++ b/sys-libs/tdb/tdb-1.3.10.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="threads"
+
+inherit waf-utils multilib-minimal python-single-r1
+
+DESCRIPTION="A simple database API"
+HOMEPAGE="http://tdb.samba.org/"
+SRC_URI="http://samba.org/ftp/tdb/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="python"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+DEPEND="
+ ${RDEPEND}
+ ${PYTHON_DEPS}
+ app-text/docbook-xml-dtd:4.2"
+
+WAF_BINARY="${S}/buildtools/bin/waf"
+
+src_prepare() {
+ default
+ python_fix_shebang .
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ local extra_opts=()
+ if ! multilib_is_native_abi || ! use python; then
+ extra_opts+=( --disable-python )
+ fi
+
+ waf-utils_src_configure \
+ "${extra_opts[@]}"
+}
+
+multilib_src_compile() {
+ # need to avoid parallel building, this looks like the sanest way with waf-utils/multiprocessing eclasses
+ unset MAKEOPTS
+ waf-utils_src_compile
+}
+
+multilib_src_test() {
+ # the default src_test runs 'make test' and 'make check', letting
+ # the tests fail occasionally (reason: unknown)
+ emake check
+}
+
+multilib_src_install() {
+ waf-utils_src_install
+}