summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2018-06-30 23:10:04 -0500
committerMatthias Maier <tamiko@gentoo.org>2018-06-30 23:11:32 -0500
commit43ab7de243f9c14b9af63a97d68eaf8dcaf2d744 (patch)
tree4537f6fde7c6459349e47bb053c31de2743e288d /sys-libs
parentsys-libs/libunwind: fix compilation with musl (diff)
downloadgentoo-43ab7de243f9c14b9af63a97d68eaf8dcaf2d744.tar.gz
gentoo-43ab7de243f9c14b9af63a97d68eaf8dcaf2d744.tar.bz2
gentoo-43ab7de243f9c14b9af63a97d68eaf8dcaf2d744.zip
sys-libs/libunwind: drop obsolete
Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libunwind/Manifest1
-rw-r--r--sys-libs/libunwind/libunwind-1.2.ebuild101
2 files changed, 0 insertions, 102 deletions
diff --git a/sys-libs/libunwind/Manifest b/sys-libs/libunwind/Manifest
index 9e51cb805142..518d2e99343e 100644
--- a/sys-libs/libunwind/Manifest
+++ b/sys-libs/libunwind/Manifest
@@ -1,3 +1,2 @@
DIST libunwind-1.1.tar.gz 1098603 BLAKE2B c1ef0916c45786dcf820bef164f03e27af29f84d3173dc3a2e9fd54486a18d99713df152d810db4eb3e36df4afa7df1b544e6c9271479e2fcbffe473a17c4372 SHA512 bfe04f2bfac9f9e47c37f0b23ed2f264d8d3d3d6f1392fe9d794ee13cad216b3740979e922e4276fb65c1ccdc836fce48812cb5459ecdd2a89a621036a35d7c1
DIST libunwind-1.2.1.tar.gz 780774 BLAKE2B a5be4142e1e4932231023bdec2ab3ecd6b707faf2d32d2b571239252a1d0fb6a273a6a46c4a107db63f74f7b54c0c54cf252b8b79ad53216333ba7bcf63147a1 SHA512 af7c280d2a963779a4a2711887618bc96383011e4e5d52e4085aa7fb351e55e357468f6ff85e66a216f1c6826538f498335a917a5970575c93be74c96316319b
-DIST libunwind-1.2.tar.gz 747369 BLAKE2B e1f0d8361d9518cafc590bffb0056157a81928a1ae7d29a1f6f78f917cd73e922b24a42b03cdd6e2eb6f6dd6e4e51116f6d83d16a5d51046104204df45ab66a6 SHA512 985d0817944e3cafd99aaa5642862d878972e0851f7954289247e808c9319f399ca29342395f0571cb6568a1104a82bd92d585936f2ca888dda37ac796fde0d4
diff --git a/sys-libs/libunwind/libunwind-1.2.ebuild b/sys-libs/libunwind/libunwind-1.2.ebuild
deleted file mode 100644
index 8528582e02c7..000000000000
--- a/sys-libs/libunwind/libunwind-1.2.ebuild
+++ /dev/null
@@ -1,101 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-MY_PV=${PV/_/-}
-MY_P=${PN}-${MY_PV}
-inherit eutils libtool multilib-minimal
-
-DESCRIPTION="Portable and efficient API to determine the call-chain of a program"
-HOMEPAGE="https://savannah.nongnu.org/projects/libunwind"
-SRC_URI="mirror://nongnu/libunwind/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="7"
-KEYWORDS="~amd64 ~arm arm64 hppa ~ia64 ~mips ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
-IUSE="debug debug-frame doc libatomic lzma +static-libs"
-
-RESTRICT="test" #461958 -- re-enable tests with >1.1 again for retesting, this is here for #461394
-
-# We just use the header from libatomic.
-RDEPEND="lzma? ( app-arch/xz-utils )"
-DEPEND="${RDEPEND}
- libatomic? ( dev-libs/libatomic_ops )"
-
-QA_DT_NEEDED_x86_fbsd="usr/lib/libunwind.so.7.0.0"
-
-# Bug 586208
-CCACHE_NODIRECT=1
-
-S="${WORKDIR}/${MY_P}"
-
-MULTILIB_WRAPPED_HEADERS=(
- /usr/include/libunwind.h
-
- # see libunwind.h for the full list of arch-specific headers
- /usr/include/libunwind-aarch64.h
- /usr/include/libunwind-arm.h
- /usr/include/libunwind-hppa.h
- /usr/include/libunwind-ia64.h
- /usr/include/libunwind-mips.h
- /usr/include/libunwind-ppc32.h
- /usr/include/libunwind-ppc64.h
- /usr/include/libunwind-sh.h
- /usr/include/libunwind-tilegx.h
- /usr/include/libunwind-x86.h
- /usr/include/libunwind-x86_64.h
-)
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.2-coredump-regs.patch #586092
- epatch "${FILESDIR}"/${PN}-1.2-ia64-undwarf.patch
- epatch "${FILESDIR}"/${PN}-1.2-ia64-ptrace-coredump.patch
- epatch -p1 "${FILESDIR}"/${PN}-1.2-ia64-missing.patch
- chmod +x src/ia64/mk_cursor_i || die
-
- # These tests like to fail. bleh.
- echo 'int main(){return 0;}' > tests/Gtest-dyn1.c
- echo 'int main(){return 0;}' > tests/Ltest-dyn1.c
-
- # Since we have tests disabled via RESTRICT, disable building in the subdir
- # entirely. This worksaround some build errors too. #484846
- sed -i -e '/^SUBDIRS/s:tests::' Makefile.in || die
-
- elibtoolize
-}
-
-multilib_src_configure() {
- # --enable-cxx-exceptions: always enable it, headers provide the interface
- # and on some archs it is disabled by default causing a mismatch between the
- # API and the ABI, bug #418253
- # conservative-checks: validate memory addresses before use; as of 1.0.1,
- # only x86_64 supports this, yet may be useful for debugging, couple it with
- # debug useflag.
- ECONF_SOURCE="${S}" \
- ac_cv_header_atomic_ops_h=$(usex libatomic) \
- econf \
- --enable-cxx-exceptions \
- --enable-coredump \
- --enable-ptrace \
- --enable-setjmp \
- $(use_enable debug-frame) \
- $(use_enable doc documentation) \
- $(use_enable lzma minidebuginfo) \
- $(use_enable static-libs static) \
- $(use_enable debug conservative_checks) \
- $(use_enable debug)
-}
-
-multilib_src_test() {
- # Explicitly allow parallel build of tests.
- # Sandbox causes some tests to freak out.
- SANDBOX_ON=0 emake check
-}
-
-multilib_src_install() {
- default
- # libunwind-ptrace.a (and libunwind-ptrace.h) is separate API and without
- # shared library, so we keep it in any case
- use static-libs || find "${ED}"usr '(' -name 'libunwind-generic.a' -o -name 'libunwind*.la' ')' -delete
-}