summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-01-20 09:45:41 +0100
committerMichał Górny <mgorny@gentoo.org>2018-01-20 09:54:39 +0100
commit48920b4f7f2437c7fd9fb2bb1c6d907c1974b571 (patch)
tree8c7862ca0a1996203244125efd837ee5f49b2632 /sys-libs
parentsys-libs/libomp: Add flags to control offloading (to 6+) (diff)
downloadgentoo-48920b4f7f2437c7fd9fb2bb1c6d907c1974b571.tar.gz
gentoo-48920b4f7f2437c7fd9fb2bb1c6d907c1974b571.tar.bz2
gentoo-48920b4f7f2437c7fd9fb2bb1c6d907c1974b571.zip
sys-libs/compiler-rt: Bump LLVM macro dep to 6
Require macros provided by LLVM 6 due to new lit options.
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/compiler-rt/compiler-rt-6.0.9999.ebuild4
-rw-r--r--sys-libs/compiler-rt/compiler-rt-9999.ebuild4
2 files changed, 4 insertions, 4 deletions
diff --git a/sys-libs/compiler-rt/compiler-rt-6.0.9999.ebuild b/sys-libs/compiler-rt/compiler-rt-6.0.9999.ebuild
index 19b4ea1e2fd7..712fe0ab6fd0 100644
--- a/sys-libs/compiler-rt/compiler-rt-6.0.9999.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-6.0.9999.ebuild
@@ -25,9 +25,9 @@ IUSE="+clang test"
RESTRICT="!test? ( test ) !clang? ( test )"
LLVM_SLOT=${SLOT%%.*}
-# llvm-4 needed for --cmakedir
+# llvm-6 for new lit options
DEPEND="
- >=sys-devel/llvm-4
+ >=sys-devel/llvm-6
clang? ( sys-devel/clang )
test? (
$(python_gen_any_dep "~dev-python/lit-${PV}[\${PYTHON_USEDEP}]")
diff --git a/sys-libs/compiler-rt/compiler-rt-9999.ebuild b/sys-libs/compiler-rt/compiler-rt-9999.ebuild
index 4f525a8bc4d4..13a501b66836 100644
--- a/sys-libs/compiler-rt/compiler-rt-9999.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-9999.ebuild
@@ -24,9 +24,9 @@ IUSE="+clang test"
RESTRICT="!test? ( test ) !clang? ( test )"
LLVM_SLOT=${SLOT%%.*}
-# llvm-4 needed for --cmakedir
+# llvm-6 for new lit options
DEPEND="
- >=sys-devel/llvm-4
+ >=sys-devel/llvm-6
clang? ( sys-devel/clang )
test? (
$(python_gen_any_dep "~dev-python/lit-${PV}[\${PYTHON_USEDEP}]")