summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-08-29 21:18:01 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-08-29 22:28:25 +0200
commit51a6e539e17d17ab551c9b938fba565c1fe60d50 (patch)
tree4e2ace8ea6a4aecfb6b4d352af9048f1e842bc04 /sys-libs
parentsys-cluster/mpich: drop REQUIRED_USE (diff)
downloadgentoo-51a6e539e17d17ab551c9b938fba565c1fe60d50.tar.gz
gentoo-51a6e539e17d17ab551c9b938fba565c1fe60d50.tar.bz2
gentoo-51a6e539e17d17ab551c9b938fba565c1fe60d50.zip
sys-libs/tevent: Bump to version 0.9.30
Package-Manager: portage-2.3.0 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/tevent/Manifest1
-rw-r--r--sys-libs/tevent/tevent-0.9.30.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/sys-libs/tevent/Manifest b/sys-libs/tevent/Manifest
index d9820333963c..5873a71b99ae 100644
--- a/sys-libs/tevent/Manifest
+++ b/sys-libs/tevent/Manifest
@@ -1,3 +1,4 @@
DIST tevent-0.9.26.tar.gz 581664 SHA256 262c14d78ede13f2c4fc5e61485ae7250a201782d94735a1d8412652453370bd SHA512 cc841e4267cdda52d4e236040a82852a29a29427d7d374170cc74b4ff8ec0652f521580a1f69a9b4f2a66d8b2a6e3fcd34f21b2e94d0512dae848d271c090ec1 WHIRLPOOL df159329f30c9bd014be9b33b2f2e6ed1a47b7dd5af7fb964952d1e9aa7d7b72fc3028122b464c933c93253fd72b2f6248af5e7cfbb6d8cfb9259454804618d7
DIST tevent-0.9.28.tar.gz 581522 SHA256 04d953379025b1560af5c4ffcce58a3ee84db7aaa09c9f1e3eff5b2945a13529 SHA512 328d586a5891796a731e6f0d02e1a731d3541a977c16abca355359cd7f60bbdbb0baaad49c05eb42c3a44f97e57a775605974d22d46ca6c26f283c8ca1b5a909 WHIRLPOOL 3a572a1c73d564b535b15fca06a1df1ba124cac031026a1cabcbc66e38cac374eb8dad05a25372ab66982ff3c772ed63e890b62545dcce926fa782fe5fc21147
DIST tevent-0.9.29.tar.gz 584544 SHA256 a4f519b0bbb718fe2175bee9011ee4d199675f28c2ef80531be38e7bbaa1c42b SHA512 831289664d3ad22ac3e1a153e0433a583c4a090cd31e25ea7afc5d974c39c1fe5d36784ff5cfffcce344df69a0852a4098834abadfab8d723fe6b6d0d8e91594 WHIRLPOOL 23e6df7158747ee2ae702a3198d0c2716668242d795692bc5bb6ddaf9ff681c423e0026fb78dd3f4f13ac46ec352001e65147bd398eade4ab67f6aab6d23f339
+DIST tevent-0.9.30.tar.gz 587303 SHA256 5785915e6f76a8a7f7251055be1cef7a7465150a2f63d893082a1ab762c48cbd SHA512 bf3509cbddcc6a36b29cec3a7e5eb6699272a1b7dc66ccd7219e8c1b8daa591d886ac6bd77b35029f45b9e1e1bbe949fbb74ad5b3ddb684e886949f7d4103b1e WHIRLPOOL 83ac49438ce9a8092d97ae1315718cb6ed6c26d9abee5768eda47cdf92995576b1342553e793f61f1b2bf2fec684f142885f30a6f374c31c6c5ad94ddb39d717
diff --git a/sys-libs/tevent/tevent-0.9.30.ebuild b/sys-libs/tevent/tevent-0.9.30.ebuild
new file mode 100644
index 000000000000..ba458c3831f0
--- /dev/null
+++ b/sys-libs/tevent/tevent-0.9.30.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit waf-utils multilib-minimal python-single-r1
+
+DESCRIPTION="Samba tevent library"
+HOMEPAGE="http://tevent.samba.org/"
+SRC_URI="http://samba.org/ftp/tevent/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~arm-linux ~x86-linux"
+IUSE="python"
+
+RDEPEND=">=sys-libs/talloc-2.1.8[${MULTILIB_USEDEP}]
+ python? ( ${PYTHON_DEPS} )"
+
+DEPEND="${RDEPEND}
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+ ${PYTHON_DEPS}
+"
+# build system does not work with python3
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+WAF_BINARY="${S}/buildtools/bin/waf"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ waf-utils_src_configure \
+ $(multilib_native_usex python '' '--disable-python')
+}
+
+multilib_src_compile() {
+ # need to avoid parallel building, this looks like the sanest way with waf-utils/multiprocessing eclasses
+ unset MAKEOPTS
+ waf-utils_src_compile
+}
+
+multilib_src_install() {
+ waf-utils_src_install
+
+ multilib_is_native_abi && use python && python_domodule tevent.py
+}