summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLei Zhang <zhanglei.april@gmail.com>2016-09-03 19:30:01 +0800
committerAlexis Ballier <aballier@gentoo.org>2016-10-03 10:51:20 +0200
commit6d628e49032d182a45ee5b9150911ade92b570c9 (patch)
treeaf149500482d299f58a1d42294aa253b12edf3f6 /sys-libs
parentpackage.mask: mask libcxx-3.9 (diff)
downloadgentoo-6d628e49032d182a45ee5b9150911ade92b570c9.tar.gz
gentoo-6d628e49032d182a45ee5b9150911ade92b570c9.tar.bz2
gentoo-6d628e49032d182a45ee5b9150911ade92b570c9.zip
sys-libs/libcxx: version bump to 3.9.0
to synchronize with live ebuild.
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libcxx/Manifest2
-rw-r--r--sys-libs/libcxx/files/libcxx-3.9-cmake-static-lib.patch196
-rw-r--r--sys-libs/libcxx/libcxx-3.9.0.ebuild196
3 files changed, 394 insertions, 0 deletions
diff --git a/sys-libs/libcxx/Manifest b/sys-libs/libcxx/Manifest
index 8e2fb798a748..d6884e00cd7a 100644
--- a/sys-libs/libcxx/Manifest
+++ b/sys-libs/libcxx/Manifest
@@ -2,3 +2,5 @@ DIST libcxx-3.7.0.src.tar.xz 994580 SHA256 c18f3c8333cd7e678c1424a57fe5e25efe740
DIST libcxx-3.7.1.src.tar.xz 995724 SHA256 357fbd4288ce99733ba06ae2bec6f503413d258aeebaab8b6a791201e6f7f144 SHA512 08d2399a8b36aa15290733256c896c9fa43f1a1223bc5c73bbcd014fddf8880e514d2a6dcc456bcf18b537c01fb6911b092e6d9958bccd8e64e9f375ed7a1ab9 WHIRLPOOL 19f77946abf48cbdd3e7ea21fd009ca3cc5f607dfe0512a44b102847044bb1d5ae4b16f503f18b14ebd9ea115256e87af07409907ba2a65f6061e217a502a359
DIST libcxx-3.8.0.src.tar.xz 1062884 SHA256 36804511b940bc8a7cefc7cb391a6b28f5e3f53f6372965642020db91174237b SHA512 3a9f0c9b4b0c22757028800b28c5fd7b28fc79d0cbf33cad2087de493dc778c93f2df4b919f162638d883069f60a633f36ddc18d7da8ae00c6af409266a05e6b WHIRLPOOL 6f1328c8b220f91d15f6644e34dd74e3d204ee0ee56769df4442d14b884e31626a289e6ab5e7d075438c7527b2efde92763b362791914bcd18c269405c9c7c8e
DIST libcxx-3.8.1.src.tar.xz 1074164 SHA256 77d7f3784c88096d785bd705fa1bab7031ce184cd91ba8a7008abf55264eeecc SHA512 782ff3cdb85d02e92404e943474d0266ff601725c202f0667d60e7807f1ba3cfdebbdb062e27a52fec96be1c99339044be93a88ba7e396682f98d99c9ac175b2 WHIRLPOOL a729c44060972edee79b0019fd4c6c23fa56dd625e564f4c5965682d9fc79be4094df0643f67c5d2ffa3ae3c743c892c3c9ba19719b2307aada35775f64ed104
+DIST libcxx-3.9.0.src.tar.xz 1198308 SHA256 d0b38d51365c6322f5666a2a8105785f2e114430858de4c25a86b49f227f5b06 SHA512 55d5c4adff378ee02b0b99d732bc9f326910f9e49ab8c320a588eccdd0362fe009bc9a6a4337d29faf6338420c91b10d0d7d67f66128268f01258d30502c4f4a WHIRLPOOL 3ee3519acfe95287a862a6c44e30ed52ced1204332913007797da4e4da40dfdc5991ae120f5686827cc208b559936da5bc5485dab75617bdd5cbbd9e95a6032a
+DIST llvm-3.9.0.src.tar.xz 18235716 SHA256 66c73179da42cee1386371641241f79ded250e117a79f571bbd69e56daa48948 SHA512 f18ae32531218ab156c3e56c11826be0fd05f0799c82eaf2e6a043b38e1277560b4d921987513b88b11d97ea2619feaf277eec72181dd2ae4f4108c2836bf7b2 WHIRLPOOL a36c1bcee6e7995067a9a7a51e3fdb0f10d51d0239250eefab92ed2e46b024a203fa10a17a25a5aca69046bcb413628e288427f1a6690d0862e07cd95694c8a8
diff --git a/sys-libs/libcxx/files/libcxx-3.9-cmake-static-lib.patch b/sys-libs/libcxx/files/libcxx-3.9-cmake-static-lib.patch
new file mode 100644
index 000000000000..5f0e31864dfd
--- /dev/null
+++ b/sys-libs/libcxx/files/libcxx-3.9-cmake-static-lib.patch
@@ -0,0 +1,196 @@
+From b640da0b315ead39690d4d65c76938ab8aeb5449 Mon Sep 17 00:00:00 2001
+From: Petr Hosek <phosek@chromium.org>
+Date: Mon, 8 Aug 2016 22:57:25 +0000
+Subject: [PATCH] Allow building both shared and static library
+
+This change allows building both shared and static version of libc++
+in a single build, sharing object files between both versions.
+
+Differential Revision: https://reviews.llvm.org/D23232
+
+git-svn-id: https://llvm.org/svn/llvm-project/libcxx/trunk@278068 91177308-0d34-0410-b5e6-96231b3b80d8
+---
+ CMakeLists.txt | 5 ++++
+ docs/BuildingLibcxx.rst | 11 ++++++--
+ lib/CMakeLists.txt | 71 ++++++++++++++++++++++++++++++++++---------------
+ 3 files changed, 63 insertions(+), 24 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 950070d..98886b0 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -52,6 +52,7 @@ MACRO_ENSURE_OUT_OF_SOURCE_BUILD(
+ # Basic options ---------------------------------------------------------------
+ option(LIBCXX_ENABLE_ASSERTIONS "Enable assertions independent of build mode." ON)
+ option(LIBCXX_ENABLE_SHARED "Build libc++ as a shared library." ON)
++option(LIBCXX_ENABLE_STATIC "Build libc++ as a static library." ON)
+ option(LIBCXX_ENABLE_EXPERIMENTAL_LIBRARY "Build libc++experimental.a" ON)
+ option(LIBCXX_ENABLE_FILESYSTEM
+ "Build filesystem as part of libc++experimental.a" ${LIBCXX_ENABLE_EXPERIMENTAL_LIBRARY})
+@@ -68,6 +69,10 @@ option(LIBCXX_INSTALL_EXPERIMENTAL_LIBRARY "Install libc++experimental.a" OFF)
+ set(LIBCXX_ABI_VERSION 1 CACHE STRING "ABI version of libc++.")
+ option(LIBCXX_ABI_UNSTABLE "Unstable ABI of libc++." OFF)
+
++if (NOT LIBCXX_ENABLE_SHARED AND NOT LIBCXX_ENABLE_STATIC)
++ message(FATAL_ERROR "libc++ must be built as either a shared or static library.")
++endif()
++
+ # ABI Library options ---------------------------------------------------------
+ set(LIBCXX_CXX_ABI "${LIBCXX_CXX_ABI}" CACHE STRING
+ "Specify C++ ABI library to use." FORCE)
+diff --git a/docs/BuildingLibcxx.rst b/docs/BuildingLibcxx.rst
+index 5dd174a..6709352 100644
+--- a/docs/BuildingLibcxx.rst
++++ b/docs/BuildingLibcxx.rst
+@@ -150,8 +150,15 @@ libc++ specific options
+
+ **Default**: ``ON``
+
+- Build libc++ as a shared library. If ``OFF`` is specified then libc++ is
+- built as a static library.
++ Build libc++ as a shared library. Either :option:`LIBCXX_ENABLE_SHARED` or
++ :option:`LIBCXX_ENABLE_STATIC` has to be enabled.
++
++.. option:: LIBCXX_ENABLE_STATIC:BOOL
++
++ **Default**: ``ON``
++
++ Build libc++ as a static library. Either :option:`LIBCXX_ENABLE_SHARED` or
++ :option:`LIBCXX_ENABLE_STATIC` has to be enabled.
+
+ .. option:: LIBCXX_LIBDIR_SUFFIX:STRING
+
+diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
+index afc388e..cabf2e6 100644
+--- a/lib/CMakeLists.txt
++++ b/lib/CMakeLists.txt
+@@ -28,16 +28,6 @@ if(NOT LIBCXX_INSTALL_LIBRARY)
+ set(exclude_from_all EXCLUDE_FROM_ALL)
+ endif()
+
+-if (LIBCXX_ENABLE_SHARED)
+- add_library(cxx SHARED ${exclude_from_all} ${LIBCXX_SOURCES} ${LIBCXX_HEADERS})
+-else()
+- add_library(cxx STATIC ${exclude_from_all} ${LIBCXX_SOURCES} ${LIBCXX_HEADERS})
+-endif()
+-
+-if (DEFINED LIBCXX_CXX_ABI_DEPS)
+- add_dependencies(cxx LIBCXX_CXX_ABI_DEPS)
+-endif()
+-
+ #if LIBCXX_CXX_ABI_LIBRARY_PATH is defined we want to add it to the search path.
+ add_link_flags_if(LIBCXX_CXX_ABI_LIBRARY_PATH "-L${LIBCXX_CXX_ABI_LIBRARY_PATH}")
+
+@@ -139,18 +129,51 @@ if ( APPLE AND (LIBCXX_CXX_ABI_LIBNAME STREQUAL "libcxxabi" OR
+ endif()
+ endif()
+
+-target_link_libraries(cxx ${LIBCXX_LIBRARIES})
+ split_list(LIBCXX_COMPILE_FLAGS)
+ split_list(LIBCXX_LINK_FLAGS)
+
+-set_target_properties(cxx
++# Add a object library that contains the compiled source files.
++add_library(cxx_objects OBJECT ${exclude_from_all} ${LIBCXX_SOURCES} ${LIBCXX_HEADERS})
++
++set_target_properties(cxx_objects
+ PROPERTIES
+ COMPILE_FLAGS "${LIBCXX_COMPILE_FLAGS}"
+- LINK_FLAGS "${LIBCXX_LINK_FLAGS}"
+- OUTPUT_NAME "c++"
+- VERSION "${LIBCXX_ABI_VERSION}.0"
+- SOVERSION "${LIBCXX_ABI_VERSION}"
++)
++
++set(LIBCXX_TARGETS)
++
++# Build the shared library.
++if (LIBCXX_ENABLE_SHARED)
++ add_library(cxx_shared SHARED $<TARGET_OBJECTS:cxx_objects>)
++ target_link_libraries(cxx_shared ${LIBCXX_LIBRARIES})
++ set_target_properties(cxx_shared
++ PROPERTIES
++ LINK_FLAGS "${LIBCXX_LINK_FLAGS}"
++ OUTPUT_NAME "c++"
++ VERSION "${LIBCXX_ABI_VERSION}.0"
++ SOVERSION "${LIBCXX_ABI_VERSION}"
+ )
++ list(APPEND LIBCXX_TARGETS "cxx_shared")
++endif()
++
++# Build the static library.
++if (LIBCXX_ENABLE_STATIC)
++ add_library(cxx_static STATIC $<TARGET_OBJECTS:cxx_objects>)
++ target_link_libraries(cxx_static ${LIBCXX_LIBRARIES})
++ set_target_properties(cxx_static
++ PROPERTIES
++ LINK_FLAGS "${LIBCXX_LINK_FLAGS}"
++ OUTPUT_NAME "c++"
++ )
++ list(APPEND LIBCXX_TARGETS "cxx_static")
++endif()
++
++# Add a meta-target for both libraries.
++add_custom_target(cxx DEPENDS ${LIBCXX_TARGETS})
++
++if (DEFINED LIBCXX_CXX_ABI_DEPS)
++ add_dependencies(cxx LIBCXX_CXX_ABI_DEPS)
++endif()
+
+ if (LIBCXX_ENABLE_EXPERIMENTAL_LIBRARY)
+ file(GLOB LIBCXX_EXPERIMENTAL_SOURCES ../src/experimental/*.cpp)
+@@ -158,7 +181,11 @@ if (LIBCXX_ENABLE_EXPERIMENTAL_LIBRARY)
+ file(GLOB LIBCXX_FILESYSTEM_SOURCES ../src/experimental/filesystem/*.cpp)
+ endif()
+ add_library(cxx_experimental STATIC ${LIBCXX_EXPERIMENTAL_SOURCES} ${LIBCXX_FILESYSTEM_SOURCES})
+- target_link_libraries(cxx_experimental cxx)
++ if (LIBCXX_ENABLE_SHARED)
++ target_link_libraries(cxx_experimental cxx_shared)
++ else()
++ target_link_libraries(cxx_experimental cxx_static)
++ endif()
+
+ set(experimental_flags "${LIBCXX_COMPILE_FLAGS}")
+ check_flag_supported(-std=c++14)
+@@ -174,7 +201,7 @@ endif()
+
+ # Generate a linker script inplace of a libc++.so symlink. Rerun this command
+ # after cxx builds.
+-if (LIBCXX_ENABLE_ABI_LINKER_SCRIPT)
++if (LIBCXX_ENABLE_SHARED AND LIBCXX_ENABLE_ABI_LINKER_SCRIPT)
+ # Get the name of the ABI library and handle the case where CXXABI_LIBNAME
+ # is a target name and not a library. Ex cxxabi_shared.
+ set(SCRIPT_ABI_LIBNAME "${LIBCXX_CXX_ABI_LIBRARY}")
+@@ -183,11 +210,11 @@ if (LIBCXX_ENABLE_ABI_LINKER_SCRIPT)
+ endif()
+ # Generate a linker script inplace of a libc++.so symlink. Rerun this command
+ # after cxx builds.
+- add_custom_command(TARGET cxx POST_BUILD
++ add_custom_command(TARGET cxx_shared POST_BUILD
+ COMMAND
+ ${PYTHON_EXECUTABLE} ${LIBCXX_SOURCE_DIR}/utils/gen_link_script/gen_link_script.py
+ ARGS
+- "$<TARGET_LINKER_FILE:cxx>"
++ "$<TARGET_LINKER_FILE:cxx_shared>"
+ "${SCRIPT_ABI_LIBNAME}"
+ WORKING_DIRECTORY ${LIBCXX_BUILD_DIR}
+ )
+@@ -197,13 +224,13 @@ if (LIBCXX_INSTALL_LIBRARY)
+ if (LIBCXX_INSTALL_EXPERIMENTAL_LIBRARY)
+ set(experimental_lib cxx_experimental)
+ endif()
+- install(TARGETS cxx ${experimental_lib}
++ install(TARGETS ${LIBCXX_TARGETS} ${experimental_lib}
+ LIBRARY DESTINATION lib${LIBCXX_LIBDIR_SUFFIX} COMPONENT libcxx
+ ARCHIVE DESTINATION lib${LIBCXX_LIBDIR_SUFFIX} COMPONENT libcxx
+ )
+ # NOTE: This install command must go after the cxx install command otherwise
+ # it will not be executed after the library symlinks are installed.
+- if (LIBCXX_ENABLE_ABI_LINKER_SCRIPT)
++ if (LIBCXX_ENABLE_SHARED AND LIBCXX_ENABLE_ABI_LINKER_SCRIPT)
+ # Replace the libc++ filename with $<TARGET_LINKER_FILE:cxx>
+ # after we required CMake 3.0.
+ install(FILES "${LIBCXX_LIBRARY_DIR}/libc++${CMAKE_SHARED_LIBRARY_SUFFIX}"
+--
+2.4.10
+
diff --git a/sys-libs/libcxx/libcxx-3.9.0.ebuild b/sys-libs/libcxx/libcxx-3.9.0.ebuild
new file mode 100644
index 000000000000..25e0b69355e1
--- /dev/null
+++ b/sys-libs/libcxx/libcxx-3.9.0.ebuild
@@ -0,0 +1,196 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# Ninja provides better scalability and cleaner verbose output, and is used
+# throughout all LLVM projects.
+: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
+EGIT_REPO_URI="http://llvm.org/git/libcxx.git
+ https://github.com/llvm-mirror/libcxx.git"
+CMAKE_MIN_VERSION=3.4.3
+PYTHON_COMPAT=( python2_7 )
+
+[[ ${PV} == 9999 ]] && SCM="git-r3" || SCM=""
+
+inherit ${SCM} cmake-multilib python-any-r1 toolchain-funcs
+
+DESCRIPTION="New implementation of the C++ standard library, targeting C++11"
+HOMEPAGE="http://libcxx.llvm.org/"
+if [[ ${PV} != 9999 ]] ; then
+ SRC_URI="http://llvm.org/releases/${PV}/${P}.src.tar.xz
+ test? ( http://llvm.org/releases/${PV}/llvm-${PV}.src.tar.xz )"
+ S="${WORKDIR}/${P}.src"
+ LLVM_S="${WORKDIR}/llvm-${PV}.src"
+else
+ SRC_URI=""
+ LLVM_S="${WORKDIR}/llvm"
+fi
+
+LICENSE="|| ( UoI-NCSA MIT )"
+SLOT="0"
+if [[ ${PV} != 9999 ]] ; then
+ KEYWORDS="~amd64 ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+else
+ KEYWORDS=""
+fi
+IUSE="elibc_glibc elibc_musl +libcxxrt libunwind +static-libs test"
+REQUIRED_USE="libunwind? ( libcxxrt )"
+
+RDEPEND="libcxxrt? ( sys-libs/libcxxrt[libunwind=,static-libs?,${MULTILIB_USEDEP}] )
+ !libcxxrt? ( >=sys-devel/gcc-4.7:=[cxx] )"
+# llvm-3.9.0 needed because its cmake files installation path changed, which is
+# needed by libcxx
+DEPEND="${RDEPEND}
+ test? ( sys-devel/clang[${MULTILIB_USEDEP}]
+ ${PYTHON_DEPS} )
+ app-arch/xz-utils
+ >=sys-devel/llvm-3.9.0[${MULTILIB_USEDEP}]"
+
+DOCS=( CREDITS.TXT )
+
+PATCHES=(
+ # Add link flag "-Wl,-z,defs" to avoid underlinking; this is needed in a
+ # out-of-tree build.
+ "${FILESDIR}/${PN}-3.9-cmake-link-flags.patch"
+
+ # Back-port of https://reviews.llvm.org/D23232, allowing building both
+ # shared and static libs in one run.
+ "${FILESDIR}/${PN}-3.9-cmake-static-lib.patch"
+)
+
+pkg_setup() {
+ use test && python_setup
+
+ if ! use libcxxrt && ! tc-is-gcc ; then
+ eerror "To build ${PN} against libsupc++, you have to use gcc. Other"
+ eerror "compilers are not supported. Please set CC=gcc and CXX=g++"
+ eerror "and try again."
+ die
+ fi
+ if tc-is-gcc && [[ $(gcc-version) < 4.7 ]] ; then
+ eerror "${PN} needs to be built with gcc-4.7 or later (or other"
+ eerror "conformant compilers). Please use gcc-config to switch to"
+ eerror "gcc-4.7 or later version."
+ die
+ fi
+}
+
+src_unpack() {
+ [[ ${PV} != 9999 ]] && default && return
+
+ if use test; then
+ # needed for tests
+ git-r3_fetch "http://llvm.org/git/llvm.git
+ https://github.com/llvm-mirror/llvm.git"
+ fi
+ git-r3_fetch
+
+ if use test; then
+ git-r3_checkout http://llvm.org/git/llvm.git \
+ "${WORKDIR}"/llvm
+ fi
+ git-r3_checkout
+}
+
+multilib_src_configure() {
+ local cxxabi cxxabi_incs
+ if use libcxxrt; then
+ cxxabi=libcxxrt
+ cxxabi_incs="${EPREFIX}/usr/include/libcxxrt"
+ else
+ local gcc_inc="${EPREFIX}/usr/lib/gcc/${CHOST}/$(gcc-fullversion)/include/g++-v$(gcc-major-version)"
+ cxxabi=libsupc++
+ cxxabi_incs="${gcc_inc};${gcc_inc}/${CHOST}"
+ fi
+
+ local libdir=$(get_libdir)
+ local mycmakeargs=(
+ -DLLVM_LIBDIR_SUFFIX=${libdir#lib}
+ -DLIBCXX_ENABLE_SHARED=ON
+ -DLIBCXX_ENABLE_STATIC=$(usex static-libs)
+ -DLIBCXX_CXX_ABI=${cxxabi}
+ -DLIBCXX_CXX_ABI_INCLUDE_PATHS=${cxxabi_incs}
+ # we're using our own mechanism for generating linker scripts
+ -DLIBCXX_ENABLE_ABI_LINKER_SCRIPT=OFF
+ -DLIBCXX_HAS_MUSL_LIBC=$(usex elibc_musl)
+ -DLIBCXX_HAS_GCC_S_LIB=$(usex !libunwind)
+ -DLIBCXX_INCLUDE_TESTS=$(usex test)
+ -DCMAKE_SHARED_LINKER_FLAGS=$(usex libunwind "-lunwind" "")
+ )
+ if use test; then
+ mycmakeargs+=(
+ -DLLVM_MAIN_SRC_DIR=${LLVM_S}
+ )
+ fi
+ cmake-utils_src_configure
+}
+
+multilib_src_test() {
+ local clang_path=$(type -P "${CHOST:+${CHOST}-}clang" 2>/dev/null)
+
+ [[ -n ${clang_path} ]] || die "Unable to find ${CHOST}-clang for tests"
+ sed -i -e "/cxx_under_test/s^\".*\"^\"${clang_path}\"^" test/lit.site.cfg || die
+
+ cmake-utils_src_make check-libcxx
+}
+
+# Usage: deps
+gen_ldscript() {
+ local output_format
+ output_format=$($(tc-getCC) ${CFLAGS} ${LDFLAGS} -Wl,--verbose 2>&1 | sed -n 's/^OUTPUT_FORMAT("\([^"]*\)",.*/\1/p')
+ [[ -n ${output_format} ]] && output_format="OUTPUT_FORMAT ( ${output_format} )"
+
+ cat <<-END_LDSCRIPT
+/* GNU ld script
+ Include missing dependencies
+*/
+${output_format}
+GROUP ( $@ )
+END_LDSCRIPT
+}
+
+gen_static_ldscript() {
+ local libdir=$(get_libdir)
+ local cxxabi_lib=$(usex libcxxrt "libcxxrt.a" "libsupc++.a")
+
+ # Move it first.
+ mv "${ED}/usr/${libdir}/libc++.a" "${ED}/usr/${libdir}/libc++_static.a" || die
+ # Generate libc++.a ldscript for inclusion of its dependencies so that
+ # clang++ -stdlib=libc++ -static works out of the box.
+ local deps="libc++_static.a ${cxxabi_lib}"
+ # On Linux/glibc it does not link without libpthread or libdl. It is
+ # fine on FreeBSD.
+ use elibc_glibc && deps+=" libpthread.a libdl.a"
+ # unlike libgcc_s, libunwind is not implicitly linked
+ use libunwind && deps+=" libunwind.a"
+
+ gen_ldscript "${deps}" > "${ED}/usr/${libdir}/libc++.a" || die
+}
+
+gen_shared_ldscript() {
+ local libdir=$(get_libdir)
+ # libsupc++ doesn't have a shared version
+ local cxxabi_lib=$(usex libcxxrt "libcxxrt.so" "libsupc++.a")
+
+ mv "${ED}/usr/${libdir}/libc++.so" "${ED}/usr/${libdir}/libc++_shared.so" || die
+ local deps="libc++_shared.so ${cxxabi_lib}"
+ use libunwind && deps+=" libunwind.so"
+
+ gen_ldscript "${deps}" > "${ED}/usr/${libdir}/libc++.so" || die
+}
+
+multilib_src_install() {
+ cmake-utils_src_install
+ gen_shared_ldscript
+ use static-libs && gen_static_ldscript
+}
+
+pkg_postinst() {
+ elog "This package (${PN}) is mainly intended as a replacement for the C++"
+ elog "standard library when using clang."
+ elog "To use it, instead of libstdc++, use:"
+ elog " clang++ -stdlib=libc++"
+ elog "to compile your C++ programs."
+}