summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-03-25 14:34:29 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-03-25 16:00:29 +0100
commit8202cf94bbd05ad80503287efaabdd6c12e3fedc (patch)
tree36482fdf6a0e784595ccc5a05eb3c3441749ffaa /sys-libs
parentsys-libs/tevent: Bump to version 0.10.0 (diff)
downloadgentoo-8202cf94bbd05ad80503287efaabdd6c12e3fedc.tar.gz
gentoo-8202cf94bbd05ad80503287efaabdd6c12e3fedc.tar.bz2
gentoo-8202cf94bbd05ad80503287efaabdd6c12e3fedc.zip
sys-libs/ldb: Bump to version 1.6.3
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/ldb/Manifest1
-rw-r--r--sys-libs/ldb/ldb-1.6.3.ebuild105
2 files changed, 106 insertions, 0 deletions
diff --git a/sys-libs/ldb/Manifest b/sys-libs/ldb/Manifest
index d2e1e64a46e4..2aa9b8ad86a7 100644
--- a/sys-libs/ldb/Manifest
+++ b/sys-libs/ldb/Manifest
@@ -8,3 +8,4 @@ DIST ldb-1.3.8.tar.gz 1375782 BLAKE2B dbca935e762af86b268308253615019b24af672741
DIST ldb-1.4.6.tar.gz 1431798 BLAKE2B 748d6054af4b898fa475692a425d96541fa2c055ffdd4b8ca6635fea04d7b143b4e7301886f307300662140bc449a3ee3932801c7c5df10f6ba3ee5a10c7a46b SHA512 fb2be7842ecfda8788e8982831e34487f016814d1e8a757e93f8716019aaba4b9b7dd469e4ba11eb3990846fb55cdb2db2ec494eb7b0ff04f261d8309b1c98f4
DIST ldb-1.5.4.tar.gz 1629123 BLAKE2B 3c71af079f2e5cb81e493d16d453c53bd0ee4c63720b0261ea6116244b2652ca581499c0b8c64949dccc95460aba7b4ef3afe7850563a830f3fb4b8753bdea2f SHA512 fc323e4283671c14d6dd4feb7e9ca943a63a166688077dbf3591f9d957cf821f9e739869842e15ca1ec4fd3764123d5afc6f4954b1af437bd1ec54df58366a22
DIST ldb-1.6.2.tar.gz 1629794 BLAKE2B 5219479c773aa87c4bd6917e60b963df9cf3c481468ed020b4e9c4a175110ce80fd1c7a4ca4e28d99c972e0891287485261310eab1bbd7b8b138ea59f168ac8c SHA512 089dee2465efe0811ff745b52b15d2d7638b940112a06680706d5401231864859605ff0392245d4c815e9b85f5a4ba782fc61d8dba215cc8198e7d9a6ddd255e
+DIST ldb-1.6.3.tar.gz 1628668 BLAKE2B e9b6535eddf49496151e544f6879641c58a614f6de95463f7d0bf1953744953a5d55dde935d39b690d4c87e66914d8de0f0f5d4816a61fdecc81f8797584013e SHA512 a41b1fd2afa9a02dec37519f28e0e720b649c2a0aa6caebeb6697dbefdc6a055ef26500c5ccb0439b495d8c03218920b389fb9601d1cf5ca4d5046f192a5fefd
diff --git a/sys-libs/ldb/ldb-1.6.3.ebuild b/sys-libs/ldb/ldb-1.6.3.ebuild
new file mode 100644
index 000000000000..a004ed3f1c6d
--- /dev/null
+++ b/sys-libs/ldb/ldb-1.6.3.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5,6,7} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit python-single-r1 waf-utils multilib-minimal eutils
+
+DESCRIPTION="An LDAP-like embedded database"
+HOMEPAGE="https://ldb.samba.org"
+SRC_URI="https://www.samba.org/ftp/pub/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="doc +ldap +lmdb python"
+
+RDEPEND="
+ !elibc_FreeBSD? ( dev-libs/libbsd[${MULTILIB_USEDEP}] )
+ dev-libs/popt[${MULTILIB_USEDEP}]
+ >=dev-util/cmocka-1.1.3[${MULTILIB_USEDEP}]
+ >=sys-libs/talloc-2.1.16[python?,${MULTILIB_USEDEP}]
+ >=sys-libs/tdb-1.3.18[python?,${MULTILIB_USEDEP}]
+ >=sys-libs/tevent-0.9.39[python(+)?,${MULTILIB_USEDEP}]
+ ldap? ( net-nds/openldap )
+ lmdb? ( >=dev-db/lmdb-0.9.16[${MULTILIB_USEDEP}] )
+ python? ( ${PYTHON_DEPS} )
+"
+
+DEPEND="dev-libs/libxslt
+ doc? ( app-doc/doxygen )
+ virtual/pkgconfig
+ ${PYTHON_DEPS}
+ ${RDEPEND}
+"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+WAF_BINARY="${S}/buildtools/bin/waf"
+
+MULTILIB_WRAPPED_HEADERS=( /usr/include/pyldb.h )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.5.2-optional_packages.patch
+ "${FILESDIR}"/${PN}-1.1.31-fix_PKGCONFIGDIR-when-python-disabled.patch
+)
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ local myconf=(
+ $(usex ldap '' --disable-ldap)
+ $(usex lmdb '' --without-ldb-lmdb)
+ --disable-rpath
+ --disable-rpath-install --bundled-libraries=NONE
+ --with-modulesdir="${EPREFIX}"/usr/$(get_libdir)/samba
+ --builtin-libraries=NONE
+ )
+ if ! multilib_is_native_abi; then
+ myconf+=( --disable-python )
+ else
+ use python || myconf+=( --disable-python )
+ fi
+ waf-utils_src_configure "${myconf[@]}"
+}
+
+multilib_src_compile(){
+ waf-utils_src_compile
+ multilib_is_native_abi && use doc && doxygen Doxyfile
+}
+
+multilib_src_test() {
+ if multilib_is_native_abi; then
+ WAF_MAKE=1 \
+ PATH=buildtools/bin:../../../buildtools/bin:$PATH:"${BUILD_DIR}"/bin/shared/private/ \
+ LD_LIBRARY_PATH=$LD_LIBRARY_PATH:"${BUILD_DIR}"/bin/shared/private/:"${BUILD_DIR}"/bin/shared \
+ waf test || die
+ fi
+}
+
+multilib_src_install() {
+ waf-utils_src_install
+
+ if multilib_is_native_abi && use doc; then
+ doman apidocs/man/man3/*.3
+ docinto html
+ dodoc -r apidocs/html/*
+ fi
+}
+
+pkg_postinst() {
+ if has_version sys-auth/sssd; then
+ ewarn "You have sssd installed. It is known to break after ldb upgrades,"
+ ewarn "so please try to rebuild it before reporting bugs."
+ ewarn "See https://bugs.gentoo.org/404281"
+ fi
+}