summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-11-27 23:47:10 +0000
committerSam James <sam@gentoo.org>2021-11-27 23:47:27 +0000
commit89a6a8647d74612648f0502baa27660008cc256c (patch)
tree34bbcfb85bb5ee718b362a8032dcf74f9cc226d7 /sys-libs
parentnet-libs/libnpupnp: remove old (diff)
downloadgentoo-89a6a8647d74612648f0502baa27660008cc256c.tar.gz
gentoo-89a6a8647d74612648f0502baa27660008cc256c.tar.bz2
gentoo-89a6a8647d74612648f0502baa27660008cc256c.zip
sys-libs/glibc: don't apply GCC 11 AVX512 workaround to upcoming patch release
Bug: https://bugs.gentoo.org/823780 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/glibc-2.34-r2.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/sys-libs/glibc/glibc-2.34-r2.ebuild b/sys-libs/glibc/glibc-2.34-r2.ebuild
index 00c85cf62a55..04479ab604b7 100644
--- a/sys-libs/glibc/glibc-2.34-r2.ebuild
+++ b/sys-libs/glibc/glibc-2.34-r2.ebuild
@@ -330,9 +330,9 @@ setup_target_flags() {
# Workaround for https://bugs.gentoo.org/823780. This really should
# be removed when the upstream bug https://gcc.gnu.org/bugzilla/show_bug.cgi?id=103275
# is fixed in our tree, either via 11.3 or an 11.2p2 patch set.
- if [[ ${ABI} == x86 ]] && tc-is-gcc && (($(gcc-major-version) == 11)) && (($(gcc-minor-version) < 3)); then
+ if [[ ${ABI} == x86 ]] && tc-is-gcc && (($(gcc-major-version) == 11)) && (($(gcc-minor-version) <= 2)) && (($(gcc-micro-version) == 0)); then
export CFLAGS_x86="${CFLAGS_x86} -mno-avx512f"
- einfo "Auto adding -mno-avx512f to CFLAGS_x86 #823780 (ABI=${ABI})"
+ einfo "Auto adding -mno-avx512f to CFLAGS_x86 (bug #823780) (ABI=${ABI})"
fi
;;
mips)