summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2018-05-25 12:31:24 +0800
committerJason Zaman <perfinion@gentoo.org>2018-05-25 15:27:31 +0800
commit90cbc45bbd7b9cf8bc06c8ef779b917c239a5a1b (patch)
treef74fe97afc8ed2777c23d9defe6e358c5c0a07f9 /sys-libs
parentsys-apps/restorecond: update live ebuild (diff)
downloadgentoo-90cbc45bbd7b9cf8bc06c8ef779b917c239a5a1b.tar.gz
gentoo-90cbc45bbd7b9cf8bc06c8ef779b917c239a5a1b.tar.bz2
gentoo-90cbc45bbd7b9cf8bc06c8ef779b917c239a5a1b.zip
sys-libs/libsepol: bump to 2.8
Package-Manager: Portage-2.3.39, Repoman-2.3.9
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libsepol/Manifest1
-rw-r--r--sys-libs/libsepol/libsepol-2.8.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/sys-libs/libsepol/Manifest b/sys-libs/libsepol/Manifest
index 38483e831113..4374d6bf7219 100644
--- a/sys-libs/libsepol/Manifest
+++ b/sys-libs/libsepol/Manifest
@@ -3,3 +3,4 @@ DIST libsepol-2.7.tar.gz 471147 BLAKE2B 5eea0be27cd14e105c261ce67d46806c60f8454e
DIST libsepol-2.8-rc1.tar.gz 473554 BLAKE2B 274894dfeb1d0dd7ba7b661266e7acdd0dc1c4ae4a51b689f2beb3a838ffebe5f1a9b7ce3f28c421215a68ba9eea57b9a3a5a4cf2a3effefa905bfdb1d71e72a SHA512 79307249604207b52af154ee17c96b90ea31c44d208935a06b276975c7521b84f8c96f9f2dd578478d2baa974fe5777c5f1417073eba828202fa227cf2ea383d
DIST libsepol-2.8-rc2.tar.gz 473561 BLAKE2B a27526915a02c1a77c49bcb107d164759799835c32ed07a9ca7924d195c4127257fa97325434e6e4edd932564f9c80c5ed122dbd7b597a4749a5cad8fbb76507 SHA512 2e738986e6ddcc86904c5ef605fe03f4a3cbd239b34c76b1a3d06da1c21c327aa835949dbd5b2328d11c6c032d1a8677da21e5c06e2107f1f60a182286a9f2ea
DIST libsepol-2.8-rc3.tar.gz 473488 BLAKE2B 1befe617e73b3a845322efe107cd22649dc17a6df0ff90c6c25486d937bffa84d9f6e83979e294df693772f1afb8943dd2db6a95f76ae71d83f15fd90819d888 SHA512 afefd13732aadd2b7e476cb439fa3d09dc870ac50f262b3c803459a5ce431c26d896e327a4207fea88eac7121e0901db77674bae632bb3940a80e183c156d7fc
+DIST libsepol-2.8.tar.gz 473384 BLAKE2B 7280221d0824b316a3e66a0126654c71f52464d8a17460a2d38f592cb54449e2c57383f22ab7a3da2af809adeba93ef46b9c03cc69ddd112ab7592a14393cef3 SHA512 dd065886819a265cd4f2751ac231a7baa5d7c7735844f3557d5c7e1feb06d4b4d03433d26ff6419b426caf90b69771ee743850fe45d36bc0201cadb86c62189c
diff --git a/sys-libs/libsepol/libsepol-2.8.ebuild b/sys-libs/libsepol/libsepol-2.8.ebuild
new file mode 100644
index 000000000000..8672b08d98b3
--- /dev/null
+++ b/sys-libs/libsepol/libsepol-2.8.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit multilib toolchain-funcs multilib-minimal
+
+MY_P="${P//_/-}"
+MY_RELEASEDATE="20180524"
+
+DESCRIPTION="SELinux binary policy representation library"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+ S="${WORKDIR}/${MY_P}/${PN}"
+else
+ SRC_URI="https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/${MY_RELEASEDATE}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+# tests are not meant to be run outside of the full SELinux userland repo
+RESTRICT="test"
+
+src_prepare() {
+ eapply_user
+ multilib_copy_sources
+}
+
+multilib_src_compile() {
+ tc-export CC AR RANLIB
+ emake \
+ LIBDIR="\$(PREFIX)/$(get_libdir)" \
+ SHLIBDIR="/$(get_libdir)"
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" \
+ LIBDIR="\$(PREFIX)/$(get_libdir)" \
+ SHLIBDIR="/$(get_libdir)" \
+ install
+}