summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-05-27 00:38:04 +0200
committerDavid Seifert <soap@gentoo.org>2017-05-27 00:53:38 +0200
commit9a5c840d76f972476a30ab361c82fba6abc5b915 (patch)
treeae2be54998ef06e757ede2505a99babffafb8fe4 /sys-libs
parentsys-libs/libcap-ng: [QA] Add missing python metadata variables (diff)
downloadgentoo-9a5c840d76f972476a30ab361c82fba6abc5b915.tar.gz
gentoo-9a5c840d76f972476a30ab361c82fba6abc5b915.tar.bz2
gentoo-9a5c840d76f972476a30ab361c82fba6abc5b915.zip
sys-libs/libieee1284: [QA] Add missing python metadata variables
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libieee1284/libieee1284-0.2.11-r4.ebuild22
1 files changed, 11 insertions, 11 deletions
diff --git a/sys-libs/libieee1284/libieee1284-0.2.11-r4.ebuild b/sys-libs/libieee1284/libieee1284-0.2.11-r4.ebuild
index 70f5d163f0c6..1cf8a0bd6c98 100644
--- a/sys-libs/libieee1284/libieee1284-0.2.11-r4.ebuild
+++ b/sys-libs/libieee1284/libieee1284-0.2.11-r4.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=6
PYTHON_COMPAT=( python2_7 )
-inherit eutils python-single-r1 multilib-minimal
+
+inherit python-single-r1 multilib-minimal
DESCRIPTION="Library to query devices using IEEE1284"
HOMEPAGE="http://cyberelk.net/tim/libieee1284/index.html"
@@ -14,9 +15,9 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86 ~x86-fbsd"
IUSE="doc python static-libs"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-RDEPEND="abi_x86_32? ( !<=app-emulation/emul-linux-x86-medialibs-20130224-r9
- !app-emulation/emul-linux-x86-medialibs[-abi_x86_32(-)] )
+RDEPEND="
python? ( ${PYTHON_DEPS} )"
DEPEND="${RDEPEND}
doc? (
@@ -26,23 +27,22 @@ DEPEND="${RDEPEND}
dev-perl/XML-RegExp
)"
-DOCS="AUTHORS NEWS README* TODO doc/interface*"
-
pkg_setup() {
use python && python-single-r1_pkg_setup
}
multilib_src_configure() {
- local myconf="--without-python"
- multilib_is_native_abi && myconf="$(use_with python)"
-
ECONF_SOURCE="${S}" econf \
--enable-shared \
$(use_enable static-libs static) \
- ${myconf}
+ $(multilib_native_with python)
}
multilib_src_install_all() {
- prune_libtool_files --all
einstalldocs
+ dodoc doc/interface*
+
+ if ! use static-libs; then
+ find "${D}" -name '*.la' -delete || die
+ fi
}