summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2017-05-29 14:44:21 -0400
committerMike Gilbert <floppym@gentoo.org>2017-05-29 14:45:07 -0400
commitacd505742fe4dbbf7609940e0cee0e25c364b74b (patch)
treec270bb9490a1b9635d9697dd36b584c3819c80e1 /sys-libs
parentsys-libs/cracklib: enable python3 support (diff)
downloadgentoo-acd505742fe4dbbf7609940e0cee0e25c364b74b.tar.gz
gentoo-acd505742fe4dbbf7609940e0cee0e25c364b74b.tar.bz2
gentoo-acd505742fe4dbbf7609940e0cee0e25c364b74b.zip
sys-libs/cracklib: fix test phase
nosetests was used for no reason. Replace with unittest, which requires no external dependencies. The test code was loading libcrack.so from the system libdir rather than the freshly build library. Package-Manager: Portage-2.3.6_p1, Repoman-2.3.2_p69
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/cracklib/cracklib-2.9.6-r1.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/sys-libs/cracklib/cracklib-2.9.6-r1.ebuild b/sys-libs/cracklib/cracklib-2.9.6-r1.ebuild
index b4d9cfdb5a91..101aef422958 100644
--- a/sys-libs/cracklib/cracklib-2.9.6-r1.ebuild
+++ b/sys-libs/cracklib/cracklib-2.9.6-r1.ebuild
@@ -16,7 +16,7 @@ SRC_URI="https://github.com/${PN}/${PN}/releases/download/${P}/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~m68k-mint"
-IUSE="nls python static-libs test zlib"
+IUSE="nls python static-libs zlib"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="python? ( ${PYTHON_DEPS} )
@@ -24,7 +24,6 @@ RDEPEND="python? ( ${PYTHON_DEPS} )
DEPEND="${RDEPEND}
python? (
dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
)"
S=${WORKDIR}/${MY_P}
@@ -72,11 +71,12 @@ multilib_src_compile() {
}
multilib_src_test() {
- do_python
+ # Make sure we load the freshly built library
+ LD_LIBRARY_PATH="${BUILD_DIR}/lib/.libs" do_python
}
python_test() {
- nosetests -w "${S}"/python || die "Tests fail with ${EPYTHON}"
+ ${EPYTHON} -m unittest test_cracklib || die "Tests fail with ${EPYTHON}"
}
multilib_src_install() {