summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-03-16 10:12:56 +0100
committerMichał Górny <mgorny@gentoo.org>2018-03-16 10:32:39 +0100
commitd19909355276eee4b6599789bc31ee30d9705928 (patch)
treea8cc08683d70ddbb81a0e01b04a4920dbae7438f /sys-libs
parentsys-libs/llvm-libunwind: Fix running multilib tests (diff)
downloadgentoo-d19909355276eee4b6599789bc31ee30d9705928.tar.gz
gentoo-d19909355276eee4b6599789bc31ee30d9705928.tar.bz2
gentoo-d19909355276eee4b6599789bc31ee30d9705928.zip
sys-libs/llvm-libunwind: Pass cxx_under_test via --param
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-6.0.0.ebuild12
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-6.0.9999.ebuild12
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild12
3 files changed, 18 insertions, 18 deletions
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-6.0.0.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-6.0.0.ebuild
index fe3c0e9d6420..6da407e13a12 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-6.0.0.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-6.0.0.ebuild
@@ -73,9 +73,14 @@ multilib_src_configure() {
-DLIBUNWIND_ENABLE_CROSS_UNWINDING=ON
)
if use test; then
+ local clang_path=$(type -P "${CHOST:+${CHOST}-}clang" 2>/dev/null)
+ local jobs=${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}
+
+ [[ -n ${clang_path} ]] || die "Unable to find ${CHOST}-clang for tests"
+
mycmakeargs+=(
-DLLVM_EXTERNAL_LIT="${EPREFIX}/usr/bin/lit"
- -DLLVM_LIT_ARGS="-vv;-j;${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}"
+ -DLLVM_LIT_ARGS="-vv;-j;${jobs};--param=cxx_under_test=${clang_path}"
-DLIBUNWIND_LIBCXX_PATH="${WORKDIR}"/libcxx
)
fi
@@ -84,11 +89,6 @@ multilib_src_configure() {
}
multilib_src_test() {
- local clang_path=$(type -P "${CHOST:+${CHOST}-}clang" 2>/dev/null)
-
- [[ -n ${clang_path} ]] || die "Unable to find ${CHOST}-clang for tests"
- sed -i -e "/cxx_under_test/s^\".*\"^\"${clang_path}\"^" test/lit.site.cfg || die
-
cmake-utils_src_make check-unwind
}
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-6.0.9999.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-6.0.9999.ebuild
index 83db4453f60b..367803c62f09 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-6.0.9999.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-6.0.9999.ebuild
@@ -73,9 +73,14 @@ multilib_src_configure() {
-DLIBUNWIND_ENABLE_CROSS_UNWINDING=ON
)
if use test; then
+ local clang_path=$(type -P "${CHOST:+${CHOST}-}clang" 2>/dev/null)
+ local jobs=${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}
+
+ [[ -n ${clang_path} ]] || die "Unable to find ${CHOST}-clang for tests"
+
mycmakeargs+=(
-DLLVM_EXTERNAL_LIT="${EPREFIX}/usr/bin/lit"
- -DLLVM_LIT_ARGS="-vv;-j;${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}"
+ -DLLVM_LIT_ARGS="-vv;-j;${jobs};--param=cxx_under_test=${clang_path}"
-DLIBUNWIND_LIBCXX_PATH="${WORKDIR}"/libcxx
)
fi
@@ -84,11 +89,6 @@ multilib_src_configure() {
}
multilib_src_test() {
- local clang_path=$(type -P "${CHOST:+${CHOST}-}clang" 2>/dev/null)
-
- [[ -n ${clang_path} ]] || die "Unable to find ${CHOST}-clang for tests"
- sed -i -e "/cxx_under_test/s^\".*\"^\"${clang_path}\"^" test/lit.site.cfg || die
-
cmake-utils_src_make check-unwind
}
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild
index 238afe790e63..f38e06e1ba4e 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild
@@ -72,9 +72,14 @@ multilib_src_configure() {
-DLIBUNWIND_ENABLE_CROSS_UNWINDING=ON
)
if use test; then
+ local clang_path=$(type -P "${CHOST:+${CHOST}-}clang" 2>/dev/null)
+ local jobs=${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}
+
+ [[ -n ${clang_path} ]] || die "Unable to find ${CHOST}-clang for tests"
+
mycmakeargs+=(
-DLLVM_EXTERNAL_LIT="${EPREFIX}/usr/bin/lit"
- -DLLVM_LIT_ARGS="-vv;-j;${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}"
+ -DLLVM_LIT_ARGS="-vv;-j;${jobs};--param=cxx_under_test=${clang_path}"
-DLIBUNWIND_LIBCXX_PATH="${WORKDIR}"/libcxx
)
fi
@@ -83,11 +88,6 @@ multilib_src_configure() {
}
multilib_src_test() {
- local clang_path=$(type -P "${CHOST:+${CHOST}-}clang" 2>/dev/null)
-
- [[ -n ${clang_path} ]] || die "Unable to find ${CHOST}-clang for tests"
- sed -i -e "/cxx_under_test/s^\".*\"^\"${clang_path}\"^" test/lit.site.cfg || die
-
cmake-utils_src_make check-unwind
}