summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-08-23 00:29:15 +0200
committerThomas Deutschmann <whissi@gentoo.org>2018-08-23 00:29:33 +0200
commitd3af994a98b6dd14cbddff5cf1f207d16f519d37 (patch)
treee7ab4276752d7b337785748802cc58d08854171c /sys-libs
parentmedia-libs/nas: link against libfl (diff)
downloadgentoo-d3af994a98b6dd14cbddff5cf1f207d16f519d37.tar.gz
gentoo-d3af994a98b6dd14cbddff5cf1f207d16f519d37.tar.bz2
gentoo-d3af994a98b6dd14cbddff5cf1f207d16f519d37.zip
sys-libs/ldb: bump to v1.5.1
Package-Manager: Portage-2.3.48, Repoman-2.3.10
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/ldb/Manifest1
-rw-r--r--sys-libs/ldb/ldb-1.5.1.ebuild105
2 files changed, 106 insertions, 0 deletions
diff --git a/sys-libs/ldb/Manifest b/sys-libs/ldb/Manifest
index 3cd1ea3bdbe9..2e74c3d4f1a1 100644
--- a/sys-libs/ldb/Manifest
+++ b/sys-libs/ldb/Manifest
@@ -7,3 +7,4 @@ DIST ldb-1.3.5.tar.gz 1374214 BLAKE2B 5c5eeff67c362fc8bf9d9a7a3cb2ba98790c583e26
DIST ldb-1.4.1.tar.gz 1427314 BLAKE2B bdeea064719be9de1dff87a11bdbb8d051d85c056fdd34210ffaf2e9a5652af1e8aba95ff110b92a443a4353457cf9a5ec0d68cdc6fbba7bd955ad6df1413dbf SHA512 0e5b3ad4fa49893c86ca422e44d53c0af062e85e5085de18cdcaf2f05f0769cb2ecb65bad20cf93c5c2e115116ac2e1ec7f2d767678a3fffc9591d9db25e6f61
DIST ldb-1.4.2.tar.gz 1427857 BLAKE2B 5a90b31b4760f0504197d3cefdb16f7d4099df660fe75c5d80907e39abde8abc6b87cdb117ee9213abf8287932c18782ab153d87bb609cb1f346231e6e00997c SHA512 f2b44cebd0f8c77926aa364d9ac4ea37da4a780b94e7f9fba7a55fef825e90e469a3230e56cd2b23ce4f6b528dda9041863e4af77bb0826a117e8317a0b79070
DIST ldb-1.5.0.tar.gz 1430987 BLAKE2B cc98a96f01e7c96f83baef0d26f54d7673fa5c7108318ae1638952fed562db15d25b51c7a7782d92bcbaea661147a605e52e30e4318d6c15594d9c6a59103d1c SHA512 204d020ae87d86939cb22050acb47c8be748555875efbc01cbd7f2774c7f8f5a928292fa53a5f15fb58e96bdbb5dd7e212cf2d5d8b4fcfcb238b6a7f25e791fb
+DIST ldb-1.5.1.tar.gz 1432221 BLAKE2B 1837a74b33b5f527bdea0925de2908fc58bb6ca713bea89cefec9dc9809bf40d107352926ed34dabb333f37533e599b142a36989ffad862b0a89e786ab54c434 SHA512 b7815da51944d4e61617fafac0417e57baa59c9dd3dfa926d5ef9072a95351562930150c691a23b81526697bfba3ffe10a75ead406bf5ffdbfc511d1861f984b
diff --git a/sys-libs/ldb/ldb-1.5.1.ebuild b/sys-libs/ldb/ldb-1.5.1.ebuild
new file mode 100644
index 000000000000..0928dd65642a
--- /dev/null
+++ b/sys-libs/ldb/ldb-1.5.1.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="threads"
+
+inherit python-single-r1 waf-utils multilib-minimal eutils
+
+DESCRIPTION="An LDAP-like embedded database"
+HOMEPAGE="https://ldb.samba.org"
+SRC_URI="https://www.samba.org/ftp/pub/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="doc +ldap +lmdb +python"
+
+RDEPEND="
+ !elibc_FreeBSD? ( dev-libs/libbsd[${MULTILIB_USEDEP}] )
+ dev-libs/popt[${MULTILIB_USEDEP}]
+ >=dev-util/cmocka-1.1.1[${MULTILIB_USEDEP}]
+ >=sys-libs/talloc-2.1.14[python?,${MULTILIB_USEDEP}]
+ >=sys-libs/tdb-1.3.16[python?,${MULTILIB_USEDEP}]
+ >=sys-libs/tevent-0.9.37[python(+)?,${MULTILIB_USEDEP}]
+ ldap? ( net-nds/openldap )
+ lmdb? ( >=dev-db/lmdb-0.9.16[${MULTILIB_USEDEP}] )
+ python? ( ${PYTHON_DEPS} )
+"
+
+DEPEND="dev-libs/libxslt
+ doc? ( app-doc/doxygen )
+ virtual/pkgconfig
+ ${PYTHON_DEPS}
+ ${RDEPEND}
+"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+WAF_BINARY="${S}/buildtools/bin/waf"
+
+MULTILIB_WRAPPED_HEADERS=( /usr/include/pyldb.h )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.4.0-optional_packages.patch
+ "${FILESDIR}"/${PN}-1.1.31-fix_PKGCONFIGDIR-when-python-disabled.patch
+)
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ local myconf=(
+ $(usex ldap '' --disable-ldap)
+ $(usex lmdb '' --without-ldb-lmdb)
+ --disable-rpath
+ --disable-rpath-install --bundled-libraries=NONE
+ --with-modulesdir="${EPREFIX}"/usr/$(get_libdir)/samba
+ --builtin-libraries=NONE
+ )
+ if ! multilib_is_native_abi; then
+ myconf+=( --disable-python )
+ else
+ use python || myconf+=( --disable-python )
+ fi
+ waf-utils_src_configure "${myconf[@]}"
+}
+
+multilib_src_compile(){
+ waf-utils_src_compile
+ multilib_is_native_abi && use doc && doxygen Doxyfile
+}
+
+multilib_src_test() {
+ if multilib_is_native_abi; then
+ WAF_MAKE=1 \
+ PATH=buildtools/bin:../../../buildtools/bin:$PATH:"${BUILD_DIR}"/bin/shared/private/ \
+ LD_LIBRARY_PATH=$LD_LIBRARY_PATH:"${BUILD_DIR}"/bin/shared/private/:"${BUILD_DIR}"/bin/shared \
+ waf test || die
+ fi
+}
+
+multilib_src_install() {
+ waf-utils_src_install
+
+ if multilib_is_native_abi && use doc; then
+ doman apidocs/man/man3/*.3
+ docinto html
+ dodoc -r apidocs/html/*
+ fi
+}
+
+pkg_postinst() {
+ if has_version sys-auth/sssd; then
+ ewarn "You have sssd installed. It is known to break after ldb upgrades,"
+ ewarn "so please try to rebuild it before reporting bugs."
+ ewarn "See https://bugs.gentoo.org/404281"
+ fi
+}