summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-09-05 08:09:43 +0200
committerMichał Górny <mgorny@gentoo.org>2018-09-05 08:20:12 +0200
commiteab43e1f6478f40c79ebc6e16017695884b39b60 (patch)
tree11d6da7960019ac0b37c51f8b7329f38462fd5a5 /sys-libs
parentsys-libs/compiler-rt-sanitizers: Inline new glibc patches (diff)
downloadgentoo-eab43e1f6478f40c79ebc6e16017695884b39b60.tar.gz
gentoo-eab43e1f6478f40c79ebc6e16017695884b39b60.tar.bz2
gentoo-eab43e1f6478f40c79ebc6e16017695884b39b60.zip
sys-libs/compiler-rt-sanitizers: Add new glibc fixes to live ebuilds
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-7.0.9999.ebuild6
-rw-r--r--sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-9999.ebuild6
2 files changed, 10 insertions, 2 deletions
diff --git a/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-7.0.9999.ebuild b/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-7.0.9999.ebuild
index 3028242fe9f6..9635d97c1190 100644
--- a/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-7.0.9999.ebuild
+++ b/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-7.0.9999.ebuild
@@ -75,8 +75,12 @@ src_unpack() {
src_prepare() {
cmake-utils_src_prepare
+ # apply the fixes for new glibc / split tirpc
+ eapply "${FILESDIR}/9999/0001-sanitizer_common-Fix-using-libtirpc-on-Linux.patch"
+ eapply "${FILESDIR}/9999/0002-test-Support-using-libtirpc-on-Linux.patch"
+
if use test; then
- # remove tests that are broken by new glibc
+ # remove tests that are (still) broken by new glibc
# https://bugs.llvm.org/show_bug.cgi?id=36065
if use elibc_glibc && has_version '>=sys-libs/glibc-2.25'; then
rm test/lsan/TestCases/Linux/use_tls_dynamic.cc || die
diff --git a/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-9999.ebuild b/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-9999.ebuild
index 6d2a4a7a40b7..e50fb3c855ab 100644
--- a/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-9999.ebuild
+++ b/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-9999.ebuild
@@ -74,8 +74,12 @@ src_unpack() {
src_prepare() {
cmake-utils_src_prepare
+ # apply the fixes for new glibc / split tirpc
+ eapply "${FILESDIR}/9999/0001-sanitizer_common-Fix-using-libtirpc-on-Linux.patch"
+ eapply "${FILESDIR}/9999/0002-test-Support-using-libtirpc-on-Linux.patch"
+
if use test; then
- # remove tests that are broken by new glibc
+ # remove tests that are (still) broken by new glibc
# https://bugs.llvm.org/show_bug.cgi?id=36065
if use elibc_glibc && has_version '>=sys-libs/glibc-2.25'; then
rm test/lsan/TestCases/Linux/use_tls_dynamic.cc || die