summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-11-19 17:39:30 +0000
committerSam James <sam@gentoo.org>2021-11-19 17:41:56 +0000
commitf9db221ddfadd7518e96fb63d93d1edabc5b97eb (patch)
treec856c83bbc149b5e9c5d2aeb3d24508f2bb06037 /sys-libs
parentsci-libs/pastix: Keyword 6.0.3 arm64, #730636 (diff)
downloadgentoo-f9db221ddfadd7518e96fb63d93d1edabc5b97eb.tar.gz
gentoo-f9db221ddfadd7518e96fb63d93d1edabc5b97eb.tar.bz2
gentoo-f9db221ddfadd7518e96fb63d93d1edabc5b97eb.zip
sys-libs/libxcrypt: disable gold
Disable gold as a precaution given report of odd behaviour (possible illegal instructions being emitted) with gold. It's not quite clear how this could happen but gold is already on its way out and I'd rather play it safe here pending more information. Bug: https://bugs.gentoo.org/821496 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libxcrypt/libxcrypt-4.4.25-r1.ebuild (renamed from sys-libs/libxcrypt/libxcrypt-4.4.25.ebuild)6
-rw-r--r--sys-libs/libxcrypt/libxcrypt-4.4.26-r1.ebuild (renamed from sys-libs/libxcrypt/libxcrypt-4.4.26.ebuild)6
2 files changed, 10 insertions, 2 deletions
diff --git a/sys-libs/libxcrypt/libxcrypt-4.4.25.ebuild b/sys-libs/libxcrypt/libxcrypt-4.4.25-r1.ebuild
index e95748621284..d8f01115f15c 100644
--- a/sys-libs/libxcrypt/libxcrypt-4.4.25.ebuild
+++ b/sys-libs/libxcrypt/libxcrypt-4.4.25-r1.ebuild
@@ -7,7 +7,7 @@ PYTHON_COMPAT=( python3_{8..10} )
# NEED_BOOTSTRAP is for developers to quickly generate a tarball
# for publishing to the tree.
NEED_BOOTSTRAP="no"
-inherit multibuild multilib python-any-r1 multilib-minimal
+inherit multibuild multilib python-any-r1 toolchain-funcs multilib-minimal
DESCRIPTION="Extended crypt library for descrypt, md5crypt, bcrypt, and others"
HOMEPAGE="https://github.com/besser82/libxcrypt"
@@ -97,6 +97,10 @@ src_prepare() {
}
src_configure() {
+ # Avoid possible "illegal instruction" errors with gold
+ # bug #821496
+ tc-ld-disable-gold
+
multibuild_foreach_variant multilib-minimal_src_configure
}
diff --git a/sys-libs/libxcrypt/libxcrypt-4.4.26.ebuild b/sys-libs/libxcrypt/libxcrypt-4.4.26-r1.ebuild
index dca937cb958a..5d0f0cffee7d 100644
--- a/sys-libs/libxcrypt/libxcrypt-4.4.26.ebuild
+++ b/sys-libs/libxcrypt/libxcrypt-4.4.26-r1.ebuild
@@ -7,7 +7,7 @@ PYTHON_COMPAT=( python3_{8..10} )
# NEED_BOOTSTRAP is for developers to quickly generate a tarball
# for publishing to the tree.
NEED_BOOTSTRAP="no"
-inherit multibuild multilib python-any-r1 multilib-minimal
+inherit multibuild multilib python-any-r1 toolchain-funcs multilib-minimal
DESCRIPTION="Extended crypt library for descrypt, md5crypt, bcrypt, and others"
HOMEPAGE="https://github.com/besser82/libxcrypt"
@@ -97,6 +97,10 @@ src_prepare() {
}
src_configure() {
+ # Avoid possible "illegal instruction" errors with gold
+ # bug #821496
+ tc-ld-disable-gold
+
multibuild_foreach_variant multilib-minimal_src_configure
}