summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenning Schild <henning@hennsch.de>2018-04-04 09:02:47 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-08-07 23:41:19 +0200
commit7c4e5cbe228dd25b6516420cec8b2d874c111146 (patch)
treed50c9e00473f3619eef0d22cb7329ad13cbeec52 /sys-power/acpi_call
parentsys-power/acpi_call: move to another upstream git repo. (diff)
downloadgentoo-7c4e5cbe228dd25b6516420cec8b2d874c111146.tar.gz
gentoo-7c4e5cbe228dd25b6516420cec8b2d874c111146.tar.bz2
gentoo-7c4e5cbe228dd25b6516420cec8b2d874c111146.zip
sys-power/acpi_call: version bump to 3.17.
Signed-off-by: Henning Schild <henning@hennsch.de>
Diffstat (limited to 'sys-power/acpi_call')
-rw-r--r--sys-power/acpi_call/Manifest1
-rw-r--r--sys-power/acpi_call/acpi_call-3.17.ebuild37
-rw-r--r--sys-power/acpi_call/files/acpi_call-3.17-linux-4.12.patch12
-rw-r--r--sys-power/acpi_call/files/acpi_call-3.17-linux-4.14.patch14
4 files changed, 64 insertions, 0 deletions
diff --git a/sys-power/acpi_call/Manifest b/sys-power/acpi_call/Manifest
index ebae8eb1b1ce..35e63fbb6c7c 100644
--- a/sys-power/acpi_call/Manifest
+++ b/sys-power/acpi_call/Manifest
@@ -1 +1,2 @@
DIST acpi_call-1.1.0.tar.gz 10470 BLAKE2B 000c5e6f1eb968bdea3d8dfb6d6bf7b18daffe8baa75ff32e8c6c4b98cafe0a72a67a65a17994a1c8efa16f528bdfbf2b27686a146730c319a5195dfa9ec0d51 SHA512 d5cf13c15f9057e3a27aaacfee6dcdb17b6a79194bdc8fd57b8140c07a532e2e58151bea881aa158c1183ac3bbe89f83fcfc2279ffd9e945a72331b6ddbf2c70
+DIST acpi_call-3.17.tar.gz 10470 BLAKE2B e1a4912f4b92532aa8496e668541975b7e563dfd7613d41f33503d5eecad786b84ba98b205f27c4a4fbd3b37b034a467cf7c9a73f2995539d2117f50751df682 SHA512 39f8f924995ba4e5490e93f03c33db083ced224699b1028102294b2cc99edebd1eea04d33b50beed9dea86939c124682ef8d013c990d5611471b104be3200cb1
diff --git a/sys-power/acpi_call/acpi_call-3.17.ebuild b/sys-power/acpi_call/acpi_call-3.17.ebuild
new file mode 100644
index 000000000000..b0d6197ccffa
--- /dev/null
+++ b/sys-power/acpi_call/acpi_call-3.17.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit linux-info linux-mod
+
+HOMEPAGE="https://github.com/teleshoes/acpi_call"
+if [ "${PV}" = "9999" ]; then
+ inherit git-r3
+ EGIT_REPO_URI="${HOMEPAGE}.git"
+ KEYWORDS=""
+else
+ inherit vcs-snapshot
+ SRC_URI="${HOMEPAGE}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="A kernel module that enables you to call ACPI methods"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+CONFIG_CHECK="ACPI"
+MODULE_NAMES="acpi_call(misc:${S})"
+BUILD_TARGETS="default"
+
+PATCHES=(
+ "${FILESDIR}/${P}-linux-4.12.patch"
+ "${FILESDIR}/${P}-linux-4.14.patch"
+)
+
+src_compile(){
+ BUILD_PARAMS="KDIR=${KV_OUT_DIR} M=${S}"
+ linux-mod_src_compile
+}
diff --git a/sys-power/acpi_call/files/acpi_call-3.17-linux-4.12.patch b/sys-power/acpi_call/files/acpi_call-3.17-linux-4.12.patch
new file mode 100644
index 000000000000..ac64ba5efaf3
--- /dev/null
+++ b/sys-power/acpi_call/files/acpi_call-3.17-linux-4.12.patch
@@ -0,0 +1,12 @@
+diff --git a/acpi_call.c b/acpi_call.c
+index 35bfe12..c059511 100644
+--- a/acpi_call.c
++++ b/acpi_call.c
+@@ -7,6 +7,7 @@
+ #include <linux/proc_fs.h>
+ #include <linux/slab.h>
+ #include <asm/uaccess.h>
++#include <linux/uaccess.h>
+
+ MODULE_LICENSE("GPL");
+
diff --git a/sys-power/acpi_call/files/acpi_call-3.17-linux-4.14.patch b/sys-power/acpi_call/files/acpi_call-3.17-linux-4.14.patch
new file mode 100644
index 000000000000..ddea4fafc695
--- /dev/null
+++ b/sys-power/acpi_call/files/acpi_call-3.17-linux-4.14.patch
@@ -0,0 +1,14 @@
+diff --git a/acpi_call.c b/acpi_call.c
+index c059511..b622bf7 100644
+--- a/acpi_call.c
++++ b/acpi_call.c
+@@ -6,7 +6,9 @@
+ #include <linux/version.h>
+ #include <linux/proc_fs.h>
+ #include <linux/slab.h>
++#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 14, 0)
+ #include <asm/uaccess.h>
++#endif
+ #include <linux/uaccess.h>
+
+ MODULE_LICENSE("GPL");