summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2020-09-01 12:12:13 -0400
committerBrian Evans <grknight@gentoo.org>2020-09-01 12:16:17 -0400
commit23815cc21c9d3b8d84c0a14a4cdf5cbea76d4ccd (patch)
treeb95cd371736b78af8c7b84a767ccf668ada9f468 /sys-power/acpilight
parentjava-pkg-simple.eclass: Fix error message when copying resources (diff)
downloadgentoo-23815cc21c9d3b8d84c0a14a4cdf5cbea76d4ccd.tar.gz
gentoo-23815cc21c9d3b8d84c0a14a4cdf5cbea76d4ccd.tar.bz2
gentoo-23815cc21c9d3b8d84c0a14a4cdf5cbea76d4ccd.zip
sys-power/acpilight: Revbump for single impl and 3.8
Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'sys-power/acpilight')
-rw-r--r--sys-power/acpilight/acpilight-1.2-r1.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/sys-power/acpilight/acpilight-1.2-r1.ebuild b/sys-power/acpilight/acpilight-1.2-r1.ebuild
new file mode 100644
index 000000000000..36f03785d73c
--- /dev/null
+++ b/sys-power/acpilight/acpilight-1.2-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 python3_7 python3_8 )
+
+inherit python-single-r1 udev
+
+MY_P="${PN}-v${PV}"
+
+DESCRIPTION="Replacement for xbacklight that uses the ACPI interface to set brightness"
+HOMEPAGE="https://gitlab.com/wavexx/acpilight/"
+SRC_URI="https://gitlab.com/wavexx/acpilight/-/archive/v${PV}/${MY_P}.tar.gz"
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+RDEPEND="virtual/udev
+ acct-group/video
+ ${PYTHON_DEPS}
+ !x11-apps/xbacklight"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+DOCS=( README.rst NEWS.rst )
+
+# Disable Makefile that installs by default
+src_compile() { :; }
+
+src_install() {
+ python_doscript xbacklight
+ udev_dorules "${S}"/90-backlight.rules
+ doman xbacklight.1
+ einstalldocs
+ newinitd "${FILESDIR}"/acpilight.initd acpilight
+ newconfd "${FILESDIR}"/acpilight.confd acpilight
+}
+
+pkg_postinst() {
+ udev_reload
+ einfo
+ elog "To use the xbacklight binary as a regular user, you must be a part of the video group"
+ einfo
+ elog "If this utility does not find any backlights to manipulate,"
+ elog "verify you have kernel support on the device and display driver enabled."
+ einfo
+ elog "To take advantage of the OpenRC init script, and automate the process of"
+ elog "saving and restoring the brightness level you should add acpilight"
+ elog "to the boot runlevel. You can do this as root like so:"
+ elog "# rc-update add acpilight boot"
+ einfo
+}