summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-power/nvram-wakeup
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-power/nvram-wakeup')
-rw-r--r--sys-power/nvram-wakeup/Manifest2
-rw-r--r--sys-power/nvram-wakeup/files/nvram-wakeup-0.97-nonls.patch18
-rw-r--r--sys-power/nvram-wakeup/metadata.xml8
-rw-r--r--sys-power/nvram-wakeup/nvram-wakeup-1.0.ebuild70
-rw-r--r--sys-power/nvram-wakeup/nvram-wakeup-1.1.ebuild74
5 files changed, 172 insertions, 0 deletions
diff --git a/sys-power/nvram-wakeup/Manifest b/sys-power/nvram-wakeup/Manifest
new file mode 100644
index 000000000000..081a12738057
--- /dev/null
+++ b/sys-power/nvram-wakeup/Manifest
@@ -0,0 +1,2 @@
+DIST nvram-wakup-1.0.tar.gz 1068875 SHA256 831af412fdf8c75a31e470398a08da97266b2dd064daaf94e45833bd4428349b
+DIST nvram-wakup-1.1.tar.gz 1070097 SHA256 b5f6a86ec7ad1c25d22f7dd0bf3261c2766e6302f0f6f80a963ceb3eb3b74811 SHA512 a47c6831e004e25f43adbc25aa46aca457602c681693621e3acda12f1f775aa1c5fa30ec9a09d71945ef2de8a2dbe97f9c1c7e09b1ae3464c368c9b8fc0f11e0 WHIRLPOOL 468f3be815aa3e4cee60f66f5cc48aebfb3aa1343fc7ee7ab899fd72c12b9fb2595dbb7ed04bf65734d9d363e766b26bf19e307049424b997fbd2ca36bb72801
diff --git a/sys-power/nvram-wakeup/files/nvram-wakeup-0.97-nonls.patch b/sys-power/nvram-wakeup/files/nvram-wakeup-0.97-nonls.patch
new file mode 100644
index 000000000000..108d02eddd29
--- /dev/null
+++ b/sys-power/nvram-wakeup/files/nvram-wakeup-0.97-nonls.patch
@@ -0,0 +1,18 @@
+--- nvram-wakeup-0.97/Makefile
++++ nvram-wakeup-0.97/Makefile
+@@ -41,3 +41,3 @@
+
+-all: $(BINS) $(GTTXT)
++all: $(BINS)
+ size $(BINS)
+@@ -88,3 +88,2 @@
+ @$(INSTALL) -vd $(DOCDIR)
+- @$(INSTALL) -vd $(GTTXTDIR)
+ @$(INSTALL) -vm 755 $(PROG_SH) $(BINDIR)
+@@ -94,3 +93,2 @@
+ @$(INSTALL) -vm 644 $(DOC) $(DOCDIR)
+- @$(INSTALL) -vm 755 $(GTTXT) $(GTTXTDIR)
+
+@@ -110,2 +108 @@
+ cd $(DOCDIR); rm -f $(DOC)
+- cd $(GTTXTDIR); rm -f $(GTTXT)
diff --git a/sys-power/nvram-wakeup/metadata.xml b/sys-power/nvram-wakeup/metadata.xml
new file mode 100644
index 000000000000..8037d8508d62
--- /dev/null
+++ b/sys-power/nvram-wakeup/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>base-system</herd>
+ <upstream>
+ <remote-id type="sourceforge">nvram-wakeup</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-power/nvram-wakeup/nvram-wakeup-1.0.ebuild b/sys-power/nvram-wakeup/nvram-wakeup-1.0.ebuild
new file mode 100644
index 000000000000..55d387ccf501
--- /dev/null
+++ b/sys-power/nvram-wakeup/nvram-wakeup-1.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit flag-o-matic eutils
+
+MY_P=${P%_p*}
+[[ ${PV} == *_p* ]] && REV=${P#*_p} || unset REV
+MY_P=${MY_P/e}
+DESCRIPTION="read and write the WakeUp time in the BIOS"
+HOMEPAGE="http://sourceforge.net/projects/nvram-wakeup"
+SRC_URI="mirror://sourceforge/nvram-wakeup/${MY_P}.tar.gz
+ ${REV+http://nvram-wakeup.svn.sourceforge.net/viewvc/*checkout*/nvram-wakeup/trunk/nvram-wakeup/nvram-wakeup-mb.c?revision=${REV}}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="nls"
+[[ -n ${REV} ]] && RESTRICT="mirror" #168114
+
+DEPEND="nls? ( sys-devel/gettext )"
+RDEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz
+ if [[ -n ${REV} ]] ; then
+ cp "${DISTDIR}"/nvram-wakeup-mb.c?revision=${REV} "${S}"/nvram-wakeup-mb.c || die
+ fi
+ cd "${S}"
+ use nls || epatch "${FILESDIR}"/${PN}-0.97-nonls.patch
+ # Need to be careful with CFLAGS since this could eat your bios
+ strip-flags
+ sed -i \
+ -e '/^CFLAGS/s:= -O2 :+= $(CPPFLAGS) :' \
+ Makefile || die "setting CFLAGS"
+}
+
+src_install() {
+ emake \
+ prefix="${D}"/usr \
+ MANDIR="${D}"/usr/share/man \
+ DOCDIR="${D}"/usr/share/doc/${PF} \
+ install || die
+
+ dodoc "${D}"/usr/bin/vdrshutdown
+ rm -f "${D}"/usr/bin/vdrshutdown
+ dodoc set_timer
+
+ rm -f "${D}"/usr/sbin/time
+ rm -f "${D}"/usr/share/man/man*/time.8*
+
+ prepalldocs
+}
+
+pkg_postinst() {
+ echo
+ ewarn "WARNING:"
+ ewarn "This program writes into the NVRAM (used by BIOS to store the CMOS"
+ ewarn "settings). This is DANGEROUS. Do it at your own risk. Neither the"
+ ewarn "author of this program (nvram-wakeup) nor anyone else can be made"
+ ewarn "responsible to any damage made by this program in any way."
+ ewarn "(The worst case happened to me is that on reboot the BIOS noticed the"
+ ewarn "illegal contents of the nvram and set everything to default values."
+ ewarn "But this doesn't mean that you can't destroy even your whole computer.)"
+ echo
+ ewarn " YOU HAVE BEEN WARNED, HAVE A NICE DAY"
+ echo
+}
diff --git a/sys-power/nvram-wakeup/nvram-wakeup-1.1.ebuild b/sys-power/nvram-wakeup/nvram-wakeup-1.1.ebuild
new file mode 100644
index 000000000000..488798d69b10
--- /dev/null
+++ b/sys-power/nvram-wakeup/nvram-wakeup-1.1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit flag-o-matic eutils
+
+MY_P=${P%_p*}
+[[ ${PV} == *_p* ]] && REV=${P#*_p} || unset REV
+MY_P=${MY_P/e}
+DESCRIPTION="read and write the WakeUp time in the BIOS"
+HOMEPAGE="http://sourceforge.net/projects/nvram-wakeup"
+SRC_URI="mirror://sourceforge/nvram-wakeup/${MY_P}.tar.gz
+ ${REV+http://nvram-wakeup.svn.sourceforge.net/viewvc/*checkout*/nvram-wakeup/trunk/nvram-wakeup/nvram-wakeup-mb.c?revision=${REV}}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+[[ -n ${REV} ]] && RESTRICT="mirror" #168114
+
+DEPEND="nls? ( sys-devel/gettext )"
+RDEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz
+ if [[ -n ${REV} ]] ; then
+ cp "${DISTDIR}"/nvram-wakeup-mb.c?revision=${REV} "${S}"/nvram-wakeup-mb.c || die
+ fi
+}
+
+src_prepare() {
+ use nls || epatch "${FILESDIR}"/${PN}-0.97-nonls.patch
+ # Need to be careful with CFLAGS since this could eat your bios
+ strip-flags
+ # GTTXT mode fix: https://sourceforge.net/tracker/?func=detail&aid=3599718&group_id=35022&atid=412757
+ sed -i \
+ -e '/^CFLAGS/s:= -O2 :+= $(CPPFLAGS) :' \
+ -e '/GTTXT/s:755:644:' \
+ Makefile || die
+}
+
+src_install() {
+ emake \
+ prefix="${D}"/usr \
+ MANDIR="${D}"/usr/share/man \
+ DOCDIR="${D}"/usr/share/doc/${PF} \
+ install
+
+ dodoc "${D}"/usr/bin/vdrshutdown
+ rm "${D}"/usr/bin/vdrshutdown || die
+ dodoc set_timer
+
+ rm "${D}"/usr/sbin/time || die
+ rm "${D}"/usr/share/man/man*/time.8* || die
+}
+
+pkg_postinst() {
+ echo
+ ewarn "WARNING:"
+ ewarn "This program writes into the NVRAM (used by BIOS to store the CMOS"
+ ewarn "settings). This is DANGEROUS. Do it at your own risk. Neither the"
+ ewarn "author of this program (nvram-wakeup) nor anyone else can be made"
+ ewarn "responsible to any damage made by this program in any way."
+ ewarn "(The worst case happened to me is that on reboot the BIOS noticed the"
+ ewarn "illegal contents of the nvram and set everything to default values."
+ ewarn "But this doesn't mean that you can't destroy even your whole computer.)"
+ echo
+ ewarn " YOU HAVE BEEN WARNED, HAVE A NICE DAY"
+ echo
+}