summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZentaro Kavanagh <zentaro@chromium.org>2018-06-14 13:40:54 -0700
committerMike Frysinger <vapier@gentoo.org>2018-06-18 10:54:21 -0400
commitb58dab88294efd16e05c66a751d606235b103dbf (patch)
treeecb72bf3e2578e52fd7fdc515cd0b82313cbabd1 /sys-power/powertop/powertop-2.8.ebuild
parentapp-emulation/reg: Remove old (diff)
downloadgentoo-b58dab88294efd16e05c66a751d606235b103dbf.tar.gz
gentoo-b58dab88294efd16e05c66a751d606235b103dbf.tar.bz2
gentoo-b58dab88294efd16e05c66a751d606235b103dbf.zip
sys-power/powertop: Support ncurses with tinfo
- Patches the configure.ac to fix bug getting libs from pkg-config - Previous code matched only when both ncursesw and ncurses existed - Used wrong variable when concatenating to LIBS - Concatenating to LIBS was redundant anyway since it is done in makefile.am - Upstream patch sent to powertop mailing list [1] Url: https://lists.01.org/pipermail/powertop/2018-June/002021.html [1]
Diffstat (limited to 'sys-power/powertop/powertop-2.8.ebuild')
-rw-r--r--sys-power/powertop/powertop-2.8.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/sys-power/powertop/powertop-2.8.ebuild b/sys-power/powertop/powertop-2.8.ebuild
index e0975e47ca83..2ec905b8419f 100644
--- a/sys-power/powertop/powertop-2.8.ebuild
+++ b/sys-power/powertop/powertop-2.8.ebuild
@@ -3,7 +3,7 @@
EAPI="5"
-inherit eutils linux-info
+inherit eutils linux-info autotools
SRC_URI="https://01.org/sites/default/files/downloads/${PN}/${P}.tar.gz"
KEYWORDS="amd64 arm ppc sparc x86 ~amd64-linux ~x86-linux"
@@ -91,11 +91,10 @@ pkg_setup() {
}
src_prepare() {
- if [[ ${PV} == "9999" ]] ; then
- eautoreconf
- else
- default
- fi
+ epatch "${FILESDIR}"/${P}-ncurses_tinfo.patch
+
+ # Call eautoreconf since ncurses patch touches configure.ac.
+ eautoreconf
}
src_configure() {