summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2021-09-10 10:21:04 +0800
committerYixun Lan <dlan@gentoo.org>2021-09-10 10:21:23 +0800
commit56fd1d665dee7bb47a2cd6c659037d546f7fa8c5 (patch)
treef6ffb3434ad2675000ff8f1e42a11db5943b9a47 /sys-power/thermald
parentdev-python/sphinx-autodoc-typehints: mark 1.12.0 sparc, bug #803719 (diff)
downloadgentoo-56fd1d665dee7bb47a2cd6c659037d546f7fa8c5.tar.gz
gentoo-56fd1d665dee7bb47a2cd6c659037d546f7fa8c5.tar.bz2
gentoo-56fd1d665dee7bb47a2cd6c659037d546f7fa8c5.zip
sys-power/thermald: version bump, 2.4.6
Closes: https://bugs.gentoo.org/812146 Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'sys-power/thermald')
-rw-r--r--sys-power/thermald/Manifest1
-rw-r--r--sys-power/thermald/thermald-2.4.6.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/sys-power/thermald/Manifest b/sys-power/thermald/Manifest
index e8c04758b2da..7c8024ebbcc9 100644
--- a/sys-power/thermald/Manifest
+++ b/sys-power/thermald/Manifest
@@ -1,2 +1,3 @@
DIST thermald-2.4.3.tar.gz 455850 BLAKE2B 2348a5ce9175049e3cb2436ee6d7773af50ace9693956f5a0e64f9fbb28826004f5cf599887d7b4a8405680ecdf90dc04c054082bcca484151373e91d64eab1b SHA512 eda313aa91235ae024a673e9933267c3aa97a3a8e3e6501bf7daac24be747174b223c2f297e7b301477899d099878aa46c58cda936507c8d4683c4f14df009c0
DIST thermald-2.4.5.tar.gz 455875 BLAKE2B f080dc065f5a0227cabed8e88d44c85c6e8ac932a6042b095a91840ea586213fe1b8ca93a04ee872f3e971d1efdd95c0f50357727d70b8e4fecd735e9c840f73 SHA512 8b7d75b3f1d7a98a9985c7552963cde19c81053d12fa39974c1129315fc23e66a432d9ada5d9e385989976453a83cf6418f410d3ce3317e23133d15d2ec37695
+DIST thermald-2.4.6.tar.gz 455905 BLAKE2B 0e3eae24bd4de8f7adc9cb8cc6dec83907d8e8240bec87d752e4502c923e7b407546204af474fe32fa43ba85a60ba51bd3dc6f1ce7cf3a62dd60dc5b0235ed52 SHA512 e337b00ec7f4fa565927f047dbb17dc05b8513850f2488dd6cfc838e5123938fbfe7c39464fffb77c100073edfca9ea51708680eaa2cba537470326df9508d3a
diff --git a/sys-power/thermald/thermald-2.4.6.ebuild b/sys-power/thermald/thermald-2.4.6.ebuild
new file mode 100644
index 000000000000..a482dfef0ff9
--- /dev/null
+++ b/sys-power/thermald/thermald-2.4.6.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools out-of-source systemd
+
+DESCRIPTION="Thermal daemon for Intel architectures"
+HOMEPAGE="https://01.org/linux-thermal-daemon https://github.com/intel/thermal_daemon"
+SRC_URI="https://github.com/intel/thermal_daemon/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/dbus-glib:=
+ dev-libs/glib:=
+ dev-libs/libxml2:=
+ dev-libs/libevdev
+ sys-power/upower
+ sys-apps/dbus:="
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc
+ dev-util/glib-utils"
+
+S=${WORKDIR}/thermal_daemon-${PV}
+DOCS=( thermal_daemon_usage.txt README.txt )
+
+src_prepare() {
+ sed -i -e "/group=/s/power/wheel/g" \
+ data/org.freedesktop.thermald.conf || die
+
+ default
+ eautoreconf
+}
+
+my_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --disable-werror \
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+}
+
+my_src_install_all() {
+ einstalldocs
+
+ rm -rf "${ED}"/etc/init || die
+ doinitd "${FILESDIR}"/thermald
+}