summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Utkin <andrey_utkin@gentoo.org>2018-04-22 02:34:10 +0100
committerAndrey Utkin <andrey_utkin@gentoo.org>2018-04-27 22:14:37 +0100
commit030c1a77d6a6f4deb616d8bf61b55a85bd8177ca (patch)
tree0daed09d63c832aa3177d3159eb1476866ceeaf1 /sys-power
parentsys-cluster/kube-scheduler: Remove old (diff)
downloadgentoo-030c1a77d6a6f4deb616d8bf61b55a85bd8177ca.tar.gz
gentoo-030c1a77d6a6f4deb616d8bf61b55a85bd8177ca.tar.bz2
gentoo-030c1a77d6a6f4deb616d8bf61b55a85bd8177ca.zip
sys-power/acpid: add new version 2.0.29
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/acpid/Manifest1
-rw-r--r--sys-power/acpid/acpid-2.0.29.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/sys-power/acpid/Manifest b/sys-power/acpid/Manifest
index 22bd5850fcb9..9ff66cb6dd04 100644
--- a/sys-power/acpid/Manifest
+++ b/sys-power/acpid/Manifest
@@ -1 +1,2 @@
DIST acpid-2.0.28.tar.xz 156036 BLAKE2B a6a78f82f7f4ecbd0d883d175c921195970e157a919fefc9cf48a94db534b496a8570c031fda5b08df3fb1775e26a50b5942bac7717aa582d590605930e3af78 SHA512 effe9c3b30b4a6ea20eca4b36a06d4b3da9b262d100685958faec4b38f89377a87dcaecee7a69b87aaddfa47688bcc46fc47a38391ac4bd2019cb3b48ab18fcb
+DIST acpid-2.0.29.tar.xz 155568 BLAKE2B 9a2c9f2f8ba035bf7452b633c20a73796ca05d4849d567f076a08a8216f2e07ca7a0b25e995054697e70bacacad07872e153c6c47f8204294964b276bca49f62 SHA512 5f480cb4456b6b843adb239519a8d05f83c3c668525457e55d7fae2ba7725356ec7a1faa16bbd54086f0eab2e8ca20952180c00b2b65a27eda534c3f28e8ed17
diff --git a/sys-power/acpid/acpid-2.0.29.ebuild b/sys-power/acpid/acpid-2.0.29.ebuild
new file mode 100644
index 000000000000..f9699804c533
--- /dev/null
+++ b/sys-power/acpid/acpid-2.0.29.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit linux-info systemd
+
+DESCRIPTION="Daemon for Advanced Configuration and Power Interface"
+HOMEPAGE="https://sourceforge.net/projects/acpid2"
+SRC_URI="mirror://sourceforge/${PN}2/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ia64 ~x86"
+IUSE="selinux"
+
+RDEPEND="selinux? ( sec-policy/selinux-apm )"
+DEPEND=">=sys-kernel/linux-headers-3"
+
+pkg_pretend() {
+ local CONFIG_CHECK="~INPUT_EVDEV"
+ local WARNING_INPUT_EVDEV="CONFIG_INPUT_EVDEV is required for ACPI button event support."
+ [[ ${MERGE_TYPE} != buildonly ]] && check_extra_config
+}
+
+pkg_setup() { :; }
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.0.25-kde4.patch #515088
+ "${FILESDIR}"/${PN}-2.0.25-add_mate-power-manager.patch #538590
+)
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ newdoc kacpimon/README README.kacpimon
+ dodoc -r samples
+ rm -f "${D}"/usr/share/doc/${PF}/COPYING || die
+
+ exeinto /etc/acpi
+ newexe "${FILESDIR}"/${PN}-1.0.6-default.sh default.sh
+ exeinto /etc/acpi/actions
+ newexe samples/powerbtn/powerbtn.sh powerbtn.sh
+ insinto /etc/acpi/events
+ newins "${FILESDIR}"/${PN}-1.0.4-default default
+
+ newinitd "${FILESDIR}"/${PN}-2.0.26-init.d ${PN}
+ newconfd "${FILESDIR}"/${PN}-2.0.16-conf.d ${PN}
+
+ systemd_dounit "${FILESDIR}"/systemd/${PN}.{service,socket}
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog
+ elog "You may wish to read the Gentoo Linux Power Management Guide,"
+ elog "which can be found online at:"
+ elog "https://wiki.gentoo.org/wiki/Power_management/Guide"
+ elog
+ fi
+
+ # files/systemd/acpid.socket -> ListenStream=/run/acpid.socket
+ mkdir -p "${ROOT%/}"/run
+
+ if ! grep -qs "^tmpfs.*/run " "${ROOT%/}"/proc/mounts ; then
+ echo
+ ewarn "You should reboot the system now to get /run mounted with tmpfs!"
+ fi
+}