summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2024-01-27 09:54:48 +0000
committerYixun Lan <dlan@gentoo.org>2024-01-27 09:57:14 +0000
commit0ee0cd8fde178ceeaccc6ae76dfd06fc730408db (patch)
tree7dacd4c2f2bcba49fdd8852781033cebb40e3375 /sys-power
parentdev-python/aiocache: Fix test failure (diff)
downloadgentoo-0ee0cd8fde178ceeaccc6ae76dfd06fc730408db.tar.gz
gentoo-0ee0cd8fde178ceeaccc6ae76dfd06fc730408db.tar.bz2
gentoo-0ee0cd8fde178ceeaccc6ae76dfd06fc730408db.zip
sys-power/thermald: add 2.5.6
Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/thermald/Manifest1
-rw-r--r--sys-power/thermald/thermald-2.5.6.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/sys-power/thermald/Manifest b/sys-power/thermald/Manifest
index 45f423fb0acf..04fd6b2d9153 100644
--- a/sys-power/thermald/Manifest
+++ b/sys-power/thermald/Manifest
@@ -1,2 +1,3 @@
DIST thermald-2.5.4.tar.gz 179202 BLAKE2B 945466ee90e61b4c59105f6f0d5b011b9cad9a9613ec5ac1f9e8d2ec1d75bc21e1685e7c8f165f5f4f46736d0b862a149b1e1444500d64aa1429d97db85209ac SHA512 7e73e7860ca6df22862db5fad1d8ab75361deac9cb3631da2950b02f366febd78a93c81afe93af396c9be2a809e8be8c764b0d3183b545e051f3ec7b9d9dd078
DIST thermald-2.5.5.tar.gz 182764 BLAKE2B 1d8c66e69c3c9d89a063a8ab8e9b8432afcfaf471cbf0f7a8e24d217c7449856de2a79c51fa2786deb6e8ed62f73a79489a1b66fc9655f36746e98a6924ae367 SHA512 74c5697ebb28b926076e375af5226e57864d6aacd2bf11fa31f2100a41d938f3fd6e5becc9cbfc8268b1456226f2e5815c93b7c55cb58e888669173d3101dc3d
+DIST thermald-2.5.6.tar.gz 182768 BLAKE2B cc6249d5e0a3b5961776ed9ac888d1468acbb2aad49f63f99bf6e3289227f786ab3cc11b6122e702ca67f898b6d6b25c4e58c2ba1ba4aad1a38e6b74eaaf950f SHA512 d039e4bd4ed203caf786c8090c27910b5b5f3886e8e4d160d6347bb2b8c1d6aaaca14958ee91ad4aedb02e67f8a6403805719bf07d55f03fe1f28f3e4378ae73
diff --git a/sys-power/thermald/thermald-2.5.6.ebuild b/sys-power/thermald/thermald-2.5.6.ebuild
new file mode 100644
index 000000000000..9abc5d8024c4
--- /dev/null
+++ b/sys-power/thermald/thermald-2.5.6.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools linux-info out-of-source systemd
+
+DESCRIPTION="Thermal daemon for Intel architectures"
+HOMEPAGE="https://github.com/intel/thermal_daemon"
+SRC_URI="https://github.com/intel/thermal_daemon/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-libs/dbus-glib:=
+ dev-libs/glib:=
+ dev-libs/libxml2:=
+ dev-libs/libevdev
+ sys-power/upower
+ sys-apps/dbus:="
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc
+ dev-util/glib-utils"
+
+S=${WORKDIR}/thermal_daemon-${PV}
+DOCS=( thermal_daemon_usage.txt README.txt )
+
+CONFIG_CHECK="~PERF_EVENTS_INTEL_RAPL ~X86_INTEL_PSTATE ~INTEL_POWERCLAMP ~INT340X_THERMAL ~ACPI_THERMAL_REL ~INT3406_THERMAL"
+
+src_prepare() {
+ sed -i -e '/tdrundir/s@\$localstatedir/run@\$runstatedir@' \
+ configure.ac || die
+
+ sed -i -e 's@\$(AM_V_GEN) glib-compile-resources@cd \$(top_srcdir) \&\& &@' \
+ Makefile.am || die
+
+ default
+ eautoreconf
+}
+
+my_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --disable-werror \
+ --runstatedir="${EPREFIX}"/run \
+ --with-dbus-power-group=wheel \
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+}
+
+my_src_install_all() {
+ einstalldocs
+
+ rm -rf "${ED}"/etc/init || die
+ doinitd "${FILESDIR}"/thermald
+}