summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2019-10-16 21:36:20 +0800
committerYixun Lan <dlan@gentoo.org>2019-10-16 21:36:20 +0800
commit13e11db1a217b48129659de7bc0c4427358f2eb3 (patch)
treec22f33969b386da94d119abd2c3f4af1b398d40f /sys-power
parentnet-voip/telepathy-haze: add dev-python/pygobject:2 to test deps (diff)
downloadgentoo-13e11db1a217b48129659de7bc0c4427358f2eb3.tar.gz
gentoo-13e11db1a217b48129659de7bc0c4427358f2eb3.tar.bz2
gentoo-13e11db1a217b48129659de7bc0c4427358f2eb3.zip
sys-power/thermald: version bump, 1.9
Closes: https://bugs.gentoo.org/697770 Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/thermald/Manifest1
-rw-r--r--sys-power/thermald/thermald-1.9.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/sys-power/thermald/Manifest b/sys-power/thermald/Manifest
index 3a395068f565..ca15004565e1 100644
--- a/sys-power/thermald/Manifest
+++ b/sys-power/thermald/Manifest
@@ -1,2 +1,3 @@
DIST thermald-1.7.1.tar.gz 420725 BLAKE2B 99e176e978e56d453fe5ff409f048122d18b9c554ed3128dac1c704a61ab483ab3ca21c2c360d1dc763de9770f877948d62d8c2216072d23fa1b828913a8e766 SHA512 a78f8aa9ef0f3e3b57fc1ebbd7ad7e67985676ad7adf5b6a6d23e4aed4e2ccb8273fb67ccd9a2133f91f7f6b19f793c9ba68e41208aabde4248ca666061fe5e0
DIST thermald-1.8.tar.gz 422982 BLAKE2B 6970190182a6ebcd6b39fcd34d75221173e1bbbf32cb7c0009001cd2934cf18bbc524ec43d1e99dbf7a1a0bda53b0b2239c9e25e08c4cb9435bceb0a512c5e3b SHA512 2360cfad311a804d7609b9879c5a0db749e1813085093e535eaa948b6fa289c385b8e6762ab15270e2e19170a4f48e0b0d736ffff029651289ec23c8dfc61743
+DIST thermald-1.9.tar.gz 427380 BLAKE2B 1954531838c0fc3677ab8f91476d5670a6b5d067d580c7c570b37e5d8d8ac408cacb218531bc8363cfd56eee9331291959ff11851550c6c782a43b19bacca01a SHA512 71fa6e9fc2f55623ed0acdb65f9699d5ea2c89c4092546a73d53ac3ea3ca0a5c60f3360c8bef0af9daeeecfe9a20411d9e4d25bc1d89349cfe83ebb03ba387a8
diff --git a/sys-power/thermald/thermald-1.9.ebuild b/sys-power/thermald/thermald-1.9.ebuild
new file mode 100644
index 000000000000..33bfe3ff73b1
--- /dev/null
+++ b/sys-power/thermald/thermald-1.9.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic out-of-source systemd
+
+DESCRIPTION="Thermal daemon for Intel architectures"
+HOMEPAGE="https://01.org/linux-thermal-daemon"
+SRC_URI="https://github.com/01org/thermal_daemon/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/dbus-glib:=
+ dev-libs/glib:=
+ dev-libs/libxml2:=
+ sys-apps/dbus:="
+DEPEND="${RDEPEND}
+ dev-util/glib-utils"
+
+S=${WORKDIR}/thermal_daemon-${PV}
+DOCS=( thermal_daemon_usage.txt README.txt )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+my_src_configure() {
+ # bug 618948
+ append-cxxflags -std=c++14
+
+ ECONF_SOURCE="${S}" econf \
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+}
+
+my_src_install_all() {
+ einstalldocs
+
+ rm -rf "${ED%/}"/etc/init || die
+ doinitd "${FILESDIR}"/thermald
+}